Jump to content

Agregar dispositivo MIDI en Mountain Lion (Solucionado)

- - - - -

  • Please log in to reply
8 replies to this topic

#1
franmglp

franmglp

    InsanelyMac Protégé

  • Members
  • PipPip
  • 97 posts
  • Gender:Male
  • Location:Argentina

Hola gente, tengo un problema agregando dispositivos MIDI por USB en Mountain Lion. Tengo un Akai MPD18 y un M-Audio Axiom 49, ambos se conectan a la PC por USB. El problema es que los conecto y en Mountain Lion los detecta en la lista de dispositivos USB de Informe del Sistema como se ve en la captura pero no sé como hacer para que los agregue como dispositivos MIDI en Configuración de Audio MIDI.

Acá se ve que el dispositivo es reconocido por OS X:

5loHb.jpg

Y acá se ve como a pesar de estar conectado el dispositivo y siendo reconocido por OS X no aparece en la lista de puertos del secuenciador que uso:

Owc2A.jpg



#2
juanerson

juanerson

    InsanelyMac Legend

  • Local Moderators
  • 1,409 posts
  • Gender:Male
  • Location:Tru, Venezuela
Hola hermano, bien... el detalle es que "reconocido o detectado" NO significa "instalado". Es decir, que existan drivers nativos es lo importante acá, es lo primordial en la elección de cualquier hardware. Entonces, te pregunto: según tu búsqueda preliminar sobre "compatibilidad" tu dispositivo de audio USB tiene soporte en OS X?

#3
franmglp

franmglp

    InsanelyMac Protégé

  • Members
  • PipPip
  • 97 posts
  • Gender:Male
  • Location:Argentina
Por ejemplo el teclado M-Audio Axiom 49 que tengo tiene soporte nativo, varias veces lo usé en Snow Leopard sin problemas y en Mountain Lion al introducir el CD de drivers dice lo siguiente: "There is no driver to install or uninstall. This product is supported by drivers built into Mac OS X.", por lo que entiendo que tiene soporte nativo.

#4
juanerson

juanerson

    InsanelyMac Legend

  • Local Moderators
  • 1,409 posts
  • Gender:Male
  • Location:Tru, Venezuela
En la página web del fabricante del dispositivo has investigado si hay alguna actualización de controladores para ML 10.8, que es exclusivo de 64 bits?

#5
franmglp

franmglp

    InsanelyMac Protégé

  • Members
  • PipPip
  • 97 posts
  • Gender:Male
  • Location:Argentina
Según estuve mirando en la web del fabricante hay controladores hasta la versión 10.7.4 de Lion.

#6
juanerson

juanerson

    InsanelyMac Legend

  • Local Moderators
  • 1,409 posts
  • Gender:Male
  • Location:Tru, Venezuela
Ese te debe servir, te recomiendo que lo descargues e instales, no te dará problemas porque Lion también es de 64 bits y 32 bits.

Otra cosa, lo tienes instalado a través de un HUB (multiplicador de puerto)?

#7
franmglp

franmglp

    InsanelyMac Protégé

  • Members
  • PipPip
  • 97 posts
  • Gender:Male
  • Location:Argentina
No, no lo tengo instalado a través de un HUB y en cuanto al driver, en la web del fabricante hay un driver que dice hasta 10.7.4 pero no deja descargarlo y dice "This device is class compliant and does not require driver support for OS X."

#8
franmglp

franmglp

    InsanelyMac Protégé

  • Members
  • PipPip
  • 97 posts
  • Gender:Male
  • Location:Argentina
Bueno, después de luchar y luchar con Mountain Lion para poder conectar mis dispositivos MIDI decidí pasarme a Lion. Instalé la versión 10.7.4 y todo perfecto, voy a Utilidades > Configuración de Audio MIDI > Estudio MIDI y en la ventana Estudio MIDI al conectar los dispositivos estos aparecen inmediatamente. Al parecer Mountain Lion da problemas con los dispositivos MIDI, si en una futura actualización se mejora la compatibilidad voy a volver a instalar Mountain Lion, por el momento me quedo con Lion ya que el hackintosh lo quiero justamente para trabajar con audio.

Muchas gracias juanerson por la ayuda.

#9
franmglp

franmglp

    InsanelyMac Protégé

  • Members
  • PipPip
  • 97 posts
  • Gender:Male
  • Location:Argentina
A pesar de tener los dispositivos MIDI funcionando en Lion 10.7.5, no me convencía por completo usar esta versión ya que al tener plataforma Ivy Bridge, Lion no es 100% compatible. Además en varios foros leí que estos dispositivos tienen soporte nativo incluso en Mountain Lion. Por eso instalé nuevamente Mountain Lion 10.8.2 y logré hacerlos funcionar!

No entiendo porqué antes no me funcionaron pero se me ocurre que pudo haber sido un problema con mis puertos USB... en la instalación anterior de Mountain Lion estaba cargando un IOUSBFamily.kext antiguo que me bloqueaba los puertos USB 3.0, ahora en la nueva instalación me di cuenta de esto y lo borré dejando solo el IOUSBFamily.kext nativo de Mountain Lion aunque no estoy totalmente seguro de que haya sido este el problema.

Les dejo unas capturas, saludos.

Posted Image

Posted Image





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy