Jump to content

AMD dual graphics 6950 supported


  • Please log in to reply
94 replies to this topic

#61
manor

manor

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 311 posts
  • Gender:Male
Anybody work 6950 in 10.8.3 sent screen images ple

#62
manor

manor

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 311 posts
  • Gender:Male
my xfx 6950 worked sleep mode with SleepEnabler.kext and patched AppleIntelCPUPowerManagement.kext from multibest remove nullcpupowerma

#63
manor

manor

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 311 posts
  • Gender:Male

still not clear screen

Attached Files



#64
vanja_bj

vanja_bj

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Hi all.
Can somebody help me in further steps to enable hardware acceleration?
I am currently booting with my integrated card set as primary (bios setup IGFX). For installation from usb I deleted everything that has ati or amd inside the name. Installation went well and I have full hd picture. Then I installed kexts I found here named as 10.8 final. It seems like this helped in the partial 6950 card recognition.
Now when I go in the menu "About This Mac" i have for graphics -Display 64 MB of Shared Mem.., and in system report the next:


575]AMD Radeon HD 6xxx:


575] Chipset Model: AMD Radeon HD 6xxx

575] Type: GPU

575] Bus: PCIe

575] PCIe Lane Width: x16

575] VRAM (Total): 2048 MB

575] Vendor: ATI (0x1002)

575] Device ID: 0x6719

575] Revision ID: 0x0000

my pc: asus maximus 4 gene-z, core i5 2500k, vtx 6950 2GB

Display:


Type: GPU

Bus: Built-In

VRAM (Total): 64 MB of Shared System Memory

Vendor: Intel (0x8086)

Device ID: 0x0112

Revision ID: 0x0009

Kernel Extension Info: No Kext Loaded

Displays:

Display:
Resolution: 1920 x 1080
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes


#65
figarotheall

figarotheall

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
I'm Italian...news for the installation of ML 10.8.2 with only graphic card with Hardware acceleration?? thanks!

#66
manor

manor

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 311 posts
  • Gender:Male
Good news any step by step gude for 10.8.2/10.8.3 with acc

#67
JustFortehFun

JustFortehFun

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
So far a few people reported the following procedure:

1) Get the official installer (InstallESD.dmg) for 10.8.2
2) Get a 8GB flash / hard drive
3) Get a VM if you don't have access to a Mac
4) Download myHack and from the menu select "Create Installer for 10.8"
5) Select your path to the InstallESD.dmg file and select your target device.
6) Wait
7) When everything finishes enter the following command in your terminal:

sudo mv /Volumes/myHack\ OS\ X\ Install\ Disk/System/Library/Extensions/ATI6000Controller.kext /Volumes/myHack\ OS\ X\ Install\ Disk/Extra/RemovedExtensions/

* This will move the ATI6000Controller.kext, so you can boot the installer

8) Open the myHack.app once again, select Fix Utility and point to the drive where you created the installer (the default is: "myHack OS X Install Disk")
9) Reboot and boot into your flash/hard drive
10) When you see the countdown - interrupt it (press any key)
11) enter the command "GraphicsEnabler=No -v" and press Enter
12) Install
13) Reboot again, boot your flash / hard drive and select the partition where you installed OS X, enter

"GraphicsEnabler=No -v"

and press Enter

14) You should now be in your OS X Desktop
15) The following commands will copy the kext you will modify back to /Extra/RemovedExtensions so if you screw you'll be able to restore them back

sudo cp -R /Volumes/myHack\ OS\ X\ Install\ Disk/Extra/RemovedExtensions/ATI6000Controller.kext /Extra/RemovedExtensions/
sudo mv -R /System/Library/Extensions/AMDRadeonAccelerator.kext /Extra/RemovedExtensions/
sudo mv -R /System/Library/Extensions/AppleGraphicsPowerManagement.kext /Extra/RemovedExtensions/

16) Copy OlegTr's kext to /System/Library/Extensions:

First cd into the dir where you downloaded the patched kext's and enter the following commands:

sudo cp -R ATI6000Controller.kext /System/Library/Extensions/
sudo cp -R AMDRadeonAccelerator.kext /System/Library/Extensions/
sudo cp -R AppleGraphicsPowerManagement.kext /System/Library/Extensions/

17) Open the myHack.app on your install drive, open it, select "Fix Utility" and select your system drive ("/")
18) Open System Settings -> Users and Groups and click Login items tab
19) Drag and drop the FBRotate.app to your login items
20) Reboot
21) Boot from your install drive and this time just select the partition where you installed OS X
22) IF you're lucky you should boot to your desktop.

Couple of things:

- Few people said it worked for them, but for me it just turns from White to Grey screen. Might be hit&miss situation
- Cold boot bug is present
- There's difference between myHack OS X Install Disk and the partition where you install your OS X so make sure you're selecting the correct one when you're presented with the 5 sec timeout in the bootloader.
- Copy FBRotate.app and the modified kexts to the USB drive, cause there's a big chance your networking won't be working right away


Links:
myHack
HD6950 Oleg_Tr's modified Kext's (Attachment in post #196)
FBrotate.app (Homepage if you're interested)

#68
manor

manor

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 311 posts
  • Gender:Male
Thanks man.very-nice guide I will try and report

#69
figarotheall

figarotheall

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
I followed that guide but I have Gray screen...why?!

#70
manor

manor

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 311 posts
  • Gender:Male
Enter reset buttion clear cold boot

#71
0o0

0o0

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
so no acceleration in 10.8.3? but works with 10.8.2?
thanks.

#72
figarotheall

figarotheall

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male

Enter reset buttion clear cold boot


When I press power button in the grey screen (without cursor...only grey screen)nothing happens....If I restarts the system, the same thing happens: white screen that changes into grey screen (my info monitor says that resolution is 1920x1080) and nothing....thanks for help!

#73
0o0

0o0

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
gray scree no cursor = kext not loaded right. simply put it. do -v and GraphicsEnabler=Yes and see what u get. remember u may not be able to boot 6950 on its own until the kext are loaded properly. try to load with ur built in and swap once ur at desktop. however for this u need to make sure 6950 is loaded and detected in profiler. Also Remove AMDaccelerator kext. doesnt work in 10.8.3. im having same issues. trying .2 now hopefully it works as some are claiming.

#74
figarotheall

figarotheall

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male

gray scree no cursor = kext not loaded right. simply put it. do -v and GraphicsEnabler=Yes and see what u get. remember u may not be able to boot 6950 on its own until the kext are loaded properly. try to load with ur built in and swap once ur at desktop. however for this u need to make sure 6950 is loaded and detected in profiler. Also Remove AMDaccelerator kext. doesnt work in 10.8.3. im having same issues. trying .2 now hopefully it works as some are claiming.


I followed the guide using the modified oleg's kext...why the kext aren't loaded properly?? And now I cannot go to the desktop because of gray screen...
P.S. I has white screen that changes into gray screen if I sets in boot -v and GraphicsEnabler=Yes.

thanks!

#75
elidoe89

elidoe89

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
it works fine for me, except for cold boot and green screen in photoshop and heaven unigine benchmark.

#76
figarotheall

figarotheall

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male

AMD dual graphics 6950 supported
Hi ALL
all credit goes to Netkas/Andy/chameleon team Ermac
This 7 kexts support 6950/6970 to mac osx 10.7.x and 10.8
just install via kext wizard.
before install delete Amdraden kexts.
AMDRadeonAccelerator.kext
After install kexts set GraphicsEnabler=Yes.
MY dual cards works v.well. more info look my ioreg files.
Allso windows7 supported crossfire
All but 2 monitors must be connected to the DP ports on the AMD graphics card, and be able to
support the required resolution. The 2 exceptions can be connected to the DVI or HDMI ports.
The monitors connected to the DP ports can be connected with DP cables, or using AMDrecommended
active adapters to DVI or HDMI ports on the monitors.
Where multiple graphics adapters are installed, Eyefinity groups cannot span across multiple
adapters. With cross-fire enabled, only monitors connected to the primary card will be enabled.
NOTE-10.8 dp4 this kexts not 100%support.

http://www.mediafire...yg175ou2sqt52z3


Hi, I has installed yours 7 kext and ML 10.8.2 goes well (1080p) but without hardware acceleration. So I has installed the other 3 oleg's kext but I has gray screen without cursor...How can I enable hardware acceleration??
thanks a lot!

#77
0o0

0o0

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
if you are working with 10.8.2 and trying to get acceleration you will need DSDT edit. there is a DSDT snippet with that kext also.

#78
figarotheall

figarotheall

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
I can't edit DSDT...I don't know how does it! :wallbash: thanks for help!

P.S. You finally have ML 10.8.2 with hardware acceleration? is from August I try unsuccessfully!

#79
dmrkillah

dmrkillah

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

it works fine for me, except for cold boot and green screen in photoshop and heaven unigine benchmark.


same as me, have you tried aty_init kext for cold boot bug?

also has anyone got 10.8.3 working with acceleration?

#80
figarotheall

figarotheall

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
Only for me, ati modified's kext don't work correctly??? I has all ok (sound, ethernet, resolution 1080p)but I don't have hardware acceleration with manor's kext or oleg's kext....





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy