Jump to content

[Guide] Getting XFX HD6950 connectors to work


  • Please log in to reply
4 replies to this topic

#1
manor

manor

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 319 posts
  • Gender:Male
[Guide] Getting XFX HD6950 connectors to work
UPDATE: redsock's bios decoder to get the encoder and link information directly from the bios.

I've finally got a new XFX HD6950 connectors info.
$ redsock_bios_decoder< your rom file (The best should get from GPU-Z.)

CAYMAN PRO Hill GDDR5 BIOS

Subsystem Vendor ID: 1682
Subsystem ID: 3122
Object Header Structure Size: 436
Connector Object Table Offset: 52
Router Object Table Offset: 0
Encoder Object Table Offset: 145
Display Path Table Offset: 12
Connector Object Id [19] which is [DISPLAY_PORT]
encoder obj id [0x21] which is [INTERNAL_UNIPHY2 (osx txmit 0x12 [duallink 0x2] enc 0x4)] linkb: false
Connector Object Id [19] which is [DISPLAY_PORT]
encoder obj id [0x21] which is [INTERNAL_UNIPHY2 (osx txmit 0x22 [duallink 0x2] enc 0x5)] linkb: true
Connector Object Id [12] which is [HDMI_TYPE_A]
encoder obj id [0x20] which is [INTERNAL_UNIPHY1 (osx txmit 0x11 [duallink 0x1] enc 0x2)] linkb: false
Connector Object Id [3] which is [DVI_D]
encoder obj id [0x20] which is [INTERNAL_UNIPHY1 (osx txmit 0x11 [duallink 0x1] enc 0x2)] linkb: false
Connector Object Id [2] which is [DVI_I]
encoder obj id [0x1e] which is [INTERNAL_UNIPHY (osx txmit 0x10 [duallink 0x0] enc 0x0)] linkb: false
Connector Object Id [2] which is [DVI_I]
encoder obj id [0x15] which is [INTERNAL_KLDSCP_DAC1 (osx txmit 0x00 enc 0x10?)] linkb: false


I sill trying to get radeon_bios_decode not found


$ radeon_bios_decode < your rom file (The best should get from GPU-Z.)

Personality: Gibba
ConnectorInfo count in decimal: 5
Disk offset in decimal 501084
0000000 00 04 00 00 04 03 00 00 00 01 00 00 12 04 05 01
0000010 00 04 00 00 04 03 00 00 00 01 00 00 22 05 04 02
0000020 00 08 00 00 04 02 00 00 00 01 00 00 11 02 06 04
0000030 00 02 00 00 04 02 00 00 00 01 00 00 00 00 03 05
0000040 04 00 00 00 04 02 00 00 00 01 00 00 11 02 01 03
0000050

Attached Files



#2
manor

manor

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 319 posts
  • Gender:Male

My - Connector Type


Last login: Tue Jun 26 09:14:57 on ttys000
navaratnams-Mac-Pro-2:~ navaratnammanoranjan$ /Users/navaratnammanoranjan/Desktop/VBIOS/redsock_bios_decoder </Users/navaratnammanoranjan/Desktop/slot1/1002_6719.rom
695CNF80.BIN:

CAYMAN PRO Hill GDDR5 BIOS

Subsystem Vendor ID: 1682
Subsystem ID: 3122
Object Header Structure Size: 436
Connector Object Table Offset: 52
Router Object Table Offset: 0
Encoder Object Table Offset: 145
Display Path Table Offset: 12
Connector Object Id [19] which is [DISPLAY_PORT]
encoder obj id [0x21] which is [INTERNAL_UNIPHY2 (osx txmit 0x12 [duallink 0x2] enc 0x4)] linkb: false
Connector Object Id [19] which is [DISPLAY_PORT]
encoder obj id [0x21] which is [INTERNAL_UNIPHY2 (osx txmit 0x22 [duallink 0x2] enc 0x5)] linkb: true
Connector Object Id [12] which is [HDMI_TYPE_A]
encoder obj id [0x20] which is [INTERNAL_UNIPHY1 (osx txmit 0x11 [duallink 0x1] enc 0x2)] linkb: false
Connector Object Id [3] which is [DVI_D]
encoder obj id [0x20] which is [INTERNAL_UNIPHY1 (osx txmit 0x11 [duallink 0x1] enc 0x2)] linkb: false
Connector Object Id [2] which is [DVI_I]
encoder obj id [0x1e] which is [INTERNAL_UNIPHY (osx txmit 0x10 [duallink 0x0] enc 0x0)] linkb: false
Connector Object Id [2] which is [DVI_I]
encoder obj id [0x15] which is [INTERNAL_KLDSCP_DAC1 (osx txmit 0x00 enc 0x10?)] linkb: false
navaratnams-Mac-Pro-2:~ navaratnammanoranjan$
------------------------------------
Last login: Sat Jun 30 18:33:56 on ttys000
navaratnams-Mac-Pro-2:~ navaratnammanoranjan$ /Users/navaratnammanoranjan/Desktop/xfx6950\ files1/radeon_bios_decode </Users/navaratnammanoranjan/Desktop/xfx6950\ files1/1002_6719.rom
ATOM BIOS Rom:
SubsystemVendorID: 0x1682 SubsystemID: 0x3122
IOBaseAddress: 0x0000
Filename: 695CNF80.BIN
BIOS Bootup Message:
CAYMAN PRO Hill GDDR5 BIOS

PCI ID: 1002:6719
Connector at index 0
Type [@offset 44199]: DisplayPort (10)
Encoder [@offset 44203]: INTERNAL_UNIPHY2 (0x21)
i2cid [@offset 44335]: 0x90, OSX senseid: 0x1
Connector at index 1
Type [@offset 44209]: DisplayPort (10)
Encoder [@offset 44213]: INTERNAL_UNIPHY2 (0x21)
i2cid [@offset 44362]: 0x91, OSX senseid: 0x2
Connector at index 2
Type [@offset 44219]: HDMI-A (11)
Encoder [@offset 44223]: INTERNAL_UNIPHY1 (0x20)
i2cid [@offset 44389]: 0x93, OSX senseid: 0x4
Connector at index 3
Type [@offset 44229]: DVI-D (3)
Encoder [@offset 44233]: INTERNAL_UNIPHY1 (0x20)
i2cid [@offset 44416]: 0x92, OSX senseid: 0x3
Connector at index 4
Type [@offset 44239]: DVI-I (2)
Encoder [@offset 44243]: INTERNAL_UNIPHY (0x1e)
i2cid [@offset 44453]: 0x94, OSX senseid: 0x5
Connector at index 5
Type [@offset 44249]: DVI-I (2)
Encoder [@offset 44253]: INTERNAL_KLDSCP_DAC1 (0x15)
i2cid [@offset 44453]: 0x94, OSX senseid: 0x5
navaratnams-Mac-Pro-2:~ navaratnammanoranjan$


ATY,Gibba@[DISPLAY_PORT]

Connector Object Id [19] which is [DISPLAY_PORT]
Connector Type Number 0x400
@0,connector-type string 0x00000400
ATY,ControlFlags Number 0x304
0 × 00000304
encoder obj id [0x21] which is [INTERNAL_UNIPHY2
HotplugID
port-number 0x1
encoder obj id [0x21] which is [INTERNAL_UNIPHY2 (osx txmit 0x12 [duallink 0x2] enc 0x4)] linkb: false
i2cid [@offset 44335]: 0x90, OSX senseid: 0x1


ATY,Gibba@ [DVI_I] top

Connector Object Id [2] which is [DVI_I] top
Connector Type Number 0x200
@1,connector-type string 0x00000200
ATY,ControlFlags Number 0x214
encoder obj id [0x1e] which is [INTERNAL_UNIPHY
port-number 0x3
encoder obj id [0x1e] which is [INTERNAL_UNIPHY (osx txmit 0x10 [duallink 0x0] enc 0x0)] linkb: false
i2cid [@offset 44453]: 0x94, OSX senseid: 0x5

ATY,Gibba@[DISPLAY_PORT]

Connector Object Id [19] which is [DISPLAY_PORT]
Connector Type Number 0x400
@2,connector-type string 0x00000400
ATY,ControlFlags Number 0x304
encoder obj id [0x21] which is [INTERNAL_UNIPHY2
port-number 0x0
encoder obj id [0x21] which is [INTERNAL_UNIPHY2 (osx txmit 0x22 [duallink 0x2] enc 0x5)] linkb: true
i2cid [@offset 44362]: 0x91, OSX senseid: 0x2

ATY,Gibba@[HDMI_TYPE_A]

Connector Object Id [12] which is [HDMI_TYPE_A]
Connector Type Number 0x800
@3,connector-type string 0x00000800
ATY,ControlFlags Number 0x204
encoder obj id [0x20] which is [INTERNAL_UNIPHY1
port-number 0x2
encoder obj id [0x20] which is [INTERNAL_UNIPHY1 (osx txmit 0x11 [duallink 0x1] enc 0x2)] linkb: false
i2cid [@offset 44389]: 0x93, OSX senseid: 0x4


ATY,Gibba@[DVI_D] Bottom

Connector Object Id [3] which is [DVI_D] Bottom
Connector Type Number 0x4
@4,connector-type string 0x00000004
ATY,ControlFlags Number 0x204
encoder obj id [0x20] which is [INTERNAL_UNIPHY1
port-number 0x4
encoder obj id [0x20] which is [INTERNAL_UNIPHY1 (osx txmit 0x11 [duallink 0x1] enc 0x2)] linkb: false
i2cid [@offset 44416]: 0x92, OSX senseid: 0x3


from

Personality: Gibba
ConnectorInfo count in decimal: 5
Disk offset in decimal 182512
0000000 00 04 00 00 04 03 00 00 00 01 00 00 12 04 05 01
0000010 00 04 00 00 04 03 00 00 00 01 00 00 22 05 04 02
0000020 00 08 00 00 04 02 00 00 00 01 00 00 11 02 06 04
0000030 00 02 00 00 14 02 00 00 00 01 00 00 00 00 03 05
0000040 04 00 00 00 04 02 00 00 00 01 00 00 11 02 01 03
0000050

to

Personality: Gibba
ConnectorInfo count in decimal: 5
Disk offset in decimal 182512
0000000 00 04 00 00 04 03 00 00 00 01 00 00 12 04 04 01 ---- DP 1
0000010 00 04 00 00 04 03 00 00 00 01 00 00 22 05 05 02 ---- DP 2
0000020 00 08 00 00 04 02 00 00 00 01 00 00 11 02 06 04 ---- HDMI
0000030 00 02 00 00 14 02 00 00 00 01 00 00 00 00 03 05 ---- DVI 1---ATY,Gibba@ [DVI_I] top
0000040 04 00 00 00 04 02 00 00 00 01 00 00 11 02 01 03 ---- DVI 2---ATY,Gibba@[DVI_D] Bottom
0000050

Hi Guys Edited kexts Latest ple uploded Thankyou.

#3
Phathak

Phathak

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
  • Gender:Male
Hi!

I have a XFX 6950 2GB right here and I want to make it fully compatible with my Hackintosh 10.8.2. Now, I don't know if that post was made either for Mac Pros compatibility or Hackintoshes. The title of this topic seems to be very optimistic about making it work so I was wondering if you had made a simple guide that we could follow. I downloaded the xfx6950 files1.zip file but really don't know what to do with it. I would greatly appreciate some help on this. I've been following other posts to the letter and I know it can be done, but really don't know where to start...

My rig :
Gigabyte X79-UD5
Intel 3930k
16gb Corsair Vengeance
XFX 6950 2GB

Thanks for your help!

#4
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 2,031 posts
  • Gender:Male
Can you post a IOreg.

#5
Phathak

Phathak

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
  • Gender:Male
I'm trying to get to my desktop right now but when I boot it reaches the desktop, shows me the status bar but freezes there. I tried booting with GenerateCState=Yes GraphicsEnabler=No but it still does it. Don't know what to do next...





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy