Jump to content

[RISOLTO] wifi, fruscio audio, soventi kernel panic con snow leopard 10.6.7

AIUTO risolto

  • Please log in to reply
16 replies to this topic

#1
nicomario

nicomario

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
Buon giorno questo è il mio primo post, spero di non aver sbagliato sezione o qualcosa
Ho installato seguendo la guida di Fwood, la retail di snow leopard con il preboot empire efi usando myhack come boot e aggiornando alla 10.6.7
Al riavvio ho pasticciato un po con i kext per l'audio alc888 hd dopo un paio di tentativi ho usato VoodooHDA-2.7.2.pkg funziona ma ha un leggero rumore di fondo con il volume dal 50% in su ( i collegamenti scheda altoparlanti sono ok )
Passiamo ai problemi :angel_not:
1 la wifi (mini pci) non funziona, l'utility airport non la rileva. potrei anche cambiarla ma non saprei quale è la più indicata per snow
2 spesso alla prima accensione mi compare la schermata nera con scritto nelle varie lingue di riavviare,
al riavvio facendo -v (oggi ho addirittura riavviato normalmente) tutto fila liscio.
kernel extension in backtrace (with dipendencies)
org.voodoo.driver .voodoohda(2.7.2)
dependency: com.apple.iolkit.I0audiofamily
dependency: com.apple.iolkit.I0pcifamily
dependency: com.apple.iolkit. I0audiofamily
dependency: com.apple.kext.osvkerndsplib
3 con itunes se attivo schermo intero, invece se avvio front row esce la schermata che mi dice di riavviare.
4 non so come può esser successo (penso dopo l'aggiornamento a 10.6.7) al posto della mela in informazioni su questo mac ho un'altro logo. Si può riavere la mela?

Un ringraziamento anticipato a tutti
Mario

#2
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,534 posts
  • Gender:Male
  • Location:Italy
Per evitare il kernel panic puoi cancellare dalla cartella Sistema/Libreria/Extensions AppleHDA.kext, oppure se vuoi fare una cosa più raffinata, puoi usare un disabler per l'AppleHDA http://www.insanelym...howtopic=216750
Per evitare il rumore di fondo puoi consultare questa guida http://www.insanelym...howtopic=267905
Per la wifi, riporta il nome della scheda e il chip che monta.
Il problema numero 3 potrebbe essere collegato appunto al Voodoohda.
Un altro logo? ..Puoi personalizzarlo cambiando tema nella cartella Extra/Themes ...ti riporto un paio di link dove spulciare:

http://www.insanelym...howtopic=159974
http://forum.voodoop...x.php?board=7.0

se vuoi quello ufficiale te lo allego io ;)

Attached File  Default.zip   1.11MB   16 downloads


Ciao :)

#3
nicomario

nicomario

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
grazie per avermi risposto.
il kernel panic all'avvio (incrociamo le dita) dovresti averlo risolto. ho usato il disabler perchè il applehda.kext non l'ho trovato.
il rumore (fruscio) invece non sono riuscito a toglierlo nonostante che abbia modificato il formato.
per la wifi il modello è intel wm382915abg il chip dovrebbe essere 82533mde ti allego lo screenshot del
system info
il problema 3 rimane appena attivo lo schermo intero con itunes va in kernel panic
Per il logo probabilmente mi sono espresso male, io vorrei cambiare quello che si vede quando si apre
informazioni su questo mac

buona serata
mario

Attached Files


Edited by nicomario, 23 June 2012 - 11:41 PM.


#4
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,534 posts
  • Gender:Male
  • Location:Italy
Dopo aver installato il disabler hai ricostruito la kernel cache?
La scheda wifi non è compatibile.

Per l'audio potresti provare patchando l'appleHDa invece di usare il voodoohda.

#5
nicomario

nicomario

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
eccomi sono rientrato adesso
il disabler era un kext che ho installato con kext wizard e poi ho ricostruito con kext utilty
per la wifi potrei usare la wm3a2200bg, ho letto che forse è compatibile, ma ho paura di installare qualche kext
sbagliato e non saper più ripristinare il sistema (con tutto il tempo che ci ho messo per arrivare fin qui) :wallbash: quindi preferirei
un vostro consiglio
per l'audio ho risolto abbassando i volumi sia del mic che del line-in che quello del spdif nel configurazione midi audio
ricapitolando ci sarebbe da sistemare solo la wifi e il kernel panic che ho quando apro front row oppure seleziono schermo intero in itune
nello screenshot che avevo postato ho notato ci sono tre device con la faccina cosa vuol dire? altra domanda ma i kext che fanno funzionare il so sono quelli che si trovano in extra/extensions o quelli in sistema/libreria/extensions ?

grazie ancora per la pazienza e buona serata
mario

#6
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,534 posts
  • Gender:Male
  • Location:Italy
Per la wifi prendi AR5B91
Mi fai vedere il kernel panic che ti esce quanto apri itunes? Avvia in verbose mode prima di mandarlo in kernel panic ;)

#7
nicomario

nicomario

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
per la wifi ho installato IO80211family.kext con key wizard e poi key utility ma non mi vede lo stesso la scheda
il kenel panic l'ho fotografato non sapendo in che altra maniera fare spero che si legga qualcosa. a me sembra che sia
qualcosa collegato alla scheda video



grazie
mario

Attached Files



#8
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,534 posts
  • Gender:Male
  • Location:Italy
Sisi centra la scheda video, non ti so proprio aiutare :(

#9
nicomario

nicomario

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
ciao e buona domenica
potrei provare a togliere qualche kext visto che per la scheda video c'è ne più di uno, però piuttosto che fare cavolate preferisco lasciarlo così :wink2:
invece se riuscissi a far funzionare la wifi mi sarebbe utile perchè dove dovrei posizionare il minihack non ho il cavo eth. qualche consiglio?

mario

#10
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,534 posts
  • Gender:Male
  • Location:Italy
Devi sostituirla, le schede wifi Intel non funzionano.

#11
nicomario

nicomario

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
ciao non l'avevo capito.... purtroppo la AR5B91 non la posso montare il mio slot è un mini pci
sto provando con una ar5005g.....
dopo tre ore di :wallbash: ci sono riuscito, riporto qui quello che ho fatto
- ho scaricato il kext IO80211family.kext
- ho aperto il pacchetto IO80211family.kext
- ho aperto il pacchetto airportatheros21.kext
- aperto info.plist e modificato "pci168c,2a" in "pci168c,1a"
- riparato e ricostruito la cache
- aspettato un paio di minuti è in preferenze del sistema - network sulla sinistra mi è comparso AIRPORT :jester:
- infine ho configurato il mio network
- l'utility airport non rileva la wifi

naturalmente non è farina del mio sacco ma ci sono arrivato googlando in giro e con l'aiuto di buoo
grazie

mario

#12
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,534 posts
  • Gender:Male
  • Location:Italy
Ottimo lavoro!
Per la scheda video forse il problema è proprio dovuto a qualche kext sbagliato di troppo che hai installato.
Volendo la tua scheda potrebbe funziona anche seguendo un'altra strada, mi riferisco ad un'iniezione nel dsdt.
Spulcia un po' tra le guide ...chissà se aggiornando alla 10.6.8 risolvi

#13
nicomario

nicomario

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
ola grazie che faccio metto risolto ?
pensavo anch'io a qualche kext di troppo. che poi la mia scheda è una 950 e non una 945 come da system info.
iniezione nel dsdt mamma mia ho paura non saprei da che parte iniziare
figurati che avevo pensato anch'io ad un aggiornamento alla 10.6.8 ma non vorrei che si blocchi causa componenti non apple.
che dici :wink2:

#14
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,534 posts
  • Gender:Male
  • Location:Italy
Nessuno qui ha componenti apple xD
Chiaramente se decidi di aggiornare il sistema operativo un backup lo devi fare, altrimenti rischi di fare una frittata.

#15
nicomario

nicomario

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
okkappa ricevuto il messaggio per intanto metto risolto, dai alla fine funziona quasi al 100%
per l'aggiornamento non saprei ho letto nel forum di parecchie persone che hanno avuto dei kernel panic
piuttosto provo a eliminare qualche kext, che comunque se ricordo male ne avevo aggiunto uno solo e in ogni caso il problema l'avevo anche
prima.
mi prendo qualche giorno di pausa poi mi fare una bella immagine del disco e poi farò ancora qualche prova.....

buona serata

#16
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,534 posts
  • Gender:Male
  • Location:Italy
Buona serata a te :)

#17
nicomario

nicomario

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
rieccomi all'attacco dopo un paio di mesi di assenteismo.
come consigliatomi da voi mi son fatto un clone del mio hd con carbon copy, l'ho avviato in modalità usb
perché non avevo voglia di stare ad aprire il pc per cambiare disco
il sistema si è avviato normalmente, ho fatto subito l'aggiornamento alla 10 .6.8 sperando che il logo di hazard (motivo fondamentale dell'aggiornamento) in informazioni del computer sparisse. purtroppo non è stato così, inoltre dovendo risistemare un paio di kext (wifi e audio) ed essendo pigro ho spento tutto è ho riavviato dal mio hd con la versione 10.6.7.....

saluti a tutti
mario





Also tagged with one or more of these keywords: AIUTO, risolto

  Topic Stats Last Post Info

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy