Jump to content

10.8 DP3 and Nvidia drivers


  • Please log in to reply
4 replies to this topic

#1
jhrfc

jhrfc

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 145 posts
  • Gender:Male
  • Location:london uk
Hi,
I successfully installed DP1 on my machine (including full graphics support) using the guide

http://www.insanelym...howtopic=276024

but when i make an boot disk for DP3 the screen on my zotac gtx 285 goes black.

If i want to revert to DP1 nvidia drivers which kext files do i need to replace?
Anybody else had any problems with DP£ and nvidia cards?


Cheers
Jon

#2
su_inmortalidad2

su_inmortalidad2

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Hi!

I had the same. SOLVED !!!
But have You installed DP3? Have You succesfully run the installer?

I have 2 graphics cards on GA-Z68X-UD3-B3. I use custom device-properties for that.
Yhe installer have run succesfully because there is not GeForceGLDriver.kext and the others with GeForce begining. So I have installed. Used FakeSMC and NullCPUPowerManagment (must be in System/Extensions for me, dont know why, in Lion works normally in /Extra/Extensions, but in Mountain Lion not).
When I tried to run 10.8, graphics blinked, gone white and kernel panic :)
So i tried with changing kexts GeForceXXXXXX.ket and NVXXXXX.kext with Lion kexts, and 10.8 DP1 kexts. Result: no graphics, still apple logo, no graphics blink!!! NOTHING huppend, it was worsed then kernel panic).

So I said, what the f***. And I tried to replace /System/Library/Frameworks/Quartz.framework and QuartzCore.framework with frameworks from 10.8 DP1. Repaired permissions, and WOW !!! SOLVED !!!!!!!!!! I had only kernel panic, when tried to use PhotoBoth. Someting is wrong i think, but I hope it was coused only by PhotoBoth and its f*** 'graphical special effects'.

Write... I will respond :):):) Now i write from my Mac OS X Mountain Lion Developer Preview 3 :)

#3
Sinadrin

Sinadrin

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
  • Gender:Male
Good night! could you please load the files to solve the problem of DP3? because i erase the build DP1 thinking that i was not going to use it! thank you very much!

#4
René_

René_

    InsanelyMac Protégé

  • Donators
  • 74 posts
  • Gender:Male
  • Location:Maassluis, Netherlands
I've had the same problem with my 8800GT, blacksreen when trying to install DP3. Because I didn't had this problem with DP1, I replaced the 3 following files: NVDAGF100Hal.kext, NVDANV50Hal.kext and NVDAResman.kext
Run myfix to repair permiss./caches and all went well.
Here are the files from DP1:
http://cl.ly/GDBS

I only need to modify the OS X install USB to get pass the black screen. After installing Mountain Lion DP3 everything was OK, no modification needed?

Even speedstep is working with "AppleIntelCpuPowerManagement.kext" from 10.7.3

Good luck and happy Hack :)

#5
jhrfc

jhrfc

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 145 posts
  • Gender:Male
  • Location:london uk
Yes i can get the install to work by using DP1 kexts, but running DP3 itself, both th eDP1 and DP3 kects give me a black screen unless I turn off graphics injection, (both boot loader and EFI string).
Is it worth trying an install with the DP1 quartz and quartz core frame works?
Cheers
Jon





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy