Jump to content

Problems with homebrew, can't install anything...

Cannot find appropriate C com

  • Please log in to reply
1 reply to this topic

#1
Yuri

Yuri

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Hi!

I just (after one week of hard trying) installed OSX 10.6.8 in my AMD.

Now I'm trying to install homebrew for rails development... I already have xCode from 10.6.7 dvd, installed ruby and rails..

But homebrew doesn't install anything..

I hit brew install mysql and the cmake installing part go wrong:


brew install mysql
==> Installing mysql dependency: cmake
==> Downloading http://www.cmake.org...ke-2.8.7.tar.gz
File already downloaded in /Users/yuriabrito/Library/Caches/Homebrew
==> ./bootstrap --prefix=/usr/local/Cellar/cmake/2.8.7 --system-libs --no-system
---------------------------------------------
CMake 2.8.7, Copyright 2000-2009 Kitware, Inc.
---------------------------------------------
Error when bootstrapping CMake:
Cannot find appropriate C compiler on this system.
Please specify one using environment variable CC.
See cmake_bootstrap.log for compilers attempted.

---------------------------------------------
Log of errors: /private/tmp/homebrew-cmake-2.8.7-wvF2/cmake-2.8.7/Bootstrap.cmk/cmake_bootstrap.log
---------------------------------------------
==> Exit Status: 6
http://github.com/mx...la/cmake.rb#L29
==> Environment
HOMEBREW_VERSION: 0.8.1
HEAD: (none)
HOMEBREW_PREFIX: /usr/local
HOMEBREW_CELLAR: /usr/local/Cellar
Hardware: quad-core 64-bit core
OS X: 10.6.8
Kernel Architecture: i386
Ruby: 1.8.7-249
/usr/bin/ruby => /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby
Xcode: 3.2.3
GCC-4.0: build 5494
GCC-4.2: build 5664
LLVM: build 2326
Clang: 1.5 build 60
MacPorts or Fink? false
X11 installed? true
==> Build Flags
CC: /usr/bin/gcc-4.2
CXX: /usr/bin/g++-4.2
LD: /usr/bin/gcc-4.2
CFLAGS: -O3 -w -pipe -march=prescott
CXXFLAGS: -O3 -w -pipe -march=prescott
MAKEFLAGS: -j4

Error: Failed executing: ./bootstrap --prefix=/usr/local/Cellar/cmake/2.8.7 --system-libs --no-system-libarchive --datadir=/share/cmake --docdir=/share/doc/cmake --mandir=/share/man
These existing issues may help you:
https://github.com/m...rew/issues/7293
https://github.com/m...rew/issues/9347
Otherwise, please report the bug:
https://github.com/m...ing-a-new-issue

I've searched everywhere and nothing =/ Pls help me.

#2
Yuri

Yuri

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Just solved my problem.

Turns out, we can't build x86_64 binaries with AMD (don't know about Intel cpus). Then, for use homebrew, you must edit the formulas for the programs you want to install.

As an example, lets suppose you want to install mysql:

brew edit mysql

search for def install and, right below, add:

ENV['CFLAGS']=ENV['CXXFLAGS']="-arch i386"

I guess this should work for every program.

PS: If anyone knows how to build x86_64 in AMD, pls post.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy