Jump to content

[Guide] iAtkos s3 v2 10.6.3 on Dell Studio 1747

- - - - - (iAtkos S3 v2 10.6.3)

  • Please log in to reply
1 reply to this topic

#1
tim2000

tim2000

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
  • Gender:Male
  • Location:Grenoble France
Hi, this tutorial is a translation from here , ly english is not perfect, but some people ask me to translate it.

Ati radeon hd 4650 is not working for the moment, i'm looking for some way to make it works.





Hi i'm posting this tutorial for all the people like me, who have been failed for months while trying to instal OSX on their Dell Studio 1747.

First, i want you to know that you have an ATI mobility radeon hd 4650, don't think it will be easy to make it work.

I've passed lot of time to search, and I will not detail exactly all manipulations, if you don't understand some basic things, use google.

If you are looking for make 10.5.2 on you're studio 1747, you should go on this topic, who help me a lot.
I'm gonna post here all the things who help me during this hack, and all the useful kexts I've found.

I'm not gonna detail how to install kext, again if you don't know anything about hackintosh, search it.

Whats work after this tutorial :
-keyboard
-Trackpad (2Finger Scroll active)
-Sound
-Battery indicator
-Wifi


Instalation and boot bug :


If when you're booting on you're DVD, a kernel panic appears and get this :

Posted Image
Posted Image

At the DVD boot, press F8, en boot with -x busratio=20 cpus=1
This allow you to lunch installation.

While installation, click on "personalize", for install the goods kexts. You have to install broadcom kext, chameleon v2 (I use rc4 but i think rc5 works too),and PS2 kexts.

The install should works fine, and Snow Leopard is now installed on your hard drive.
For lunch it without kernel panic, you have to boot with -x busratio=20 cpus=1 (again).

I've add this line in apple.com.Boot.plist : "Graphics Mode"="1280x1024x32" busratio=20 cpus=1
You have to remove ATIRadeonX2000.kext too.


My apple.com.Boot.plist is like that :

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>Kernel</key>
	<string>mach_kernel</string>
	<key>Kernel Flags</key>
	<string>"Graphics Mode"="1280x1024x32" busratio=20 cpus=1</string>
	<key>Hide Partition</key>
	<string>hd(0,1)</string>
	<key>Boot Graphics</key>
	<string>No</string>
		<key>Quiet Boot</key>
		<string>No</string>
		<key>Timeout</key>
		<string>5</string>
</dict>
</plist>


Mount inactive disk :


This hard drive problem is weird. But I've resolved it with this tutorial. My video card don't works, but my hard drives are back.

Kext et Fix :


Battery indicator :

I don't know if battery indicator kext in iAtkos works, so I give you mine.

[attachment=80105:VoodooBattery.kext.zip]


Sound

VoodooHDA package have works for me, you can found it here, only one headphone input works, but it's already very good.

Update 10.6.4 :

There is no problem with this update, but don't forget to remove ATIRadeonX2000.kext


Website and useful link :


http://www.insanelym...howtopic=136640
http://www.insanelym...howtopic=201836


http://www.darwinx86.net/
http://www.mac-on-pc.fr/
http://voodooprojects.org/
http://www.hackint0sh.org/





Posted Image

Posted Image

#2
dkash

dkash

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
thnx





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy