Jump to content

[Aiuto] ATI RADEON X-1950-Pro - NO QE/CI


  • Please log in to reply
25 replies to this topic

#1
emmetreo

emmetreo

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
  • Gender:Male
  • Location:Salerno
Buongiorno a tutti, finalmente posso scrivere nella sezione in italiano del forum.
Ho installato sul mio hardware che leggete in firma OS-X 10.6.1.
Il problema principale è relativo alla scheda video, ho installato il seguente kext
ATI RADEON X1950GT 10.6.5 & 10.6.6 : press load.command for install. no DSDT. 10.6.6 32
scaricato da kexts, ed ora al riavvio il video è quasi sempre funzionante, salvo qualche volta che rimane la schermata nera e devo riavviare.
Il video non è fluido, se apro immagini jpg il programma di preview mostra finestre nere, credo che non siano attivi il Quartz Exstreme e Core Image, chiedo il vostro cortese supporto.
Grazie a tutti

#2
mrmojorisin17

mrmojorisin17

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,942 posts
  • Gender:Male
Ma come fai ad installare un kexts per Snow 10.6.5 & 10.6.6 su una 10.6.1?
Dai un'occhiata qua.

#3
emmetreo

emmetreo

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
  • Gender:Male
  • Location:Salerno
Purtroppo non supporta le versioni GT e PRO ... e devo verificare meglio la versione OS-X installata, dove posso visualizzare l'informazione ?
Per rimuovere i driver attualmente installati quale procedura devo eseguire ?
Tnx ;)

#4
David23

David23

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,921 posts
  • Gender:Male
  • Location:Como
E il tag?!?!

#5
emmetreo

emmetreo

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
  • Gender:Male
  • Location:Salerno
Ho verificato la versione di OS installata ed è la 10.6 (10A432) DARWIN 10.0.0.
Inoltre nelle proprietà della scheda grafica non sono presenti nè la voce Quartz Extreme ne Core Image e la quantità di memoria indicata è da 512mb anziche 256mb effettivamente presenti sul componente.
@David23 a quale tag ti riferisci ?

#6
mrmojorisin17

mrmojorisin17

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,942 posts
  • Gender:Male
Per utilizzare i kexts da te citati nel primo post devi prima aggiornare alla 10.6.5 o 10.6.6 tramite ComboUpdate che puoi scaricare dal sito Apple.

#7
emmetreo

emmetreo

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
  • Gender:Male
  • Location:Salerno
Ho provato ad effettuare l'aggiornamento, ma al riavvio il sistema rimane bloccato, nonostante esegua kext utility per ripristinare i permessi. Forse devo eseguire anche l'utility AMD ?

#8
mrmojorisin17

mrmojorisin17

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,942 posts
  • Gender:Male
Prima di riavviare devi controllare che in S/L/E o E/E non ci sia lo SleepEnabler.kext (se c'è lo elimini) e devi sostituire nella root (/) dell'HD di sistema il mach_kernel con uno patchato per sistemi AMD.

#9
emmetreo

emmetreo

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
  • Gender:Male
  • Location:Salerno

Prima di riavviare devi controllare che in S/L/E o E/E non ci sia lo SleepEnabler.kext (se c'è lo elimini)

Per effettuare questa prima operazione devo aprire la consolle e andare nella cartella S (system) utilizzando le righe di comando... che non conosco purtroppo.

e devi sostituire nella root (/) dell'HD di sistema il mach_kernel con uno patchato per sistemi AMD.

Anche per quest'operazione credo sia necessaria la consolle e righe di comando inoltre dove posso trovare un mach_kernel patchato ?

Ti ringrazio molto per l'aiuto mrmojorisin, farò il possibile per seguire i tuoi preziosi consigli :(

#10
mrmojorisin17

mrmojorisin17

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,942 posts
  • Gender:Male
Trovi tutto quello che ti serve su Google (comandi terminale) e qua sul forum (kernel patchato).

F.A.Q. utilissima di Fabio :( ( http://www.insanelym...howtopic=225608 )

Edited by mrmojorisin17, 01 March 2011 - 04:00 PM.


#11
emmetreo

emmetreo

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
  • Gender:Male
  • Location:Salerno

Trovi tutto quello che ti serve su Google (comandi terminale) e qua sul forum (kernel patchato).

F.A.Q. utilissima di Fabio :D ( http://www.insanelym...howtopic=225608 )


Eccomi, allora vediamo se ho ben recepito le tue indicazioni.
- per prima cosa scarico l'update mediante aggiornamento software;
- una volta scaricata la installo
- poi controllo nelle cartelle system/library/exstension se c'è il file sleepEnabler.kext e se presente lo cancello (ma posso farlo anche dalla finestra ? o solo dal terminale ?)

eccoci giunti al passaggio per me molto difficile
- devo sostituire nella root (/) dell'HD di sistema il mach_kernel con uno patchato per sistemi AMD, quì avrei bisogno davvero di indicazioni dettagliate e l'occorrente, essendo davvero un novellino di questo magico mondo OSX :)

#12
mrmojorisin17

mrmojorisin17

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,942 posts
  • Gender:Male
Per eliminare il kext basta che lo trascini nel cestino.
Per sostituire il kernel il procedimento è molto semplice.
Nella sezione internazionale trovi il kernel patchato per Snow 10.6.6 (link); una volta scaricato il kernel e aggiornato il sistema devi eliminare il mach_kernel presente nella root dell'HD di sistema e metterci quello patchato (precedentemente rinominato mach_kernel).
Riavvii e tutto dovrebbe essere ok.
Fai sapere :)

#13
emmetreo

emmetreo

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
  • Gender:Male
  • Location:Salerno
Ok, faccio per precauzione un immagine del disco.. se riesco con Norton o Acronics, e proseguo, aggiornamenti a breve :(

#14
mrmojorisin17

mrmojorisin17

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,942 posts
  • Gender:Male
Saggia decisione :(

#15
emmetreo

emmetreo

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
  • Gender:Male
  • Location:Salerno
Eccomi, la creazione dell'immagine della partizione mi ha richiesto quasi un ora e lo scaricamento dell'update da 1 gb lo stesso, ma passiamo alla fase operativa :(
Allora ho verificato nella cartella S/L/X e non è presente il kext sleepEnabler.kext, pertanto non l'ho potuto cancellare;
poi ho scaricato il pacchetto d'installazione Legacy_kernel-10.6.0 pkg che ha una procedura di installazione, quindi dovrebbe fare, se ho ben capito, tutto da solo.
A questo punto ho avviato l'installazione dell'aggiornamento, e completata mi ha richiesto il riavvio del sistema.
Prima di riavviare ho lanciato il legacy_kernel pkg che alla fine mi ha dato un errore.
Riavviato il PC diverse volte (causa video nero per il driver malfunzionante) mi ritrovo ancora con la 10.6.0
Potrei rimuovere il driver video in modo da poter fare queste prove più tranquillamente ?

#16
mrmojorisin17

mrmojorisin17

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,942 posts
  • Gender:Male
Occhio che devi scaricare un kernel patchato per 10.6.6, non 10.6.0 :(
E comunque prima di riavviare potresti anche installare i kexts per la VGA in cui parlavi nel Post #1 (prima di riavviare ripara però i permessi).

#17
emmetreo

emmetreo

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
  • Gender:Male
  • Location:Salerno
Eccomi faccio un breve repor di quanto fatto, con l'aiuto mrmojorisin ;)
Ho eseguito nuovamente la procedura di aggiornamento del sistema da 10.6.0 a 10.6.6 e mi ha richiesto il riavvio del sistema per poter terminare l'aggiornamento per cui dato l'ok in fase di chiusura ha installato i pacchetti e subito riavviato la macchina.
Al riavvio le solite difficoltà con lo schermo nero (led del monitor verde, quindi non và in sleep mode..) e riesco a far ripartire il sistema e finalmente vedo le finestre in trasparenza ed una velocità nettamente migliorata.
Provo ad avviare alcune applicazioni ma tutte in errore, allora rieseguo la patch e finalmente si aprono i prog e riesco anche a vedere le foto per la prima volta con preview !!
Riavvio la macchina ed al solito niente da fare ... monitor nero... riavvio fino a riuscire a fare lo start-up ed installo i driver
Radeon X1950 PRO / GT Bronya Snow Leopard 10.6.5 : Updated driver for Snow Leopard 10.6.5 For more info see:

riavvio il sistema ma niente da fare, sempre la schermata nera del monitor con led verde acceso...
Noto grande difficoltà a configurare questa scheda video, confido le Vs. supporto.
Grazie mille :(

#18
emmetreo

emmetreo

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
  • Gender:Male
  • Location:Salerno
Sono in un vicolo ceco, ieri sera ho provato in svariati modi ad installare altri kext, senza successo, avrei bisogno di un po' di supporto per superare quest'altro gradino.
Pensavo se è il caso di reinstallare tutto d'accapo.
Inoltre il PC avvia l'installazione solo dalla distribuzione hazard 10.6.0 attivanto
legacy kernel
patch AMD
Ho provato con versioni successive e diverse, ma si bloccano tutte visualizzando un cerchietto di divieto sul desktop.
Help me please :(

#19
mrmojorisin17

mrmojorisin17

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,942 posts
  • Gender:Male
Link utile: http://www.insanelym...howtopic=223631

#20
emmetreo

emmetreo

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
  • Gender:Male
  • Location:Salerno
Grazie per il tuo riscontro, ieri ho consultato la guida da te indicata, ma per me è ancora troppo tecnica e non conosco bene l'inglese, se cortesemente potresti indicarmi sommariamente i passi da fare. Grazie mille :(





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy