Jump to content

GMA X4500 não funciona em 10.5.7


  • Please log in to reply
7 replies to this topic

#1
motionCrazy

motionCrazy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts
  • Location:João Pessoa, Paraíba
Olá pessoal do InsanelyMac, estou retornando aqui novamente para pedir uma ajudinha...

Tenho um amigo que é fanático por Macs, e ele queria colocar um Hackintosh no notebook dele, recomendei o iAtkos v7, até o momento, tudo funcionando perfeitamente, exceto o vídeo...

O Notebook dele é um Lenovo G450:

Motherboard: NITU1
Processador: Intel Celeron 900 2.2 GHz 1MB Cache
RAM: 2GB DDR3
GPU: Intel GMA X4500
HD: 160GB SATA

Já andei pesquisando várias kexts mas só achei pro Snow Leopard, achei um patch para o Leopard mas fico com medo de arriscar e acho que ele não está disposto a tentar instalar mais uma vez...

Grato desde já.

#2
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,836 posts
  • Gender:Male
  • Location:Brazil
Esta placa não é suportada no Mac OS, nem no Leopard, nem no Snow. O que existe pro Snow é uma kext da X3100 modificada que permite mudança de resolução (framebuffer), mas sem aceleração.

Se não quiser arriscar a kext do Snow no Leopard, pode tentar o método do boot modificado para resolução nativa
http://deviato.wordp...-gma-version-2/

http://rapidshare.com/#!download|929l3...eonMR2a.zip|206

#3
motionCrazy

motionCrazy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts
  • Location:João Pessoa, Paraíba
Valeu, old...
Só funciona se for o Chamaleon RC4? Ia recomendar o RC5 pra ele.

#4
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,836 posts
  • Gender:Male
  • Location:Brazil
É uma versão modificada do Chameleon RC4, com a oficial não funciona a resolução nativa.

#5
motionCrazy

motionCrazy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts
  • Location:João Pessoa, Paraíba
Certo, old, mais uma dúvida, como meu inglês não é tão bom...

Checo se tenho o arquivo com.apple.Boot.plist nas pastas /Extra e /Library/Preferences/SystemConfiguration
Abro ele com o editor de texto, adiciono a as linhas (editando pra minha resolução):
<key>Graphics Mode</key>
<string>1280x720x32</string>

Substituo o arquivo boot pelo que você botou ali pra download e reinicio?

#6
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,836 posts
  • Gender:Male
  • Location:Brazil
Exato.

Mas um detalhe, só substitua o arquivo boot se você tem o RC4 instalado. Se tiver o RC5, antes use um instalador do RC4 (ou instale manualmente o boot0 e o boot1h do RC4) aí sim substitua o boot. Se usar o boot do RC4 com o boot0 e o boot1h do RC5 pode dar problema.

Testar a kext do Snow também não seria tão arriscado (até menos que o boot), se der problema você entra no modo single user e remove a kext.

#7
motionCrazy

motionCrazy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts
  • Location:João Pessoa, Paraíba
Old, caso não tenha o arquivo com.apple.Boot.plist em uma das pastas, edito e colo no diretório que estiver faltando?
Meu amigo tá tentando editar e diz que não tem permissões...
Seria possível disponibilizar um link do RC4 também, old?
E como faz pra entrar no modo single caso dê erro?

#8
oldnapalm

oldnapalm

    InsanelyMac V.I.P.

  • Moderators
  • 6,836 posts
  • Gender:Male
  • Location:Brazil
Na pasta do sistema tem que ter o plist, é só fazer uma cópia, editar e substituir. Se abrir o original direto não vai conseguir gravar mesmo. Também pode copiar para a pasta Extra.

Tem um instalador do RC4 no tópico sobre o Chameleon, veja em "guias e tutoriais".

Sobre o single user, veja em "perguntas frequentes (FAQ)".





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy