Jump to content

10.5.8 success on a Dell Dimension 4400


  • Please log in to reply
No replies to this topic

#1
Cerastez

Cerastez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 160 posts
  • Gender:Female
  • Location:Bellingham, WA, USA
iPC 10.5.6 on a Dell Dimension 4400, then upgraded to 10.5.8
Netgear FA311 ethernet card
nVidia GeForce FX5200 AGP video card
Creative Labs Audigy2 Soundblaster sound card


The 4400 is not very well supported. I would not recommend going out and buying one, but if you already have one and want to hackintosh it, then this guide will get it up and running. You must get a video card for it. Mine came with an ATI Rage 128 Ultra and you will never get QE/CI with that. The FA311 ethernet card was stock and it works fine with that. I am fairly certain that the onboard sound would work, but I had a sound card so I used it.

Specs

IntelĀ® PentiumĀ® 4 microprocessor that runs at 1.60 GHz
00:00.0 Host bridge [0600]: Intel Corporation 82845 845 [Brookdale] Chipset Host Bridge [8086:1a30] (rev 04)
00:01.0 PCI bridge [0604]: Intel Corporation 82845 845 [Brookdale] Chipset AGP Bridge [8086:1a31] (rev 04)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 PCI Bridge [8086:244e] (rev 05)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801BA ISA Bridge (LPC) [8086:2440] (rev 05)
00:1f.1 IDE interface [0101]: Intel Corporation 82801BA IDE U100 Controller [8086:244b] (rev 05)
00:1f.2 USB Controller [0c03]: Intel Corporation 82801BA/BAM USB Controller #1 [8086:2442] (rev 05)
00:1f.3 SMBus [0c05]: Intel Corporation 82801BA/BAM SMBus Controller [8086:2443] (rev 05)
00:1f.4 USB Controller [0c03]: Intel Corporation 82801BA/BAM USB Controller #1 [8086:2444] (rev 05)
01:00.0 VGA compatible controller [0300]: nVidia Corporation NV34 [GeForce FX 5200] [10de:0322] (rev a1)
02:09.0 Ethernet controller [0200]: National Semiconductor Corporation DP83815 (MacPhyter) Ethernet Controller [100b:0020]
02:0a.0 Multimedia audio controller [0401]: Creative Labs SB Audigy [1102:0004] (rev 04)
02:0a.1 Input device controller [0980]: Creative Labs SB Audigy Game Port [1102:7003] (rev 04)
02:0a.2 FireWire (IEEE 1394) [0c00]: Creative Labs SB Audigy FireWire Port [1102:4001] (rev 04)
02:0b.0 Communication controller [0780]: Conexant HSF 56k Data/Fax Modem [14f1:2013] (rev 01)




Installation

Boot off the iPC 10.5.6 Final disk and install
  • iPC OSx86 10.5.6 Base System
  • 9.5.0 Voodoo Kernel
  • LegacyAppleIntelPIIXATA chipset driver Edit: There was no DVD playback with this
  • Intel ICH10 SATA Support
  • AC97 audio (only install if you are using the onboard audio. Do not install if you are using a sound card.)
  • Seatbelt.kext 10.5.5
  • AppleSMBIOS ToH
  • Applications (OSx86 Tools, Kext Helper, Pacifist, Perian)
Restart using -f



Upgrade to 10.5.8

Go to the Apple site search for and download the MacOSUpdCombo10.5.8.pkg
Do not use the Software Update
Run the MacOSUpdCombo10.5.8.pkg installer
Restart and boot off the iPC 10.5.6 Final disk
Uncheck, do not install iPC OSx86 10.5.6 Base System
Install these:
  • 9.5.0 Voodoo Kernel
  • LegacyAppleIntelPIIXATA chipset driver Edit: There was no DVD playback with this
  • Intel ICH10 SATA Support
  • AC97 audio (only install if you are using the onboard audio. Do not install if you are using a sound card.)
  • Seatbelt.kext 10.5.5
  • AppleSMBIOS ToH
Restart using -f

Go ahead and use Software Update to update software now that the system is at 10.5.8



Netgear FA311 ethernet card

Download the attached IONetworkingFamily.kext and use Kext Helper to install it
*The IONetworkingFamily.kext from 10.4.7 will also make the FA311 work.



nVidia GeForce FX5200 AGP video card

Use the instructions on Astro123's post to get your FX5200 going.

*One hint, OSx86Tools will not work correctly the way that it is installed from the iPC 10.5.6 Final disk. It can not be inside a folder, inside your Applications folder. Move OSxTools so it is just the app inside the Applications folder.
*Also, if you do not get QE/CI after following Asto123's instructions use OSx86Tools to enable QE and restart. You still have to do all the stuff in Astro123's post, OSx86Tools just switches it on.



Creative Labs Audigy2 Soundblaster sound card

Get into the BIOS and disable the onboard audio.

Use the instructions on Oxtie's post. Be certain to download kXAudioDriver-1.3b0, a link to it can be found in Oxtie's signature. Version 1.11b0 will not work for this setup.


DVD Playback Issues

I had initially installed LegacyAppleIntelPIIXATA chipset driver. There was no DVD playback with this kext. I would get "There was an initialization error : A Valid Video Device Could Not Be Found For Playback [70017].." Neither Apple's DVD Player nor VLC worked.
I was able to get DVD Playback by installing Intel ICH10 SATA Support instead. It made it so that Apple's DVD Player worked but was very slow and chunky. So I have been using VLC. It runs smoothly.

Attached Files







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy