Jump to content

Problems with Darwine


  • Please log in to reply
No replies to this topic

#1
avesthefox

avesthefox

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I've spent countless hours this past week working on an ibook that I purchased from my uncle for $40. I grew up with PC's so to say that Mac is alien is an understatement ;)

So far, I really like what I see... But there's just so much learning and getting used to.... (its no help that the PowerPC is no longer updated on...)

My current project is trying to get a copy of Darwine to actually work on my machine so that I may could run some of my favorite Windows app's on the go.

So what's the problem? I cant get Darwine or anything related to run on the dratted thing! I click the icon and the program icon in the menu pops up then bounces back before closing out again without an error notice or anything. I looked into the package content of WineHelper to click on the terminal icon and got an error

I'd paste it all here, but alas, I'm having to use my Windows PC to type this message and txt conversions from mac to PC seems a bit complicated at the moment, but the least I can do is describe it...

the terminal starts up with the program giving me the last login information, the selected file's location then starts up with "Welcome to Darwine!" then it does more file location defining until it comes to a line that says "WineHelper Undefined Symbols:" then it repeats this line twice:

/Applications/Darwine/WinHelper.app/Contents/MacOS/WineHelper undefined reference to _NSLocalCountryCode expected to be defined in Cocoa

then ends with:

Trace/BPT trap
logout
[Process completed]

Now before anybody starts pointing out the obvious, I've done my homework (I did mention I worked my tail off this past week trying to get things to work to my liking) I checked to see if the software can run on my OS (Mac OS 10.3.9(aka Panther)) and the machine (PowerPC) I've researched endlessly through forums and bug reports concerning the problem (there was one suggestion, but I'll get to that later) and I've tried different builds of Darwine that could run on this OS (one build actually did send an error that it could not run because it was possibly defective) I've downloaded and installed X11 and the xcode tools (as well as many other things) and I've tried things with the terminal as instructed from Darwine startup tutorials, but alas, there seems to be no solution!

The solution that was mentioned in the above paragraph involved me downloading the source code of Darwine and rebuilding it from that. Some claimed the advise to be most helpful, so I went on my way looking and digging around for this source code, but there doesn't seem to be any trace of it on the internet anymore (that, or I'm just so #@$ clueless on what I need to be typing into google)

So finally I come here, I've created an account and everything just to get some help concerning this issue.. (I stumbled upon that startup tutorial somewhere in this forum)

I have a headache, and I've barely eaten anything in the past week...

give this tired worn out computer junky/nerd a helping hand, please?

PS. Please don't refer me to some expensive Windows emulation software... I've researched that subject quiet a bit before learning about Darwine... I'm a very poor fellow, so I'm leaning on the freeware end of the software chain... :D





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy