Jump to content

[Tuto] Installation d'un 10.5.6 retail sur un MSI Wind


  • Please log in to reply
13 replies to this topic

#1
TheChesterCat

TheChesterCat

    InsanelyMac Protégé

  • Members
  • PipPip
  • 94 posts
  • Gender:Male
  • Location:Strasbourg
Bonjour à tous,

Voilà mon tuto concernant l'installation de Leopard sur un MSI Wind u100 à partir d'une version 10.5.6 retail. Vous allez voir, c'est assez simple et votre machine sera diablement efficace. C'est aussi pour cette raison que j'ai décidé de repasser mon Wind sous Leo plutôt que de le laisser sous Snow (qui ne supporte plus l’Atom avec un kernel vanilla !!).


Pré-requis:

- Une clé usb de 8Go minimum,
- Une image disque de Leopard 10.5.6 retail ou un dvd d'installation original,
- Le zip contenant les kexts nécessaires et autres installeurs (voir fichier joint à mon post),
- Un accès à un os X fonctionnel (hackintosh ou non), le temps de préparer la clé,
et bien sûr…. un Wind (Ben ouais, quand même!!! :P )



La préparation de la clé usb.

1- Ouvrir l'utilitaire de disque et formatez la clé usb en deux partitions, toute deux "Mac os journalisé", l'une de 200Mo, l'autre ayant la taille de l'espace libre restant sur la clé. Assurez vous de cliquer sur le bouton option puis de sélectionner "MBR" et non "GuiD". Nommez la première partition "bootloader", et la laissez la seconde sans nom.

2- Toujours dans l'utilitaire de disque, cliquez sur l'onglet "restauration". Faites de la partition anonyme la destination de restauration. Montez l'iso de Leopard 10.5.6, et cliquez droit sur cette dernière (qui se trouve dans la colonne de gauche), puis sélectionnez "choisir comme source". Cliquez maintenant sur "restaurer" et attendez la fin de l'opération. Une fois l'opération terminée, fermez l'utilitaire de disque.

3- Exécutez ensuite le package modifié de Chameleon 2rc3. Lorsqu'il vous demandera le point de destination, choisissez la partition 'bootloader' de la clé usb.

4- Allez ensuite récupérer la dernière version de Chameleon sur le site du fameux bootloader. Extrayez le dossier 'Chameleon-2.0-rc...blablabla...' et placez le à la racine du volume ‘bootloader’. Renommez le dossier en 'chameleon', ça sera plus simple pour la suite qu'avec un nom à rallonge!!

5- Dans le zip joint à mon post, copiez les dossiers 'kext' et 'autres' et collez le à la racine du volume ‘bootloader’.

6- Allez dans le dossier 'kext' et copier les kexts suivants:

Disabler.kext
FakeSMC.kext
SleepEnabler.kext

Allez ensuite dans bootloader/extra/extensions. Supprimer tous les kexts qui seraient présents dans ce dossier extensions puis coller ensuite les deux kexts précédemment cités.

7- Vous pouvez fermer le terminal, votre clé est prête!!!



L'installation de Leopard

1/ Bootez sur la clé usb précédemment préparée jusqu'à arriver sur le disque d'installation de Leopard. Assurer vous d'avoir une souris usb connectée à votre Wind car le trackpad ne sera pas actif de suite!!
Avant de commencer l'installe à proprement dit, mieux vaut faire un tour dans l'utilitaire de disque pour bien partitionner/formater son disque dur comme bon vous semble, MAIS avec l'option GUID, c'est important pour la suite!!!. Après quoi, lancez l'installe et allez vous prendre un café… Au bout de 15 à 20 minutes, l'installation se termine MAIS échoue, c'est normal!! Vous ne pensiez tout de même pas voir un dvd retail d'os X s'installer sur un pc?! tongue.gif ¬ .

2/ Rebooter à nouveau (sur la clé), mais sélectionnez cette fois le volume sur lequel vous venez d'installer Leopard. Vous devriez arriver sur le bureau sans encombre. Félicitations, vous êtes en 10.5.6, même si tout est encore bancal….

3/ Arrivés à ce niveau, nous allons nous atteler à activer le contrôleur ethernet de manière à pouvoir faire la mise à jour vers 10.5.8.
Ouvrez le terminal et tapez:

sudo -s
cd /volumes/bootloader/kext
cp -R RealtekR1000.kext /volumes/leopard/system/library/extensions
kextload RealtekR1000.kext

Vous pouvez refermer le terminal.
Normalement vous devriez avoir une connexion ethernet valide. Partant de là, allez dans le menu 'pomme' et lancer la recherche de mise à jour de logiciels. Faites toutes les mises à jour et redémarrer votre machine aussi souvent que le système vous le demandera, jusqu'à ce que Leopard soit à jour et qu'il n'y ait plus aucune mise à jour disponible. Vous devriez maintenant être en 10.5.8!!

4/ Maintenant que tout est à jour, on va pouvoir rendre fonctionnel la vidéo, le son, le trackpad, bref, tout ce qui ne fonctionne pas encore.
Ouvrez le terminal et tapez :

sudo –s
cd /volumes/bootloader/kext
cp -R ClamShellDisplay.kext /volumes/leopard/system/library/extensions
cp -R RealtekR1000.kext /volumes/leopard/system/library/extensions
cp –R VoodooPS2controller.kext /volumes/leopard/system/library/extensions
cp –R VoodooBattery.kext /volumes/leopard/system/library/extensions
cp –R VoodooHDA.kext /volumes/leopard/system/library/extensions
cd /volumes/bootloader/kext/GMA950
cp –R AppleIntelgma950.kext /volumes/leopard/system/library/extensions
cp –R AppleIntelIntegratedFramebuffer.kext /volumes/leopard/system/library/extensions

Vous pouvez refermer le terminal.

5/ Allez dans le dossier ‘autres’ du volume ‘bootloader’. Vous y trouverez les installers pour le chipset wifi ainsi que celui pour le remapping du clavier. Exécutez les tous les deux.

6/ Bien que l'installe se soit bien passée, il faut encore installer un bootloader (Chameleon dans notre cas) afin de pouvoir se passer de la clé usb pour le démarrage.
Ouvrez le terminal, puis tapez:

sudo -s
diskutil list

Quand un disque est partitionné suivant la table de partition Apple/Intel (GUID), une partition cachée de 200Mo nommée EFI est créée. Recherchez cette partition et gardez en tête son indicatif (dans notre cas disk0s1). Nous allons maintenant formater cette partition:

newfs_hfs -v EFI /dev/disk0s1

Puis on monte la partition pour pouvoir y travailler:

mkdir /volumes/EFI
mount_hfs /dev/disk0s1 /volumes/EFI

On y installe ensuite Chameleon:

cd /volumes/bootloader/chameleon/i386
fdisk -f boot0 -u -y /dev/rdisk0
sudo dd if=boot1h of=/dev/rdisk0s1
sudo cp boot /volumes/EFI

On copie ensuite les kexts nécessaires:

cp -R /volumes/bootloader/extra /volumes/EFI
cd /volumes/EFI/extra/extensions
chmod -R 755 *.kext
chown -R root:wheel *.kext

On démonte la partition EFI:

umount -f /volumes/EFI
rm -rf /volumes/EFI

Reste à l'activer:

fdisk -e /dev/disk0
p
f 1
w
y
q

Vous pouvez quitter le terminal.

7/ Y'a plus qu'à rebooter (éventuellement avec l’option –f pour forcer la reconstruction du cache).
Allez ensuite dans l’utilitaire de disque pour vérifier et faire corriger les éventuels problèmes de droits.

Ca y est, c'est terminé!!! Normalement tout devrait être fonctionnel, avec un 10.5.8 100% à jour !!! Enjoy !!!
:D

Attached Files



#2
Gils3310

Gils3310

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Merci ca peut servir :)

#3
baisalez

baisalez

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
bonjour à tous,

J'ai un problème, j'ai tout essayé, j'ai suivi ce tuto et des autres similaires sur un targa clone du MSI Wind,
après l'installation sur la clé USB qui s'est toujours bien déroullée, ainsi que l'installation de chameleon, je ne suis jamais parvenu à booter la clé USB n'y Chameleon n'y la pomme, pourtant il me semble que je procède de la bonne manière. Même si le netbook Targa ne serait pas compatible, je devrais au moins arriver à booter au minimum Chameleon. Qu'est ce vous en pensez. Si quelqu'un pourrait m'aider se serais sympa.

Merci d'avance à tous

#4
TheChesterCat

TheChesterCat

    InsanelyMac Protégé

  • Members
  • PipPip
  • 94 posts
  • Gender:Male
  • Location:Strasbourg

(...) après l'installation sur la clé USB qui s'est toujours bien déroullée, ainsi que l'installation de chameleon, je ne suis jamais parvenu à booter la clé USB n'y Chameleon n'y la pomme, pourtant il me semble que je procède de la bonne manière. Même si le netbook Targa ne serait pas compatible, je devrais au moins arriver à booter au minimum Chameleon.


@Baisalez
Si l'installation de Chameleon s'est bien déroulée sur ta clé usb, je ne vois que deux options:
1- Vérifier que ta clé soit bien partionnée avec la table MBR pour être bootable sur un pc,
2- Vérifier que le bios de ton Targa pour être certain de bien booter sur ta clé usb.
C'est clair que tu devrais au moins booter sur Chameleon....??!
En espérant avoir pu t'aider,

LaFrenchPomme

#5
Sidihbibi

Sidihbibi

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 4 posts
  • Gender:Male
  • Location:Morocco
j'essaye d'installer ideneb ou kalyway sur MSI NetOn ap1900 je voudrais un conseil car après chaque installation réussi ça reste cloqué sur l'écran d'accueil pomme une idée sur la configuration du bios
Merci d'avance

#6
christd17

christd17

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Bonjour, j'ai un petit soucis, je boot bien mais l'install me dit Mac ne peut etre installez sur cet ordinateur :s

#7
TheChesterCat

TheChesterCat

    InsanelyMac Protégé

  • Members
  • PipPip
  • 94 posts
  • Gender:Male
  • Location:Strasbourg
@Sidihbibi
Commence par booter avec l'option -v pour passer en mode verbose. Tu auras des tas d'infos, notamment au moment où ton système va planter.

@Christd17
Si l'installeur te dit que l'osX ne peut être installé sur ce système, c'est certainement que ton disque dur n'est pas préparé convenablement (faire un tour dans l'utilitaire de disque) ou pire, ton disque dur n'est pas détecté (à vérifier dans l'utilitaire de disque aussi, mais si ta machine est un Wind U100, ça ne devrait pas être le cas!!!).

Bonne chance....
LaFrenchPomme

#8
christd17

christd17

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Merci pour ta réponse. Malheureusement pour moi, le disque est bien préparer, car je l'ai formaté en Mac Journalisé en GUID. As tu une autre solution ?

#9
TheChesterCat

TheChesterCat

    InsanelyMac Protégé

  • Members
  • PipPip
  • 94 posts
  • Gender:Male
  • Location:Strasbourg

Merci pour ta réponse. Malheureusement pour moi, le disque est bien préparer, car je l'ai formaté en Mac Journalisé en GUID. As tu une autre solution ?


Effectivement, c'est bizarre. Est ce que depuis le dernier formatage, tu as tenté une installation qui s'est mal déroulée ou qq chose comme ça?? Je pense à ça car si le programme d'installe détecte un autre os Mac déjà installé, il te dira que c'est pas possible d'en réinstaller un par dessus, à moins de cliquer sur 'option' ou qq chose du genre et de forcer l'installation malgré les données déjà présente.
Je vois que ça...!!? Sinon reformate en forçant les données à 0, pour être certain que le disque soit clean.

#10
christd17

christd17

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Bon ben j'ai fait que tu m'a di, j'ai effacer le disque en mettant que des 0 dessus, et pareil :s Je comprend pas pourquoi

#11
christd17

christd17

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Bon ben j'ai installez une Kalyway et c'est passer nickel. Je ne comprend pas pourquoi la retail ne veut pas fonctionner sur mon Msi Wind

#12
TheChesterCat

TheChesterCat

    InsanelyMac Protégé

  • Members
  • PipPip
  • 94 posts
  • Gender:Male
  • Location:Strasbourg
Je viens de trouver ce lien directement chez Apple, mais ça ne te fera pas avancer plus.... Bizarre!!!
De mémoire, ça m'étais arrivé une fois, mais j'avais SnowLeo déjà installé, cqfd. Je crois me souvenir qu'il y avait un bouton 'options' où était expliqué pourquoi il ne voulait pas faire l'installe et comment y remédier.

Question bête: C'est bien un U100 ton Wind??

#13
Maxemieu

Maxemieu

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Bonjour,
je me permets de relancer le sujet, car j'essaie moi aussi
de faire une install sur un MSIwind U100,
l'installation s'est passée comme prévu, mais là
ou ça coince c'est pour rebooter, je reboote bien sur la clé,
mais comment repasser sur le disque et le bureau ?
Merci d'avance pour quelques éclaircissements

#14
The Kevin

The Kevin

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Salut tout le monde!
voila, je suis nouvaeu de le monde du hackintosh et j'aurais besoins de votre aide :
je me suis offert un MSI Wind U100 la semaine derniere et j'ai, pour voir, installé Mac OS X Leopard 10.5.7 en suivant le tuto http://www.mncorp.ne...-avec-iatkos-v7
Installation genial, tout se passe bien, wifi, sond, usb, tout fonctionne apars 3 petite choses qui m'enervent un peut et c'est la que vous intervenez :
> Je n'ai pas de clavier Francais, je ne peux pas faire d'@'‚ de '–' et de '_' . Le 'fr-wind.keylayout' etant bien placé n'apparait pas dans la liste des claviers dispos.
> La WebCam ne marche ni avec PhotoBooth ni avec MaCam ni rien d'autre.
> Je ne peux pas cliquer avec le trackpad.

pouvez vous regler ses problemes ?

Merci d'avance, bonne soirée :(





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy