Jump to content

iPhone 3G (Firmeware 3.1.3;Broadband 05.12.01;Bootloader 5.9) Unlock?


  • Please log in to reply
7 replies to this topic

#1
viper2k

viper2k

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
Hi,

I have the iPhone 3G (16GB) from a T-Mobile contract, zhat is activated.
The iPhone:


Software Version: 3.1.3
Baseband Version: 05.12.01
Bootloader Version: 5.9

Is there a possibility to get it unlocked, so that all SIM cards are accepted?"The jailbrock had no difficulities.


Thx for your answers

#2
tank27

tank27

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 100 posts
how did you jailbreak it

how do you know your bootloader version

Hi,

I have the iPhone 3G (16GB) from a T-Mobile contract, zhat is activated.
The iPhone:


Software Version: 3.1.3
Baseband Version: 05.12.01
Bootloader Version: 5.9

Is there a possibility to get it unlocked, so that all SIM cards are accepted?"The jailbrock had no difficulities.


Thx for your answers



#3
ralphwiggum

ralphwiggum

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
Not unlock yet for baseband 05.12.01

Just a week after Apple released the iPhone 3.1.3 update, Sherif Hashim has discovered an exploit that could allow iPhone users to unlock their iPhone on the iPhone 3.1.3 firmware on baseband 05.12.01 and use it with other carriers like T-Mobile in the US, for example. We get these a lot, but no the iPhone can’t be unlocked to work with Verizon because Verizon operates on a CDMA network. Apple always updates the baseband with each update, causing many iPhone users to loose their unlock so this is good news for the iPhone users that had their baseband updated and lost their unlock.
For now, download iPhone toolbar (works on Windows/Mac on Firefox, Safari, or Internet Explorer browser) and you’ll receive an alert once the unlock is released, and instructions on how to install it.
The exploit Sherif Hashim uses has not been revealed yet, but iPhone Dev Team member MuscleNerd has confirmed that it works. The iPhone Dev Team will most likely wait for Apple to release the next generation iPhone 4G before releasing this unlock so that Apple does not patch the exploit before then. For now, all iPhone users that are unlocked/jailbroken are advised to be extremely cautious of future firmware updates and avoid updating before the jailbreak tools are updated

source:http://www.quickpwn.com/2010/02/iphone-3-1-3-05-12-01-baseband-unlock-imminent-sherif-hashim-discovers-exploit.html

:(

#4
viper2k

viper2k

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
And a downgrade is also not possible, because of the bootloader version 5.9 right?

Hopefully sherif-hashim will realease a new tool, that it makes possble to unlock it.

#5
ralphwiggum

ralphwiggum

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts

And a downgrade is also not possible, because of the bootloader version 5.9 right?

Hopefully sherif-hashim will realease a new tool, that it makes possble to unlock it.


Yes, unfortunately because of bootloader 5.9 you wont be able to downgrade just yet, but I would imagine something will appear at some point as fuzzyband is able to downgrade bb 05.12.01 with 5.8 bootloader so maybe fuzzyband will get updated, sorry I know that's not great news but there is hope I think

Regards.

#6
zandera

zandera

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 179 posts
  • Gender:Male
  • Location:Prague

Yes, unfortunately because of bootloader 5.9 you wont be able to downgrade just yet, but I would imagine something will appear at some point as fuzzyband is able to downgrade bb 05.12.01 with 5.8 bootloader so maybe fuzzyband will get updated, sorry I know that's not great news but there is hope I think

Regards.



use SPIRIT

#7
ralphwiggum

ralphwiggum

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts

use SPIRIT


Spirit is only a jailbreak tool, not an unlock tool

What's Spirit?
Spirit is an untethered jailbreak for iPad, iPhone, and iPod touch on the latest firmwares.
Spirit is not a carrier unlock.
If you currently are using a tethered jailbreak, you have to restore to use Spirit. Do not upgrade if you use an unlock on an iPhone 3G or 3GS. (You can, however, restore to 3.1.2 if you have SHSH blobs for that version.)

It will do an untethered jb, however if your baseband is 05.12.01 you still cant unlock, baseband must be below this in order to unlock.

Regards

#8
adiabu283

adiabu283

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Really wonderful piece of information and I appreciate it
iphone case





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy