Jump to content

[Resolved] Compaq C770US Fan Issue


  • Please log in to reply
5 replies to this topic

#1
sh0rtbus

sh0rtbus

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
I have recently installed iATKOS v7 on my compaq c770US laptop with great success. I have the webcam, wifi, ethernet, sound, and video card working flawlessly. My only problem is my fan will not cool effectively. When the laptop gets too hot (around 80 degrees), the fan bursts to 100% for about 5 - 10 seconds. I have found a fix for this, however, it was created for leopard 10.5.1. After installing it my fan worked appropriately, however, now my mouse and keyboard do not function and I am asked to reboot on some boots. I was hoping someone could provide the changes made to each kext so that I may update the stock kexts. If there is an easier solution to this I would be grateful, I have not been able to locate one though. Thanks!

Edit: After booting with verbose I have found that the reason I am asked to reboot is because of my ApplePS2Controller.kext failing.

Attached Files

  • Attached File  a.zip   749.57KB   33 downloads


#2
sh0rtbus

sh0rtbus

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Success! After about 2 hours worth of work I have both my cpu and system fan working for leopard 10.5.8. I will post the updated kernel extensions when I finish updating the version information. All credit goes to Vanilla for the original creation of these kexts!

#3
Roofus

Roofus

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

Success! After about 2 hours worth of work I have both my cpu and system fan working for leopard 10.5.8. I will post the updated kernel extensions when I finish updating the version information. All credit goes to Vanilla for the original creation of these kexts!


DUUUUDE!!! Thank you so much, i'm on a Compaq 515 and this fixed my problem entirely. I had the same issure of the fan cutting on once about every couple of minutes at full blast for about 10-20 seconds then cutting off again. BTW, you noted that it worked in 10.5.8, does it also work in snow leopard?

#4
Tobicool

Tobicool

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
hey,

is there some fix for the ApplePS2Controller.kext?
I use the controller from Voodo!
work that togehter?

#5
Tobicool

Tobicool

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
sorry for doublepost:D
but i´ve solved the problem:

I have changed the AppleACPIPlatform.kext and now it´s pretty good working!

The wan runs in a low speed, and wenn it should cool the CPU down, it does it!

here the kext:

http://www.multiupload.com/ENELOV01N3

Attached Files



#6
monwae

monwae

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

DUUUUDE!!! Thank you so much, i'm on a Compaq 515 and this fixed my problem entirely. I had the same issure of the fan cutting on once about every couple of minutes at full blast for about 10-20 seconds then cutting off again. BTW, you noted that it worked in 10.5.8, does it also work in snow leopard?



im trying to install iatkos v7 on my compaq 515, what driver should choose on the custumize section,, coz the insatallation went good but after reboot with the chameleon it says loading darwin and the screen went white an it reboot again over and over.... am i missing something??

soory for my bad english

compag 515 amd athlonX2 radeon3200 bios updateF.0c





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy