Jump to content

[FR] D-Link DWL-G122 rev. B1 (adaptateur USB Wi-Fi)

- - - - -

  • Please log in to reply
11 replies to this topic

#1
marcelg

marcelg

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Bonjour à toutes et à tous,

J'ai installé depuis quelques semaines une version x86 de Tiger 10.4.6 sur mon portable Toshiba M60-175 et j'éprouve quelques difficultés avec le WiFi. Ce qui est clair, c'est que la carte WiFi intégré à base de chipset Intel 2200BG ne fonctionne pas.

J'ai donc acheté un adaptateur USB WiFi D-Link DWL-G122 (rev. B1) à base de chipset Ralink 2500 car un pilote existe (ici) et de nombreux témoignages sources semblent indiquer une bonne "compatibilité" avec Mac OS X.

J'ai pris soin de chercher un maximum d'informations avant d'installer cette adaptateur et ait suivi scrupuleusement toutes les recommandations et instructions trouvées. Parmi les points positifs, l'adaptateur est bien reconnu par le système et apparaît correctement dans mes périphériques réseau (pas en "grisé"). L'application de configuration du WiFi se lance bien à chaque fois que j'insère mon adaptateur dans un port USB.

Tout cela est bien joli... mais le problème est que la connection Internet (via un routeur WiFi) ne fonctionne pas, enfin pas toujours !!! Et c'est là un vrai problème : la connection peut être parfaite pendant toute une session de travail et, un "reboot" plus tard, complétement inopérante !!! Cela, bien sûr, sans aucune modification de la configuration entre-temps.

J'ai bien sûr tenté de modifier des dizaines de pramétres (diffusion de la clé SSID, mode de cryptage des données, canal utilisé...) sans que cela ne change quoique que soit dans le caractère aléatoire de la connexion. J'ai même configuré différents réseaux WiFi avec des caractéristiques différentes sans plus de succès.

Quand cela ne fonctionne pas, ce sont souvent les mêmes symptômes qui sont observés : reconnaissance de la clé OK, lancement de l'application fournie avec le pilote, identification des réseaux disponibles puis, au bout de quelques secondes, "dispartition" des mêmes réseaux et impossibilité d'aller plus loin.

Donc, toute suggestion pour parfaire le fonctionnement de mon système, sera la bienvenue...

Merci d'avance,
Marcel

#2
xp1700

xp1700

    InsanelyMac Protégé

  • Members
  • PipPip
  • 91 posts
  • Location:québec canada
prend rt 2500 replug
http://mitglied.lyco...plug0-3-4b1.dmg
et ca devrais regler ton probleme

#3
marcelg

marcelg

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Bonjour,

Ce petit programme, censé résoudre le "bug" de branchement de l'adaptateur n'a malheureusement rien apporté au problème de reconnaissance du réseau que je rencontre.

Merci beaucoup de votre aide,
Marcel

#4
marcelg

marcelg

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Re-bonjour à toutes et à tous,

Pour compléter la description de mon problème, voilà ce que m'affiche "l'état du réseau" quand je branche mon adaptateur WiFi :

"D-Link DWL-G122 est actuellement activé. D-Link DWL-G122 possède une adresse IP locale et n'est peut-être pas en mesure d'accéder à Internet"

En précision, l'adresse IP affectée est du style 169.254.204.142 (celle que j'ai sous les yeux en ce moment) alors que, normalement, l'adresse IP affectée dans mon réseau à cette adresse mac est 192.168.0.5.

Si je change la configuration IPv4 de "Via DHCP" en "Utilisation de DHCP avec une adresse manuelle" et spécifie, comme adresse, 192.168.0.5, cela n'améliore rien.

Enfin, j'ai oublié de préciser dans mon précédent post, qu'au cours d'une session, la connexion Wi-Fi peut :
- ne pas fonctionner du tout (ce qui est le cas en ce moment...)
- fonctionner deux minutes au début
- fonctionner tout au long de la session...

Cela dépend de l'humeur ;-)

Merci à toutes et à tous... et bonne nuit
Marcel

#5
xp1700

xp1700

    InsanelyMac Protégé

  • Members
  • PipPip
  • 91 posts
  • Location:québec canada
est tu loing de ton routeur
le signal est a combien
moi jai la meme chose que toi pour la clef et un router d link di-524
et ca fonctione bien

#6
marcelg

marcelg

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Bonjour,

J'ai essayé à différentes distances de mon routeur et cela n'a malheureusement rien changé. Lorsque j'ai le bonheur de voir mon réseau, le force du signal est au moins de 80%

Merci d votre aide,
Marcel

#7
marcusacapus

marcusacapus

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
Hello,
As tu essayé de reconstruitre les autorisations et éventuellement mis à la poubelle (avant de reconstruire le autorisations) tes fichiers cache des extensions au cas il y ait confusion entre tes 2 cartes Wifi ?
Nota : c'est une suggestion, pas une certitude :D

#8
sn8k

sn8k

    Personnal Devil

  • Members
  • PipPipPipPipPipPipPip
  • 889 posts
  • Gender:Male
  • Location:Paris, pas celui du texas.
par hasard , as tu regardé dans le WIKI du site ??????????????

See latest 29/11/05 RT2500 OSX 10.4.x USB Driver at Ralink. Needs to unplug/plug USB after every reboot(for solution, check this forum out)

L'adresse du forum en question :
http://61.222.76.235...opic.php?t=1506

#9
marcelg

marcelg

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Bonjour,

Je suis au courant de ce petit inconvénient lié à ce pilote et je prends bien soin de brancher mon adaptateur qu'une fois le système démarré. Le fait de le brancher / débrancher plusieurs fois dans une même session n'apporte aucune solution à mon problème.

Merci de votre aide,
Marcel

#10
DrJägermeister

DrJägermeister

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,028 posts
  • Location:Somewhere in France
  • Interests:Sex, drugs and rock & roll

En précision, l'adresse IP affectée est du style 169.254.204.142 (celle que j'ai sous les yeux en ce moment) alors que, normalement, l'adresse IP affectée dans mon réseau à cette adresse mac est 192.168.0.5.
Si je change la configuration IPv4 de "Via DHCP" en "Utilisation de DHCP avec une adresse manuelle" et spécifie, comme adresse, 192.168.0.5, cela n'améliore rien.

Les adresses IP 169.254.x.x sont apipa, tu les as quand tu ne recoit rien de DHCP et que t´en as pas mis a la main.
Quand tu change l´adresse a la main est-ce que tu change aussi l´IP du router+ subnetmask+ DNS serveur?
L´IP seule ne suffit pas encore, il te faut changer les 4 (IP,router, subnet, DNS) a condition que tu peux bien te connecter au réseau Wifi. Pour les 1ers test je te conseille d´eteindre le WEP et de le rallumer plus tard quand tout fonctionne.

#11
desmopro

desmopro

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 214 posts
j'ai une rev c , ma clé est elle compatible , puis ou trouver les driver ?

#12
sn8k

sn8k

    Personnal Devil

  • Members
  • PipPipPipPipPipPipPip
  • 889 posts
  • Gender:Male
  • Location:Paris, pas celui du texas.
pourquoi c'est toujours aux autres de chercher ..???

http://forum.insanel...o...919&hl=G122

Topic sur la G122 Rev.C





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy