Jump to content

[Install] iPC 10.5.6 on Sony VAIO TZ Series

- - - - -

  • Please log in to reply
17 replies to this topic

#1
rampar

rampar

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
So I just got in my Sony VAIO TZ 150N laptop and I have to say I love the thing, what I obviously hate is Windows (especially Vista) so I searched but couldn't really find too many threads to show a walk through of how to install 10.5.5 or 10.5.6 on it, so I set out to do it on my own.

I'm not going to go into my setup, because with all the testing I have 5 partitions on my HDD (1 Windows and 4 Leopard), but here is what I got to work so far.

Step one: Get iPC 10.5.6 obviously ; ) (I recommend FF5 Final)

2: DO NOT change anything from the stock configuration in the BIOS, leave everything as it is.
3: Boot up iPC installation. Note: I've tried it with -v -x and everything, but it works fine without any commands, so just let it boot up normally.
4: If you need to format your HDD or partition do that through Disk Utility then select the correct HDD or partition and click "Continue"
5: Click on "Customize" to customize the installation and select these options:
a: Intel GMA950
b: LegacyAppleIntelPIIXATA
c: Azalea Audio
d: Under Power Management > Power Package and Clamshell
e: PS/2 Keyboard Fix (make sure not to select PS/2 Mouse)
f: SMBIOS Resolver
g: OSx86 Tools

Then click on to install it (you can skip the DVD check). After it is finished and it restarts, eject the CD and push type in -f to make sure all the kexts are loaded up.

Go through the registration screen as you normally would.

When it boots up you'll have noticied that the screen only takes up 2/3 of the screen. To fix this restart the computer and go into BIOS and you'll see an option for "Screen Stretch", set this option to YES, now when you boot into Leopard you'll see the correct resolution already selected.

To get the battery meter working, open up System Preferences, go to Power, click on Show All then Options and select "Show in Menubar" and now you have your battery display with the correct reading!

OpenGL/Quartz GL: Go to Applications and open OSx86 Tools, click on Enable/Disable Quartz GL and click Enable. Enter password and reboot.

What works out of the box:
Bluetooth!

What isn't working right now:
Ethernet
Wifi (I ordered an Apple Airport Extreme BCM 4321 that should be here in a couple days)
Headphone/Audio
Proper sleep (the display turns off when you close the lid, but won't come back on).
Memory Card Reader

I will hopefully have everything working soon enough, I don't know how many people actually have a TZ but it's a beautiful computer that is only made complete with OS X. Hopefully this guide will help other Sony people as well. I will be updating this as I go on.

If you have another Sony laptop and need help you can PM me and I'll try to help.

Thanks and Happy Modding!

#2
everrain

everrain

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hi, i habe a sony vaio tz31 computer, in this moment running windows 7, but im a osx user and i want to install it on this laptop.
Please update info as yo make some progress.
Thanks!

#3
pixie23

pixie23

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Followed rampar's footsteps and got OS X 10.5.6 on my TZ. Some other things I got working:

Ethernet (edit AppleYukon2.kext, found from another thread):
1. cd /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/AppleYukon2.kext/Contents
2. sudo nano Info.plist
3. find <key>Yukon-88E8055</key> and delete all
4. edit <key>Yukon-88E8053</key> to <key>Yukon-88E8055</key>
5. edit <string>0436211ab</string> to <string>0436311ab</string>
6. edit <string>Yukon Gigabit Adapter 88E8053 Singleport Copper SA</string> to<string>Yukon Gigabit Adapter 88E8055 Singleport Copper SA</string>
7. Ctrl+O enter and Ctrl+x to exit
8. Repair permissions, rebuild cache:
chmod -R 755 /System/Library/Extensions/IONetworkingFamily.kext
chown -R root:wheel /System/Library/Extensions/IONetworkingFamily.kext
rm /System/Library/Extensions.mkext
kextcache -k /System/Library/Extensions

Make sure to go to System Preferences when you want to use it for the first time and click apply.

Audio:
I'm attaching the kext that gives me headphones + speakers. However, it makes the system crash on shutdown... probably due to version incompatibility? 10.5.6 seems to need a newer kext (this was generated in part with taruga's patcher).

Attached Files



#4
mperrett

mperrett

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Hi

Followed the initial installation guide here and iPC worked first time. My sound also worked without issues and does the expresscard (I have a 48GB flash disk there which mounts fine). I also opened up my TZ before hand and installed an atheros WIFI card which is detected as an Airport extreme and connects fine. I am trying VMWare fusion tonight to see if I can install vista.

My logitech VX nano mouse and t-mobile Web/walk usb modem also work fine (modem is E160).

To sum up things that worked:

Wifi
Bluetooth
RF/USB mouse
Expresscard + SSD (fixed NTFS writing with macfuse and NTFS-3G)
Sound
LAN (Used fix above, but needed to add sudo before rm and kextcache and then reboot)
Brightness (fixed using shades application and mapping function keys to control)

And things that don't (yet)

Sleep (fixed sleep when lid is closed using insomniax)
Memory card (SD or MS)
Front buttons
volume shortcut keys
Fingerprint reader

If anyone knows how to fix sleep or memory cards this would make the install complete as the other problems are minor.

Anybody wants me to try other programs/fixes let me know.

#5
funmacos

funmacos

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Hi All,
I have a Sony Vaio . I installed 10.5.5. Following the steps in the tutorial the installation goes through like breeze. But it asks to reboot and then it cannot come up as a MAC.

Any ideas on what I am not setting up or any other step I should do to make it boot as MAC.

Thanks for any input :hysterical:

#6
mperrett

mperrett

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Hi

Could you clarify which Sony model and what version of 10.5.5 you tried? My version was iPC 10.5.6.

Just to update all I downloaded VMFusion trial and installed it and vista (no hardware VM on my TZ tho...) It works fine for C++ programming but its a little slow at times, that could just be vista.

Marc

#7
funmacos

funmacos

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Hi All,

The Sony Vaio is VGN-S270B with Intel Centrino And Graphics by ATI.

Thanks for any help.

Hi All,

The Sony Vaio is VGN-S270B with Intel Centrino And Graphics by ATI.

I tried to install the iDeneb 10.5.5 as per installation guide at
http://tgrounds.blog...1055-on-pc.html


Thanks for any help.

#8
spenny1

spenny1

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Hi all

I have a Sony Vaio VGN-FS115Z and was wondering if anyone else has had any luck on installing iPC 10.5.6 on this. The system specs are:

NVidia GeforceGo 6200 128Mb

Intel GMA915 Chipset

Realtek High Definition Audio

Intel Pentium M 1.73Ghz

1GB DDR Ram



I have installed iPC onto a Compaq Presario V4000 and that is working properly (after many a reinstall for right kexts). I have had luck installing iPC onto the Vaio and getting to the setup options with the GMA915 Graphic kext however the graphics are pretty poor, nothing like the acceleration i had with the Compaq, so i'm thinking i need the right NVidia kext. Any thoughts.



The other thing that i can figure out is the sound, i think it is ALC260 however in the iPC customize menu i only see ALC266, will this work?



Many thanks for any help



Spenny

#9
vincetan

vincetan

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
anyone has any update on experience with os x + vaio tz? :)

really wanna convert my tz over to os x

thanks!! :)

#10
mateus vieira

mateus vieira

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

So I just got in my Sony VAIO TZ 150N laptop and I have to say I love the thing, what I obviously hate is Windows (especially Vista) so I searched but couldn't really find too many threads to show a walk through of how to install 10.5.5 or 10.5.6 on it, so I set out to do it on my own.

I'm not going to go into my setup, because with all the testing I have 5 partitions on my HDD (1 Windows and 4 Leopard), but here is what I got to work so far.

Step one: Get iPC 10.5.6 obviously ; ) (I recommend FF5 Final)

2: DO NOT change anything from the stock configuration in the BIOS, leave everything as it is.
3: Boot up iPC installation. Note: I've tried it with -v -x and everything, but it works fine without any commands, so just let it boot up normally.
4: If you need to format your HDD or partition do that through Disk Utility then select the correct HDD or partition and click "Continue"
5: Click on "Customize" to customize the installation and select these options:
a: Intel GMA950
b: LegacyAppleIntelPIIXATA
c: Azalea Audio
d: Under Power Management > Power Package and Clamshell
e: PS/2 Keyboard Fix (make sure not to select PS/2 Mouse)
f: SMBIOS Resolver
g: OSx86 Tools

Then click on to install it (you can skip the DVD check). After it is finished and it restarts, eject the CD and push type in -f to make sure all the kexts are loaded up.

Go through the registration screen as you normally would.

When it boots up you'll have noticied that the screen only takes up 2/3 of the screen. To fix this restart the computer and go into BIOS and you'll see an option for "Screen Stretch", set this option to YES, now when you boot into Leopard you'll see the correct resolution already selected.

To get the battery meter working, open up System Preferences, go to Power, click on Show All then Options and select "Show in Menubar" and now you have your battery display with the correct reading!

OpenGL/Quartz GL: Go to Applications and open OSx86 Tools, click on Enable/Disable Quartz GL and click Enable. Enter password and reboot.

What works out of the box:
Bluetooth!

What isn't working right now:
Ethernet
Wifi (I ordered an Apple Airport Extreme BCM 4321 that should be here in a couple days)
Headphone/Audio
Proper sleep (the display turns off when you close the lid, but won't come back on).
Memory Card Reader

I will hopefully have everything working soon enough, I don't know how many people actually have a TZ but it's a beautiful computer that is only made complete with OS X. Hopefully this guide will help other Sony people as well. I will be updating this as I go on.

If you have another Sony laptop and need help you can PM me and I'll try to help.

Thanks and Happy Modding!


Hello.
First of all, thanks for helping us and please, excuse my bad english.

I have a Sony VGN-AR 520-E and last week I've tried to install OSX on it using Kalyway 10.5.2 , everything is fine except, sound, usb and video onboard does not work.Only off board video card works.Do you know how i can fix this problems.
Thanks in advance

#11
pipep

pipep

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Ok, after a week of working on this this is my status:

VAIO VGN-TZ16GN (it's pretty much the same of TZ160 TZ150 series)
Intel Core 2 Duo Processor U7500 (1.06ghz)
Mobile Intel 945GMS express chipset
Phoenix Bios
2gb of ram

Following above instructions i got working:

Ethernet (with pixie23 fix)
Sound, only from speakers, headphones and mic jack doesn't work (and I don't need em so doesn't matter) (out of the box)
Bluetooth (out of the box)
Both USB Ports (out of the box)
Wi-Fi (out of the box, as I bought a macbook airport card from ebay for $30 and exchanged with the original intel wi.fi card that doesn't work)

The big problem is I needed to force the computer off taking out the battery, as it hangs with the screen off, but processor and vents on, overheating itself.

The fix for this is the following:

1. Update Chameleon to 2.0 RC-3 (http://chameleon.osx86.hu/)
2. Update PC-EFI to 10.6 (http://netkas.org/) --> with an installer it updates chameleon to RC3 so u could skip number 1. --> installer: http://tonymacx86.bl...pported-by.html )
3. Follow the instructions by Voyn1x to patch your DSDT ---> http://www.infinitem...-to-dsdt-t3436/
4. Download Onyx for Leopard, unzip, install, run and go to Parameters tab -> Expose and Dashboard -> uncheck "Enable Dashboard and its widgets" ( http://www.titanium....glish/apps.html )

With this u won't be able to use the dashboard, but when u shutdown the computer it shuts down.

As a result of this workaround i have now also working:

FireWire, FingerPrints, SD and Memory Stick Slots, Video Out (VGA)

What doesn't work: Camera, Multimedia Buttons in the front right, Sleep function

Hope this helps someone, if I ever make the sleep function work i'll post it, but i won't give it much attention, as this vaio turns on in just 75 seconds.

Another cool thing is that my battery (it's new) lasts for 5:30 hours

GOOD LUCK!

#12
dreammeister

dreammeister

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hi guys,

I successfully got my TZ270/N working with the excellent guide above - well everything except the wireless.

The problem I now have is that after upgrading to 10.5.8 my sound has stopped working.

I resinstalled the Azalea Audio kext using the iPC dvd - but it does not seem to want to work..

If anyone has any idea on how to upgrade the kext to get it working with 10.5.8, I'd appreciate it.

Thanks!

DM

#13
sianto

sianto

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
I wonder whats wrong with my Vaio VGN-TZ37GN ??

I followed all your instructions here, using 10.5.6 iPC Universal PPF5 Final

However, I always get kernel panic:

(THIS SCREEN IF I DID NOT PRESS F8)
Posted Image


(THIS SCREEN IF I PRESS F8 AND -V)
Posted Image



Had 2 previous successfull attempt with my desktop pc and my twinhead notebook.
This Vaio TZ gave me headache.
What should I do?? I badly wanted an osx for my TZ....

#14
sianto

sianto

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
never mind. I got it. and without anyone helping.

#15
Hujbera

Hujbera

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

Hi

Followed the initial installation guide here and iPC worked first time. My sound also worked without issues and does the expresscard (I have a 48GB flash disk there which mounts fine). I also opened up my TZ before hand and installed an atheros WIFI card which is detected as an Airport extreme and connects fine. I am trying VMWare fusion tonight to see if I can install vista.

My logitech VX nano mouse and t-mobile Web/walk usb modem also work fine (modem is E160).

To sum up things that worked:

Wifi
Bluetooth
RF/USB mouse
Expresscard + SSD (fixed NTFS writing with macfuse and NTFS-3G)
Sound
LAN (Used fix above, but needed to add sudo before rm and kextcache and then reboot)
Brightness (fixed using shades application and mapping function keys to control)

And things that don't (yet)

Sleep (fixed sleep when lid is closed using insomniax)
Memory card (SD or MS)
Front buttons
volume shortcut keys
Fingerprint reader

If anyone knows how to fix sleep or memory cards this would make the install complete as the other problems are minor.

Anybody wants me to try other programs/fixes let me know.



Hello...



i think, how this is a little old theme, but i have a TZ, i very like it, and this comp with SSD enough for me. so beautiful computer. so the quastion, how what is the model number the atheros wifi card, what work fine on OSX. thanks the answer...

#16
incvn

incvn

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

So I just got in my Sony VAIO TZ 150N laptop and I have to say I love the thing, what I obviously hate is Windows (especially Vista) so I searched but couldn't really find too many threads to show a walk through of how to install 10.5.5 or 10.5.6 on it, so I set out to do it on my own.

I'm not going to go into my setup, because with all the testing I have 5 partitions on my HDD (1 Windows and 4 Leopard), but here is what I got to work so far.

Step one: Get iPC 10.5.6 obviously ; ) (I recommend FF5 Final)

2: DO NOT change anything from the stock configuration in the BIOS, leave everything as it is.
3: Boot up iPC installation. Note: I've tried it with -v -x and everything, but it works fine without any commands, so just let it boot up normally.
4: If you need to format your HDD or partition do that through Disk Utility then select the correct HDD or partition and click "Continue"
5: Click on "Customize" to customize the installation and select these options:
a: Intel GMA950
b: LegacyAppleIntelPIIXATA
c: Azalea Audio
d: Under Power Management > Power Package and Clamshell
e: PS/2 Keyboard Fix (make sure not to select PS/2 Mouse)
f: SMBIOS Resolver
g: OSx86 Tools

Then click on to install it (you can skip the DVD check). After it is finished and it restarts, eject the CD and push type in -f to make sure all the kexts are loaded up.

Go through the registration screen as you normally would.

When it boots up you'll have noticied that the screen only takes up 2/3 of the screen. To fix this restart the computer and go into BIOS and you'll see an option for "Screen Stretch", set this option to YES, now when you boot into Leopard you'll see the correct resolution already selected.

To get the battery meter working, open up System Preferences, go to Power, click on Show All then Options and select "Show in Menubar" and now you have your battery display with the correct reading!

OpenGL/Quartz GL: Go to Applications and open OSx86 Tools, click on Enable/Disable Quartz GL and click Enable. Enter password and reboot.

What works out of the box:
Bluetooth!

What isn't working right now:
Ethernet
Wifi (I ordered an Apple Airport Extreme BCM 4321 that should be here in a couple days)
Headphone/Audio
Proper sleep (the display turns off when you close the lid, but won't come back on).
Memory Card Reader

I will hopefully have everything working soon enough, I don't know how many people actually have a TZ but it's a beautiful computer that is only made complete with OS X. Hopefully this guide will help other Sony people as well. I will be updating this as I go on.

If you have another Sony laptop and need help you can PM me and I'll try to help.

Thanks and Happy Modding!


i followed this guide, almost all work, but headphone doesnt work only from the speaker, sleep not work , cannot wake up from sleep ! brighness cannot be controlled !

pls help me to fix , many thanks and happy new year !!!!!!!!!

#17
jaymonkey

jaymonkey

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
  • Location:England - UK
Hi Ramper,

Following your great guide I managed to install IPC 10.5.6 on my Sony SZ-1XP/C

This was the only method that worked to get a running very stable OSX system.
Thank you very much for posting your Guide.

Sound working using AppleHDA Patcher :-
http://www.insanelym...showtopic=32859

And This Script:-Attached File  STAC9225.txt   5.66KB   9 downloads

Now dual booting with Windows 7 using Boot Think - makes for a very usable system

Some questions :-

Have you had any Luck in updating to 10.5.8 ?
Or Even Snow Leopard 10.6.X ?

I'm getting anther hard drive to clone my existing system before attempting any updates but would be interested in hearing about your (or anyone else's) experiences with Sony TZ or SZ (same motherboard).

Cheers
Jay

#18
rampar

rampar

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

Hi Ramper,

Following your great guide I managed to install IPC 10.5.6 on my Sony SZ-1XP/C

This was the only method that worked to get a running very stable OSX system.
Thank you very much for posting your Guide.

Sound working using AppleHDA Patcher :-
http://www.insanelym...showtopic=32859

And This Script:-Attached File  STAC9225.txt   5.66KB   9 downloads

Now dual booting with Windows 7 using Boot Think - makes for a very usable system

Some questions :-

Have you had any Luck in updating to 10.5.8 ?
Or Even Snow Leopard 10.6.X ?

I'm getting anther hard drive to clone my existing system before attempting any updates but would be interested in hearing about your (or anyone else's) experiences with Sony TZ or SZ (same motherboard).

Cheers
Jay


Glad you were able to use it, but I got rid of that laptop a long time ago and haven't tried anything afterwards.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy