Jump to content

ACER 5930G LAVORIAMO SU I KEXT AUDIO


  • Please log in to reply
66 replies to this topic

#1
maxpaine

maxpaine

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
ciao!
diciamo che sono arrivato ad avere un ottimo Hackbook!
l'unica pecca è la scheda audio che funziona solo l'uscita delle casse e basta...
non funziona: il subwoofer, la presa microfono, la presa cuffie e la presa spdif.
io ho instllato i driver AZALIA alc888.
direi di provare gli ALC888 Address 0 ma non sono riuscito a trovarli.
qualcuno di voi è riuscito a far funzionare degnamente questa scheda audio?
grazie a tutti. :D

#2
ugokind

ugokind

    InsanelyMac Deity

  • Donators
  • 1,712 posts
  • Gender:Male
  • Location:10100
  • Interests:Apicoltura
    Mac
    Linux
    Homebrew
    Australia
    Spremermilcervello
ciao max

segui i miei post
io ho i codec verbs della ns scheda..
ho testato il taruga patch con i ns codec.. mi crea le voci ma non si senten nulla

ieri ho testato i driver audio per le schede madri che montano intel 45.. che hanno alc1200.. stesso risultato

puntroppo le istruzioni di the king sono lacunose.. io sono arrivato ad avere i nodi e i numeri di interconnessione.. ma poi non so dove mettere i dati.. e le stringhe generate..

se qualcuno mi dicesse come creare i dati da mettere nel driver.. sarei a cavallo


iiihhhhhhh

#3
giucan

giucan

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
Salve ragazzi, scusate l' ot, ma voi avete risolto il problema del freeze all' avvio? Anche io sono sulla buona strada per raggiungere un ottimo risultato con questo laptop, ma quando arrivo alla schermata della mela si blocca (prima che inizi a ruotare quella rotellina) e devo riavviarlo 5 o 6 volte prima che parta.
Per quanto riguarda l' audio anche io mi ritrovo nella vostra stessa situazione e ho provato i kext appleazalia postati da pameloanderson.
P.S.: un sentito ringraziamento a ugokind per aver segnalato la soluzione per il kext ethernet yukon 880E8071.
Ciao a tutti.

#4
ugokind

ugokind

    InsanelyMac Deity

  • Donators
  • 1,712 posts
  • Gender:Male
  • Location:10100
  • Interests:Apicoltura
    Mac
    Linux
    Homebrew
    Australia
    Spremermilcervello
solo un appunto.. il freeze o non mela rotante può essere uno stallo dopo aver caricato o meno il driver appleahci.. per l'accesso al boot device.

vedi di capire che versione hai.. o meglio.. se riesci con macdrive a legere il system.log .. le ultime righe.. ed a postarcele.

così da capire come e perchè.

poi visto che il nostro laptop è davvero mistico.. proporrei ai 5930g di crearci un ns piccolo db di driver per fare tuning .. e magari creo un calderone in cui metterceli.

anche perchè io ora sto ancora cercando una stabilità al kernel 9.5 xnu voodoo.. ma un mese fa il voodoo2 9.6 più o mneo andava.. ma dopo tutte queste modifiche ora non parte più quindi ci sono ancora tante cose da fare.

io ora mi sto trastullando sul power/battery/bundle di power management/sleep.. che e certamente non perfetto..
perfetto per me vuol dire che deve non solo vedere la batteria.. ma nel pannello di controllo in energy saver deve funzionare bene tutto.. senza intoppi. e deve andare in stop lampeggiando il led dell'accensione in arancione.. e risalire perfettamente.
un mese fa lo faceva.. ora non più-

altro punto critico:
-lavorare con applesmbios.. con o meno un resolver.. che sappia gestire bene il ns chipset
-che sappia fornire i dati corretti al sistema
-dsdt.aml... ne ho 3 funzionanti .. .ma alla fine non so come 'valiare' la loro bontà.

#5
giucan

giucan

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
Innanzitutto Ugokind grazie per la celerità della tua risposta e per l' impegno che profondi in questo magnifico progetto. Per il resto volevo dirti che momentaneamente sto provando ad installare la ideneb 1.4, ma senza risultati; direi che andava molto meglio la 1.3 10.5.5, anche se col problema del freeze, che effettivamente si verificava dopo una scritta del tipo appleahci.
Appena rimetto la 1.3 ti farò sapere.
Ciao e tante grazie ancora

#6
hasai

hasai

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 171 posts
  • Gender:Male
  • Location:Ragusa
Salve per l'audio sonon combinato come voi, ho provato tutti acl888 possibili e immaginabili ma niente, ma quanto riguarada che ogni tanto all'avvio non parte e si deve riavviare, come avete risolto Grazie

#7
ugokind

ugokind

    InsanelyMac Deity

  • Donators
  • 1,712 posts
  • Gender:Male
  • Location:10100
  • Interests:Apicoltura
    Mac
    Linux
    Homebrew
    Australia
    Spremermilcervello
ricordatevi l'appledecrypt

posto il mio ahci..

anche io ho provato tutti gli alc ma proprio tutti.. per qesto dico che va creato uno ad hoc.. per noi
non serve provare un alc 888 comunque.. perchè quelli che girano sono per rel standard a 5+1 credo.. per motherboard e non laptop

ricordo che da vista noi abbiamo 4 casse + subwoofer.. e l'hda in pratica da come ho letto nei codec verbs è un canale che passa trasversalmente su ingressi e uscite.. e ci sono 5 nodi con lo stesso codice.

dobbiamo sforzarci di completare la procedura di the king

#8
maxpaine

maxpaine

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
qualcuno di voi ha provato l'AppleDHAPatcherv1.20
se volete provare ve lo posto....
oggi io non riesco.
fatemi sapere....

P.S. un ringraziamento particolare a UGOKIND per il lavoro che sta svolgendo!

Attached Files



#9
ugokind

ugokind

    InsanelyMac Deity

  • Donators
  • 1,712 posts
  • Gender:Male
  • Location:10100
  • Interests:Apicoltura
    Mac
    Linux
    Homebrew
    Australia
    Spremermilcervello
ovviamente si.. è quello che ho scritto e fatto .. non ha funzionato.. ovvero ha funzionato generando un kext .. ma il kext non produce suono

questo PERCHE' il taruga patch non crea un driver ma modifica un kext predefiniti per schede che non sono nel ns standard!

#10
ido82

ido82

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
salve a tutti :)

anche io ho un Acer 5930g, però ho parecchi problemi: ho provato ad installare quasi tutte le versioni (ideneb, xxx, ipc) ma l'unica con cui sono riuscito ad avviare è stata la iatkos 5i, tutte le altre si bloccavano su: appleusbechi unable to initialize UIM. ho provato anche a fare una installazione retail, ho masterizzato il generic.iso e cambiato col dvd retail di leopard 10.5.6, ma si pianta allo stesso errore.

con iatkos invece molto spesso non si avvia, e si pianta su apple ahci qualcosa, ora non ricordo bene, oppure su un errore vga, in pratica le rare volte che mi parte devo mettere -x come flag di avvio.

qual'è il modo migliore per installare macosx su questo pc senza che poi si blocchi all'avvio?  :rolleyes:

per quanto riguarda le periferiche, per ora sono riuscito ad installare solo una chiavetta wifi usb, e l'ultima iatkos l'ho installata su un disco usb, e non mi vede né hd né lettore dvd  :)

non si potrebbe fare un topic per questo portatile con i vari kext e le procedure per installarli?

#11
ugokind

ugokind

    InsanelyMac Deity

  • Donators
  • 1,712 posts
  • Gender:Male
  • Location:10100
  • Interests:Apicoltura
    Mac
    Linux
    Homebrew
    Australia
    Spremermilcervello
si che si può fare.. ma vedi a mio modesto parere è un casino .. perchè molti credono di avere la soluzione.. ma non esiste.
infatti io ho installato bene solo la lawless 10.5.4-- le ideneb.. iatkos..leoall.. ipc.. xxx.. non mi sono mai andate bene.
tu sei riuscito con iatkos.. e un altro è roiscito con ideneb

questo vuol dire che ci sono molte strade per arrivare al risultato.. e molte combinazioni di kext che tra loro vanno bene

occorre affinare prima di postare un kext dato per certo.. come ho detto a giorgio-multi.. mettere un kext con numero di release (da info o version.plist) con un flag se è patchato o moddato o se è nativoo se è legacy. e magari un pezzo di ritaglio del system.log o dmesg che riporti come os ha caricato il driver..
allora sarebbe corretto e utile.. altrimenti faresti come me che butti su una patela di kext di altri che dicono.. tutto bene e poi invece a te non vanno! non solo perdi tempo ma dopo 2 settimane hai una cartella extensions che è un colabrodo e non sai come tornare indietro.

#12
maxpaine

maxpaine

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts

si che si può fare.. ma vedi a mio modesto parere è un casino .. perchè molti credono di avere la soluzione.. ma non esiste.
infatti io ho installato bene solo la lawless 10.5.4-- le ideneb.. iatkos..leoall.. ipc.. xxx.. non mi sono mai andate bene.
tu sei riuscito con iatkos.. e un altro è roiscito con ideneb

questo vuol dire che ci sono molte strade per arrivare al risultato.. e molte combinazioni di kext che tra loro vanno bene

occorre affinare prima di postare un kext dato per certo.. come ho detto a giorgio-multi.. mettere un kext con numero di release (da info o version.plist) con un flag se è patchato o moddato o se è nativoo se è legacy. e magari un pezzo di ritaglio del system.log o dmesg che riporti come os ha caricato il driver..
allora sarebbe corretto e utile.. altrimenti faresti come me che butti su una patela di kext di altri che dicono.. tutto bene e poi invece a te non vanno! non solo perdi tempo ma dopo 2 settimane hai una cartella extensions che è un colabrodo e non sai come tornare indietro.

ciao,
Io non mi posso lamentare della mia installazione!
Parte 9 volte su 10, e se non si avvia... Basta riaccenderlo e parte senza problemi!
Funziona quasi tutto, ho installato circa 30gb di programmi!
Ho sostituito la wi-fi con una Apple AirPort N, l'unico problema è la scheda audio!
Ho un installazione pulita xchè le prove le faccio su un HD esterno dove ho installato leopard.
Ti volevo chiedere una cosa: ma la Lawless non e per server AMD?
Ciao

#13
ugokind

ugokind

    InsanelyMac Deity

  • Donators
  • 1,712 posts
  • Gender:Male
  • Location:10100
  • Interests:Apicoltura
    Mac
    Linux
    Homebrew
    Australia
    Spremermilcervello
no.. non mi pare!
la cosa furba del lawless (tolto forse ipc)
è che nel dvd c'è una succosa cartella extensions.. e non solo l'mkext.. in modo tale da gestire una rosa maggiore di possibilità in boot.. e di hw

hai ragione.. allora proviamoci

#14
maxpaine

maxpaine

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts

Salve per l'audio sonon combinato come voi, ho provato tutti acl888 possibili e immaginabili ma niente, ma quanto riguarada che ogni tanto all'avvio non parte e si deve riavviare, come avete risolto Grazie

ciao, ho visto che hai montato le ddr2 800 vanno bene?
Anche io volevo provare!
Però non sapevo se andavano bene, secondo te le ddr a 1066 saranno supportate o il limite x il nostro notebook è 800?
Grazie!

#15
Anygraf

Anygraf

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
  • Location:Roma - Italia
Ciao MaxPaine io ho un acer aspire 6930g e ho problemi per fargli vedere la scheda grafica.
Ho installato xxx osx86 10.5.6 perche è l'unica che ha funzionato(a parte Iatkos 10.5.4)!
Sapresti guidarmi per installare i kext per le geforce 9600 gt?
Grazie mille!!!!!

#16
OPROF

OPROF

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:Napoli
Salve a tutti ! studio su questo portatile (ACER 5930g) che sono ormai 5 mesi ! allora tutte le versioni per quando riguarda le istallazioni funzionano !
anche Leopard ORIGINALE con il BOOT-132 e Chamaleon DFE.
Allora vi chiederete perchè a me non parte il dvd ? semplicemente perchè appena carica il kext usb 2.0 situato in /system/library/extensions/IOUSBFamily/AppleUSBEHCI.kext il portatile si blocca !! perchè L'ACPI 3.0a nuovissimo indirizza gli IRQ a caso
quindi al boot darwin metteteci -legacy -v -f in questo modo partirà 8 su 10 cosi potete istallare qualsiasi relase ma ricordate, che dovete rimetterli questi comandi al boot per entrare in leopard dopo l'istallazione perchè il maledetto AppleUSBEHCI.kex sta ancora là, quindi se lo cancellate leopard non si bloccherà più ma non avrete più USB 2.0 e la bellissima WEB
se avete fatto caso, non genera ne con qualsiasi utility il file DSDT.aml che forse risolverebbe questo problema ! secondo me ci vuole un buon bios mod.
Per quando riquarda la scheda video e la relase funzionante benino e la iatkos v5 10.5.5. selezionate in drivers-vga-graphicsupdate e NVKush cosi avrete tutto l'accelerazione abilitato anche HDMI, per l'audio sono riuscito ad abilitare tutte le casse interne compreso il subwofer e l'ingresso mic se non sentite niente quando siete entrati in leopard è perchè qualcosa si è inceppato con la tabella IRQ quindi basta che mandate in stop il portatile (sleep) e al risveglio funzionerà l'audio vi lascio i miei 5 mesi di lavoro ricordate di eliminare il file ALCinject.kext che non serve per il nostro portatile.
Vi dico che non sono un esperto di unix e linux nemmeno con i forum è ne un programmatore, ma mi piace condividere questa esperienza del acer 5930g che credo che sia un buon portatile per leopard. Se qualcuno riesce con qualche novità a far funzionare bene sto acer postate e non tenetevelo solo per voi GRAZIE a tutti.

Attached Files



#17
ido82

ido82

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
grazie OPROF dei consigli per l'avvio, li proverò appena possibile  :)



Salve a tutti ! studio su questo portatile (ACER 5930g) che sono ormai 5 mesi ! allora tutte le versioni per quando riguarda le istallazioni funzionano !
anche Leopard ORIGINALE con il BOOT-132 e Chamaleon DFE.
Allora vi chiederete perchè a me non parte il dvd ? semplicemente perchè appena carica il kext usb 2.0 situato in /system/library/extensions/IOUSBFamily/AppleUSBEHCI.kext il portatile si blocca !! perchè L'ACPI 3.0a nuovissimo indirizza gli IRQ a caso
quindi al boot darwin metteteci -legacy -v -f in questo modo partirà 8 su 10 cosi potete istallare qualsiasi relase ma ricordate, che dovete rimetterli questi comandi al boot per entrare in leopard dopo l'istallazione perchè il maledetto AppleUSBEHCI.kex sta ancora là, quindi se lo cancellate leopard non si bloccherà più ma non avrete più USB 2.0 e la bellissima WEB
se avete fatto caso, non genera ne con qualsiasi utility il file DSDT.aml che forse risolverebbe questo problema ! secondo me ci vuole un buon bios mod.
Per quando riquarda la scheda video e la relase funzionante benino e la iatkos v5 10.5.5. selezionate in drivers-vga-graphicsupdate e NVKush cosi avrete tutto l'accelerazione abilitato anche HDMI, per l'audio sono riuscito ad abilitare tutte le casse interne compreso il subwofer e l'ingresso mic se non sentite niente quando siete entrati in leopard è perchè qualcosa si è inceppato con la tabella IRQ quindi basta che mandate in stop il portatile (sleep) e al risveglio funzionerà l'audio vi lascio i miei 5 mesi di lavoro ricordate di eliminare il file ALCinject.kext che non serve per il nostro portatile.
Vi dico che non sono un esperto di unix e linux nemmeno con i forum è ne un programmatore, ma mi piace condividere questa esperienza del acer 5930g che credo che sia un buon portatile per leopard. Se qualcuno riesce con qualche novità a far funzionare bene sto acer postate e non tenetevelo solo per voi GRAZIE a tutti.



#18
ugokind

ugokind

    InsanelyMac Deity

  • Donators
  • 1,712 posts
  • Gender:Male
  • Location:10100
  • Interests:Apicoltura
    Mac
    Linux
    Homebrew
    Australia
    Spremermilcervello
grazie.. domani proverò l'audio

io lo sleep ora come ora non riesco ad usarlo.. ripeto.. andava ma ora non va più e credo sia per via dei driver modirficati

allora: per il driver Appleusbehci mi senti di dire che esistono 2 versioni da tenere a mente:
la 3.2.8 e la 3.2.5.. io ho scelto la seconda .. stabile.. pertanto non ho problemi di irq.. o meglio.. non ho problemi e non sono mai andato a vedere se e come gli irq lavorano..ma COME SI VEDONO GLI IRQ??

quindi ribadisco il concetto.. io sono pronto a far vedere che il mio 5930g si spegne con sleep e riparte benissimo.. se metto il restore della partizione di un mese fa.. oggi invece non va,.. quindi la concomitanza di driver determina inevitabilmente uno o l'altro funzionamento

la risposta per quanto riguarda certe caratteristiche che sono fortemente legate al bios sono per me il primo anello.. ecco perchè come dice maxpaine non tornerei mai indietro..
io ho stravolto i driver... partendo dalla compilazione deldriver applesmbios.. con il sorgente di anv.

da qui la prova driver dopo driver del resto.. ma sentendo che questa persona ha problemi di sleep e irq.. mi sento di ribadire il concetto sacrosanto che il sistema va configurato con seria e scrupolosa attenzione .. quindi non si può dire che va tutto bene.

10 portatili identici non possono avere 10 risposte diverse.. con 10 combinaizoni di driver diversi e 10 problematiche diverse.. è inconcepibile

e quindi l'idea di postare un elenco eterogeneo di driver solo per il nome che hanno.. (senza una versione... etc) è blasfemo

quindi facciamo un reset. allora.. OPROF:

mi dici che versione di iousbfamily hai? non ha senso che si schianti così.. vedo cosa posso fare
altra domanda. come hai ottenuto il driver audio?
terza domanda.. che gruppo di rriver usi per la gestione del power management? (batteria.. poer.. disabler.. )??


ciao

#19
ugokind

ugokind

    InsanelyMac Deity

  • Donators
  • 1,712 posts
  • Gender:Male
  • Location:10100
  • Interests:Apicoltura
    Mac
    Linux
    Homebrew
    Australia
    Spremermilcervello

Salve a tutti ! studio su questo portatile (ACER 5930g) che sono ormai 5 mesi ! allora tutte le versioni per quando riguarda le istallazioni funzionano !
anche Leopard ORIGINALE con il BOOT-132 e Chamaleon DFE.
Allora vi chiederete perchè a me non parte il dvd ? semplicemente perchè appena carica il kext usb 2.0 situato in /system/library/extensions/IOUSBFamily/AppleUSBEHCI.kext il portatile si blocca !! perchè L'ACPI 3.0a nuovissimo indirizza gli IRQ a caso
quindi al boot darwin metteteci -legacy -v -f in questo modo partirà 8 su 10 cosi potete istallare qualsiasi relase ma ricordate, che dovete rimetterli questi comandi al boot per entrare in leopard dopo l'istallazione perchè il maledetto AppleUSBEHCI.kex sta ancora là, quindi se lo cancellate leopard non si bloccherà più ma non avrete più USB 2.0 e la bellissima WEB
se avete fatto caso, non genera ne con qualsiasi utility il file DSDT.aml che forse risolverebbe questo problema ! secondo me ci vuole un buon bios mod.
Per quando riquarda la scheda video e la relase funzionante benino e la iatkos v5 10.5.5. selezionate in drivers-vga-graphicsupdate e NVKush cosi avrete tutto l'accelerazione abilitato anche HDMI, per l'audio sono riuscito ad abilitare tutte le casse interne compreso il subwofer e l'ingresso mic se non sentite niente quando siete entrati in leopard è perchè qualcosa si è inceppato con la tabella IRQ quindi basta che mandate in stop il portatile (sleep) e al risveglio funzionerà l'audio vi lascio i miei 5 mesi di lavoro ricordate di eliminare il file ALCinject.kext che non serve per il nostro portatile.
Vi dico che non sono un esperto di unix e linux nemmeno con i forum è ne un programmatore, ma mi piace condividere questa esperienza del acer 5930g che credo che sia un buon portatile per leopard. Se qualcuno riesce con qualche novità a far funzionare bene sto acer postate e non tenetevelo solo per voi GRAZIE a tutti.


ecco il mio errore con i tuoi driver
Sound assertion ""( kRequestStateCORB == fCodecRequest->state ) = CORB engine stuck or response was missing"" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDAController/AppleHDAController.cpp" at line 1492 goto handler
Sound assertion "0 != err" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/IOHDAFamily/IOHDACodecDevice.cpp" at line 131 goto Exit
Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDADriver.cpp" at line 1653 goto Exit
Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDADriver.cpp" at line 108 goto Exit
Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDADriver.cpp" at line 1653 goto Exit
Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDADriver.cpp" at line 108 goto Exit
Sound assertion "0 == fPathControls" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAPath.cpp" at line 1241 goto Exit
Sound assertion "0 != result" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAPath.cpp" at line 1162 goto Exit
Sound assertion "0 != pathSet->getWidgetAmplifierGainRange ( &zeroValue, &minValue, &maxValue, &minDB, &maxDB, kPATH_CONTROL_SPATIAL_CHANNELID_Master )" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 248 goto handler
Sound assertion "0 != widget->setUnsolicited ( true )" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDACodecGeneric.cpp" at line 830 goto handler
Sound assertion "0 != widget->setUnsolicited ( true )" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDACodecGeneric.cpp" at line 830 goto handler


mio APPLEUSBEHCI:
AppleUSBEHCI:

Versione: 3.2.5
Ultima modifica: 30/01/09 14:57
Informazioni: 3.2.5, Copyright © 2000-2008 Apple Inc. All Rights Reserved.
Posizione: /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBEHCI.kext
Versione kext: 3.2.5




ti chiedo per cortesia se puoi postarmi le release dei tuoi kext.. basta un kexstat.. poichè io lo sleep non lo posso fare.. e se ti può interessare.. il blocco usb (ehci, ohci e ahci) che ti risolverebbe il tuo problema

io non uso mai -legacy e viaggio sempre a 64 bit non ho mai casini di quel tipo

acpi 3.0a? come fai a determinarlo? il driver è sempre 1.2.1--

a me nvkush da schermo nero

sto testando questa soluzione:
http://www.insanelym...p...t&p=1086872

Audio e codev verbs:
con questa utility
http://www.insanelym...p...t&p=1024515
presa da questo bel post.. che completa a mio parere le istruzioni di THE KING
http://www.insanelym...p...=137188&hl=

qui c'è scritto come inserire i codec verbs.. da una fonte certa come vista.

sto modificando il driver di Oprof..visto che le entry sono quasi esatte ma non funzionano
magari con i verbs che vista vede.. fuziona

tra l'altro chissà se si può gestire 2 verbs.. quelli dell'hdmi audio e quelli realtek che vista vede

eccoli
01171cf0 01171d11 01171e11 01171f41 01271c40 01271d09 01271ea3 01271f99 01471c10 01471d01 01471e13 01471f99 01571c1f 01571d10 01571e21 01571f02 01671cf0 01671d11 01671e11 01671f41 01771cf0 01771d11 01771e11 01771f41 01871c30 01871d9c 01871ea1 01871f02 01971cf0 01971d11 01971e11 01971f41 01a71c3f 01a71d34 01a71e81 01a71f02 01b71cf0 01b71d11 01b71e11 01b71f41 01c71cf0 01c71d11 01c71e11 01c71f41 01d71c2d 01d71d85 01d71e16 01d71f40 01e71c20 01e71d11 01e71e45 01e71f02 01f71cf0 01f71d11 01f71e11 01f71f41

00571c10 00571d01 00571e56 00571f18 00771c21 00771d01 00771e56 00771f58 00971c22 00971d01 00971e56 00971f58 00b71c23 00b71d01 00b71e56 00b71f58 00d71c24 00d71d01 00d71e56 00d71f58

#20
maxpaine

maxpaine

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts

Salve a tutti ! studio su questo portatile (ACER 5930g) che sono ormai 5 mesi ! allora tutte le versioni per quando riguarda le istallazioni funzionano !
anche Leopard ORIGINALE con il BOOT-132 e Chamaleon DFE.
Allora vi chiederete perchè a me non parte il dvd ? semplicemente perchè appena carica il kext usb 2.0 situato in /system/library/extensions/IOUSBFamily/AppleUSBEHCI.kext il portatile si blocca !! perchè L'ACPI 3.0a nuovissimo indirizza gli IRQ a caso
quindi al boot darwin metteteci -legacy -v -f in questo modo partirà 8 su 10 cosi potete istallare qualsiasi relase ma ricordate, che dovete rimetterli questi comandi al boot per entrare in leopard dopo l'istallazione perchè il maledetto AppleUSBEHCI.kex sta ancora là, quindi se lo cancellate leopard non si bloccherà più ma non avrete più USB 2.0 e la bellissima WEB
se avete fatto caso, non genera ne con qualsiasi utility il file DSDT.aml che forse risolverebbe questo problema ! secondo me ci vuole un buon bios mod.
Per quando riquarda la scheda video e la relase funzionante benino e la iatkos v5 10.5.5. selezionate in drivers-vga-graphicsupdate e NVKush cosi avrete tutto l'accelerazione abilitato anche HDMI, per l'audio sono riuscito ad abilitare tutte le casse interne compreso il subwofer e l'ingresso mic se non sentite niente quando siete entrati in leopard è perchè qualcosa si è inceppato con la tabella IRQ quindi basta che mandate in stop il portatile (sleep) e al risveglio funzionerà l'audio vi lascio i miei 5 mesi di lavoro ricordate di eliminare il file ALCinject.kext che non serve per il nostro portatile.
Vi dico che non sono un esperto di unix e linux nemmeno con i forum è ne un programmatore, ma mi piace condividere questa esperienza del acer 5930g che credo che sia un buon portatile per leopard. Se qualcuno riesce con qualche novità a far funzionare bene sto acer postate e non tenetevelo solo per voi GRAZIE a tutti.

ciao,
grazie del tuo lavoro... io ho provato il tuo kext audio.... ma non mi funziona!
il portatile non riesco a mandarlo in sleep mode (stop) perche altrimenti non riparte piu!
poi: da dove elimino il file ALCinject.kext che non lo trovo da nessuna parte?
secondo me un bios mod ci vorrebbe!!! ma chi è così esperto tra di noi da poterlo fare????
ciao...





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy