Jump to content

Clear Intel GMA950 driver download link?


  • Please log in to reply
11 replies to this topic

#1
CrArC

CrArC

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
My laptop has been running leo4allv3 for the last few months but I decided an upgrade was in order. NO 10.5.4 release has worked so far: JaS booted to blank screen, iAtkos wouldn't work after install, etc now I've got hold of iDeneb 10.5.4 it seems promising except the gma950 drivers will not work properly with the chip in the laptop.

I get no artefacts as such, instead the whole screen flickers on and off, and side to side as much as ten times a second, making it impossible to see anything.

I'm trying to get it to install without choosing video drivers (though last time I tried I got that damned blank screen) then hoping I can download a copy afterwards: maybe the older versions found on older releases.

Does anyone know where you can find these?? There's no real clear "download link here" for most drivers for OS X 86 but I can't even find one buried in a thread!

#2
geiman

geiman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 349 posts
I've got the same problem! In order to boot up properly, go into the bios of your computer and disable one core of your processor (assuming you have a core 2 duo, core duo, etc.). Then you should be able to boot up normally without any problems. I know that isn't really a fix, but its all I've been able to accomplish. It seems in the newer versions of os x, ie 10.5.4, the gma950 driver doesn't quite work. Atleast thats what I'm speculating. If anyone with more info wants to chime in please feel free.

#3
CrArC

CrArC

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
Cool, cheers for the info; didn't think to try disabling a core as all previous builds seemed to boot ok! I was fairly happy with the old drivers so, if like me you have an older distro (leo4allv3, kalyway 10.5.2) I guess we could try robbing the versions off the disks and testing those.

I've just clawed some life out of the machine and am in the process of updating it to 10.5.4 without reinstalling fresh; I'm assuming this will let me test if the drivers will ruin everything again since it would be like getting a running distro without drivers and installing the older ones off the old disks.... :D

#4
kamikaze

kamikaze

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 218 posts
  • Gender:Male
  • Location:Paris, FR

My laptop has been running leo4allv3 for the last few months but I decided an upgrade was in order. NO 10.5.4 release has worked so far: JaS booted to blank screen, iAtkos wouldn't work after install, etc now I've got hold of iDeneb 10.5.4 it seems promising except the gma950 drivers will not work properly with the chip in the laptop.

I get no artefacts as such, instead the whole screen flickers on and off, and side to side as much as ten times a second, making it impossible to see anything.

I'm trying to get it to install without choosing video drivers (though last time I tried I got that damned blank screen) then hoping I can download a copy afterwards: maybe the older versions found on older releases.

Does anyone know where you can find these?? There's no real clear "download link here" for most drivers for OS X 86 but I can't even find one buried in a thread!


You may want to check this thread http://forum.insanel...howtopic=122375

#5
binaryphr3k

binaryphr3k

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
currently i was running kalyway 10.5.1 and everything worked ethernet my gma 950 sound video time machine all worked...now i started to read alot about these kalyway updates..so out of my own stupidity i updated my machine from 10.5.1 -> 10.5.4 .....Now everything working beautifully but the only problem is that i cant change my resoulution and my mouse becomes invisible when i put it @ the Dock or on a video..(wich lags)..
and also i times it becomes invisible completly....
ive tried every natit.kext and all of paulicat's kext and none worked.....man i regret updating my machine..
if anyone has a kext that works for GMA 950 on a machine running kalyway 10.5.4.....it would be great
please i dont want to format my partition and re-install kalyway 10.5.1.....i have so many programs installed and so many files...also ive been on other forums and i get {censored}...no one reponds or tries to help me..please anyone....

#6
geiman

geiman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 349 posts
well, if you've read you can see we are having problems too. You can find kexts for intel 950 on this forum, all you need to do is search, or browse under the graphics section. Other than that you're in the same boat as many of us. os x is unstable on pc's so reinstalling is something you need to be prepared for. My advice; spend 100$ and grab an external hard drive, which you can use to make time machine backups. Then you can reinstall whenever and easily restore your programs, files, etc..

#7
CrArC

CrArC

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts

You may want to check this thread http://forum.insanel...howtopic=122375


That thread was ideal! Cheers; I replaced the GMA950 driver gma950.pkg in the iDeneb disc image, burnt a copy and was able to install 10.5.4 on my laptop successfully using the older drivers. Everything works just as well as before, but with 10.5.4 goodness :(

geiman, using Time Machine is precisely what I like to do! I use an external HDD for TimeMachine my PC, and store my OS X install on one internal drive, and most of my data on two others. On my laptop I have simply partitioned the internal HDD three ways: equal-sized splits for Time Machine and OS X and a third partition for data.

Even so, reinstalling OS X always takes a long time and restoring from time machine just as long (on the laptop at least). I am pleased Time Machine will restore apps and settings from completely different distributions, it does make it much easier.

#8
sethoramma4

sethoramma4

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
CrArC... did that kext give ur resolution changing capability? cuz i tried ideneb.. everything worked cept res change... same gma 950

qe/ci are enabled but no res change. does that do it for u?

#9
geiman

geiman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 349 posts
Yeah, time machine is pretty great, and I know it takes time but I'll gladly let it work for an hour or so if all I have to do is let it be and watch the magic happen. Anyways, so I take it you got everything working good now, does that mean you can enable both cores of your cpu without the screen issues anymore? I would love to know!

#10
geiman

geiman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 349 posts
sethoramma: I just stumbled across this at Hackint0sh forums, not sure but maybe it will work for you? It says about including the displayconfigx, so maybe that is where you're having problems. I'm no expert, so as always use caution!

http://www.hackint0s...ead.php?t=47139

#11
CrArC

CrArC

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts

CrArC... did that kext give ur resolution changing capability? cuz i tried ideneb.. everything worked cept res change... same gma 950

qe/ci are enabled but no res change. does that do it for u?


Yeah, the old GMA950 drivers did! If you did exactly the same as in that thread, maybe you selected the 'newer' old GMA drivers (remember when installing leo4all there was 'GMA950 Old' and 'GMA950 Nores'? You may have patched iDeneb with the QE/CI drivers which can't change res!!

If that's the case, rather than reinstalling first why not try grabbing the right drivers from the disc/disc image and just installing them over the nores ones? Might work!


Yeah, time machine is pretty great, and I know it takes time but I'll gladly let it work for an hour or so if all I have to do is let it be and watch the magic happen. Anyways, so I take it you got everything working good now, does that mean you can enable both cores of your cpu without the screen issues anymore? I would love to know!


Yeah, I could enable both cores using the old GMA950 drivers - in fact disabling a core hadn't made a difference for me. If I didn't select any video drivers iDeneb would hang at a blue screen on first boot after install finished.


I have since reverted to Leo4Allv3 but again, am running 10.5.4 after updating using kalyway combo update 10.5.3 and then apple software update, so still using those old GMA950 drivers, and they're still working as well as they ever did. Just out of curiosity, since i'm assuming i'm not the only laptop-toting person here, has anyone got a working battery meter on 10.5.4?? i haven't got a battery meter any more!!!!

#12
geiman

geiman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 349 posts
Yeah, I've got my battery meter working, there are 2 or 3 options, I know this one works for me, as for the others its up to you to try.

http://forum.insanel...showtopic=80425

check that out and let me know if it works for you.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy