Jump to content

macOS High Sierra - Final Release is out! (17A365)


Allan

The final release of macOS Sierra are available to download.

 

You can download it from App Store.

 

You can consult the list of useful tips created by @fantomas:

Soon we'll have the methods to create a Penboot to all Hacks.

You can use the createinstallmedia, and after the process been concluded just install Clover in your Pendrive. ;)

sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled  —nointeraction

EDIT: The list above will be constantly been updated as we got new methods and fixes.



User Feedback

Recommended Comments



Installing macOS High Sierra 17A405 on my IvyBridge was a peace of cake, but installing it on the SkyLake rig was a bit more complicated. It gave me the same OSInstall.mpkg error but the weird thing is that I did sucessfully installed it few days ago but today it was not that easy to install, but regardless here we are :D

post-1011040-0-42732000-1507387677_thumb.png

post-1011040-0-53610400-1507387678_thumb.png

Share this comment


Link to comment
Share on other sites

Installing macOS High Sierra 17A405 on my IvyBridge was a peace of cake, but installing it on the SkyLake rig was a bit more complicated. It gave me the same OSInstall.mpkg error but the weird thing is that I did sucessfully installed it few days ago but today it was not that easy to install, but regardless here we are :D

after updating  10.13 supplemental update ,the system crashed  with old webdriver..

Share this comment


Link to comment
Share on other sites

after updating  10.13 supplemental update ,the system crashed  with old webdriver..

yup, the same thing happened here, I had to do a clean install today.

 

Eversince I installed the new supplemental update I get the "System Preferences crashed" error on startup.

P.S.:

Cuda crashes on startup.

 

P.P.S.: Re-installing cuda fixed the crash

Share this comment


Link to comment
Share on other sites

yup, the same thing happened here, I had to do a clean install today.

 

Eversince I installed the new supplemental update I get the "System Preferences crashed" error on startup.

P.S.:

Quda crashes on startup

yes, i must  do a clean install today. and updated  the new supplemental update then installed new webdriver...all worksed fine now...i think it is better to switch to rx580

Share this comment


Link to comment
Share on other sites

yes, i must  do a clean install today. and updated  the new supplemental update then installed new webdriver...all worksed fine now...i think it is better to switch to rx580

to be honest I'm thinking about switching back to AMD as well.

Share this comment


Link to comment
Share on other sites

@chris1111

 

hi..

I mean ..the new installer on post #267...

 

the  "MACOSXInstaller.dmg" (available at your site)for Hght Sierra  has the update as refers the post #267?

 

and does the "MACOSXInstaller-Auto.dmg" has the new installer as referred on post #267?

thank you.

c.frio

Share this comment


Link to comment
Share on other sites

@chris1111

 

hi..

I mean ..the new installer on post #267...

 

the  "MACOSXInstaller.dmg" (available at your site)for Hght Sierra  has the update as refers the post #267?

 

and does the "MACOSXInstaller-Auto.dmg" has the new installer as referred on post #267?

thank you.

c.frio

New Installer is from Apple

Install macOS High Sierra.app

Share this comment


Link to comment
Share on other sites

Fix for ICH10 with High Sierra. Now with hot-plug support.

 

For this we need two binary patches.

First patch fix I/O error for ICH10:

4585F60F 95C289C8 83E0FE66 85C9780F 84D2750B -> 89C883E0 FE6685C9 0F98C141 08CC9090 9090750B 

With second patch will work hot-plug:

89C82540 6002003D 40200000 750C81E1 BF7FFFFF 898B5101 0000 -> 90909090 90909090 90909090 90909090 90909090 90909090 9090

With these two patches I got ICH10 with hot-plug.

attachicon.gifСнимок экрана 2017-09-30 в 14.40.42.png

 

Good luck ;)

How to apply this patch?

 

what is the dfiference between this and https://github.com/kozlek/HWSensors ?

 

greetings

Share this comment


Link to comment
Share on other sites

How to apply this patch?

If using Clover:

 

Config.plist->KernelAndKextPatches->kextsToPatch:

Name: AppleAHCIPort
Find: 4585F60F 95C289C8 83E0FE66 85C9780F 84D2750B
Replace: 89C883E0 FE6685C9 0F98C141 08CC9090 9090750B

Name: AppleAHCIPort
Find: 89C82540 6002003D 40200000 750C81E1 BF7FFFFF 898B5101 0000
Replace: 90909090 90909090 90909090 90909090 90909090 90909090 9090

If not using Clover, manually edit AppleAHCIPort with a hex editor

Share this comment


Link to comment
Share on other sites

If using Clover:

 

Config.plist->KernelAndKextPatches->kextsToPatch:

Name: AppleAHCIPort
Find: 4585F60F 95C289C8 83E0FE66 85C9780F 84D2750B
Replace: 89C883E0 FE6685C9 0F98C141 08CC9090 9090750B

Name: AppleAHCIPort
Find: 89C82540 6002003D 40200000 750C81E1 BF7FFFFF 898B5101 0000
Replace: 90909090 90909090 90909090 90909090 90909090 90909090 9090

If not using Clover, manually edit AppleAHCIPort with a hex editor

 

Can this patch run fine with Z270 mobos?

Share this comment


Link to comment
Share on other sites

How to apply this patch?

 

what is the dfiference between this and https://github.com/kozlek/HWSensors ?

 

greetings

 

 

Slice's FakeSMC apparently has fix for EmuVariableUefi-64 which leads to OSInstall.mpkg error. Unsure about the other.

 

Sent from my SM-G930F using Tapatalk

 

 

I didn't know that there was a new version from Kozlek, I had lost location services when upgraded to HS. However, now it's working again, I don't know what that was about, is there any relation with FakeSMC and location services?

 

Anyway, thank for pointing out that :)

Share this comment


Link to comment
Share on other sites

How do you guys enable trim on High Sierra with APFS? And do you? I've read about some problems (long boot?) if trim command is used in Terminal, so I am still running my APFS SSD without it.

Share this comment


Link to comment
Share on other sites

How do you guys enable trim on High Sierra with APFS? And do you? I've read about some problems (long boot?) if trim command is used in Terminal, so I am still running my APFS SSD without it.

TRIM enabled by default.. maybe just on nvme

Share this comment


Link to comment
Share on other sites

in kexts to patch

IOAHCIBlockStorage

f

00415050 4c452053 534400

r

00000000 00000000 000000

How do you guys enable trim on High Sierra with APFS? And do you? I've read about some problems (long boot?) if trim command is used in Terminal, so I am still running my APFS SSD without it.

 

post-468967-0-08729700-1507464842_thumb.png

Share this comment


Link to comment
Share on other sites

Someone told me that "We are in a great Forum, so, let's have some fun and learn from each other!"

So, I wanna share my stories after re-installing APFS-10.13 (17A365) with SIP: Enabled from pre- till post-install succeeded:

 

1. Installer: (OFC) a Retail macOS 10.13 downloaded from Mac App Store. USB Installer using createinstallmedia or Boot Buddy (GUI)

 

2. Bootloader: Using Legacy Clover v2.4k r4243 w/o rc.script I got no "OSInstall.mpkg" missing / corrupted error again, though with "RecoveryHD" environment looks a like installation UI with no Languages selection chooser as a greeting. For SMBios is MBP10,1 with default values generated by Clover Configurator v4.5.3. And still same since DP1, I removed nvram.plist found from all my partitions before proceeding (there're already another OSes installed on a single Disk)

 

3. Graphics: My Nvidia Fermi GF119 however has known issue with random windowserver crash since 10.12 using native / web driver, though QE/CI was enabled. I then tried reconfiguring it using Web Driver with SIP: Enabled (no longer need for NVWebValidationFix) and yeah, same crash with non-native display resolutions but get much better: my crazy cursor behavior has gone! Oh wait, just a little bit problem with abnormal logoff-reboot-shutdown except replacing NVDAResman.kext with DP1 has (for sure, not applied for web driver). It works well on 10.11.x as my daily use with InjectNvidia=True/False or with GFX0 Graphics personalities within my patched DSDT, just forget it under newer macOS versions.

 

4. TouchPad (PS2 ELAN_101): This is I think, the funny part or maybe sounds illogical... using EmlyDinesh's ApplePS2SmartTouchpad v4.7 b5 since 10.13 DP1 I got a blank trackpad under Preferences, my TP however still detected as a mouse (previously was using 10.11.6's trackpad.Pref for temp solution to work). At the first time reaching the Desktop after did a clean install, I then accidentally connected my USB Mouse to the port and voilaaa... my TP Pref no longer became blank and all features are back again automatically illogically..!!! I think I loss my mind, then turning my wifi on.. and yes, now get motion video guides on TP Pref.

 

5. Battery: Using @Slice's FakeSMC v3.5.0 and VoodooBattery v1.4.2 the indicator shown on Apple Menu Bar.

 

My another devices fortunately (as seen on sig), just work except AR3011 BT, known incompatible RTL-CardReader, WebCam works with CamTwist, but.. aah, NP.

That is guys for my "stories", not a successful guide nor even tutorial so.., if U don't mind just simply, ignore it..!!!  :P. This concludes my 17A365 (I mean, on my mach) before updating to 17A405 and going to be 'crazy' again, happily.

 

#EDIT: Plz note regarding to SIP: Enabled, I only use this on Legacy..!!!

post-826765-0-31064300-1507471806_thumb.png

post-826765-0-54774900-1507471891_thumb.png

Share this comment


Link to comment
Share on other sites

@Badruzeus

 

Can you please tell me the value of the CsrActiveConfig that you are using? I assume by "SIP:Enabled" you are referring to that config. Right?

Share this comment


Link to comment
Share on other sites


×