Jump to content

Mac OSX86 Leopard on Vaio SZ7


alhinai
 Share

18 posts in this topic

Recommended Posts

Has anyone managed to get Leopard installed on their SZ yet? I have got the Kalyway 10.5.1 release ISO as I heared that this is the easiest release to install on most of the PCs/laptops with most of the required drivers included. However, I have attempted to get it installed on my Vaio SZ791 for 6 hours last night but did not suceed. The installation goes thorugh normally until the last reboot where it freezes on the gray screen with the small dark apple logo in the center.

 

I am trying to get it to dual boot with vista on the same HD. I have formatted the OSX partition with apple disk utilities with MAC OSX Journaled option. In Kalyway I have tried all different combination of options including, the vanilla option with the F8, however nothing worked. I am getting the same results no matter what customization options I select.

 

Anyone knows the correct steps to get Kalyway release installed on a Vaio SZ? any help would be highly appreciated.

Link to comment
Share on other sites

Maybe......

 

During the install there is an option to remove AppleIntel CPU Powermanagement, DO this and then DON't load any drivers until you have booted at least once! you can always load the later! Try this minimal approach and eliminate the obvious causes! I think it might be the Powermanagement....

 

SticMAN

 

Has anyone managed to get Leopard installed on their SZ yet? I have got the Kalyway 10.5.1 release ISO as I heared that this is the easiest release to install on most of the PCs/laptops with most of the required drivers included. However, I have attempted to get it installed on my Vaio SZ791 for 6 hours last night but did not suceed. The installation goes thorugh normally until the last reboot where it freezes on the gray screen with the small dark apple logo in the center.

 

I am trying to get it to dual boot with vista on the same HD. I have formatted the OSX partition with apple disk utilities with MAC OSX Journaled option. In Kalyway I have tried all different combination of options including, the vanilla option with the F8, however nothing worked. I am getting the same results no matter what customization options I select.

 

Anyone knows the correct steps to get Kalyway release installed on a Vaio SZ? any help would be highly appreciated.

Link to comment
Share on other sites

Has anyone managed to get Leopard installed on their SZ yet? I

 

Anyone knows the correct steps to get Kalyway release installed on a Vaio SZ? any help would be highly appreciated.

 

 

Leo happily installed on a Sony SZ5 (see sig)... runs VERY well... since this install was a while back, I can only remember the following detail: I had JAS 10.4.8 on the Sony first, and installed Kaly 10.5.1 OVER that install.

 

ALSO of course you should install only with STAMINA mode switch, as the GMA950 is easily supported. Your model has a different GPU than my SZ5.

Interestingly enough, I can even boot with my nvidia7400 activated ("SPEED" switch), but then no QE/CI.

Haven't bothered tweaking that since STAMINA mode more than quick enough and the choice for watching DVDs on battery anyway.

 

The install was really not tricky at all, as long as you are careful installing EFI. I did that manually, as it seemed like Kaly's install would not always install EFI properly.

 

Besides this, I totally agree with SticMans advice: MINIMUM options first, better kexts can easily added later.

 

good luck,

ninetto

Link to comment
Share on other sites

I have a Sony SZ750n, and I have tried everything except for the Brazil method. Kalyway 10.5.2 has about 9 minutes left to install.

 

I'm using the vanilla kernel and have the X3100 Drivers selected along with the power management patch.

 

Havn't had much good luck with this thing as far as video, sound, and networking go. However, the bluetooth seems to work just fine.

 

NOTE: This thing has a hard-switch where you can select the X3100 (stamina) or the 8400gs m (speed).

So far I have only been able to get proper rez with an external monitor using NVinject.

Now I'm trying for the slower, built-in X3100, but hopefully I can get native res on internel monitor this time.

 

I also selected the 667 SM bios patch...

 

My goal is to have a portable Final Cut Pro rig...

One of the coolest things about the Sony SZ7 is that it had an expresscard slot as well as a regular cardbus slot, on opposite sides of the notebook, and the express card is not the kind that looks like the cardbus, but is smaller on the inside... it's a real seperate slot...

The whole reason I think this feature is great is because I will be able to ingest 3 P2 cards on location from the Panasonic HVX200 HD-CAM at the same time into Final Cut Pro... dope..

 

I just hope I can get it all working.. I'm new to this whole Mac thing, but I've been an A+ Windows nerd since I was a squirt.

Link to comment
Share on other sites

  • 3 weeks later...
  • 2 months later...
  • 1 month later...
  • 2 months later...

i got my SZ79GN/C to work almost perfectly

just a few thing that won't work

like motion eye, it stopped working since i patched the GMA X3100

internal card reader(use the one sony provided instead)

swap out the 4965agn with broadcom draft n work like a charm

sleep shut down work out of the box

can use computer up to 3 hours and a half

here is my hardware configuration

Intel Core2duo T9300 @2.50GHz WOB

Ram 1GBx2 WOB

Hdd250GB WOB

DVD-RAM WOB

Motion Eye won't work after patch GMA X3100

Bluetooth WOB

Broadcom 4321 N WOB

Marvell Fast Ethernet Need A little bit modification

Finger Print recognized but can't find a solution to make it works just yet

Intel X3100 patched worked need an external monitor and switchresx

8400M GS worked with external monitor only not recognize internal LCD at all (help would appreciated)

internal Memory Card Reader doesn't recognize so far i have no need of that

 

if any of Vaio SZ user want a guide i would make one

anyway just want to give some information

i'm using kalyway 10.5.2 to install

after finish install enter single user environment

and delete all AppleIntelGMA and AppleIntelIn*.kext

Link to comment
Share on other sites

  • 3 weeks later...

Hey,

 

I have Vaio SZ58 and a copy of kalyway 10.5.2. Havent tried installing just yet though as wanted to know all the pitfalls beforehand.

 

Should I not bother with 10.5.2 and rather get the latest version?

 

The guide to install on SZ would be most helpful.

 

Thanks.

Link to comment
Share on other sites

Marvell Fast Ethernet need to add device id in order to make it works

 

as i'm totally new to editing kexts, could you please provide the information what EXACTLY needs to be done to get the Marvell giganet to run?

 

thank you very much,

Gekko :jester:

Link to comment
Share on other sites

  • 2 weeks later...

This is a message for Titan...

Hi.. I saw your post about getting your Vaio SZ79 working with Leo using Kalyway 10.5.2

I have an SZ38 and would like to do the same.

Can you share your installation instructions with me???

i dont know whether it is appropriate (as i am new here in the forum)... but you can send me the instructions at my userid here at yahoo dot com...

 

THanks so much....

Link to comment
Share on other sites

seriously.. has anyone succeeded in installing osx86 on a sz7 machine?

i'm currently debating on giving it a try...

which one would be more suitable?

 

ideneb 1.3 - kalyway 10.5.2 - iatakos ?

 

thanks

 

btw. i already tried installing kalyway, however i couldn't get the internal lcd to work.. seems to be a common problem

does anyone know a fix for that problem?

Link to comment
Share on other sites

I am in a similar place...

 

I am looking at dual booting Vista and OSX on an SZ-650n/c

 

So I wanted to know:

 

A) which version is better for my system; Ideneb 1.3 or Kalyway 10.5.2 or Iatakos ??

 

B) Is there a driver for the 8400m GS on OSX?

 

Could some one please assist me with this, I am completely new to the whole OSX86 thing and could really use the help on this.

Link to comment
Share on other sites

ok. i have tried ideneb 1.3 and none of the configurations seem to have worked- always gets stuck while booting on the gray apple logo

with kalyway and iatkos i am experiencing problems with the graphics card...

so there is one left: JaS (10.5.2 or 10.5.4)

any configuration suggestions?

 

thanks

 

edit: ok kalyway 10.5.2 seemed to install just fine

 

works in speed mode only with an external screen

heard that you would need to patch the x3100 to get the

internal screen to work..

how do you do that??

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 year later...
 Share

×
×
  • Create New...