Jump to content
sonotone

Dell Laptops Post-installer - XPS, Inspiron, Vostro, Lattitude

1,017 posts in this topic

Recommended Posts

I have a Vostro 1400 laptop, and I'm wondering how to use/configure the AppleSMBIOS. After I install and reboot, my computer gets stuck on a blue screen with the cursor. Anything I can do before I try to install again?

 

(About my hackintosh: Dell Vostro 1400; Intel Core 2 Duo; No webcam; STAC 9228 audio)

Share this post


Link to post
Share on other sites
Advertisement
I would recommend you to use a software called Ukelele ( http://scripts.sil.org/cms/scripts/page.ph...&id=ukelele ).

It is a keyboard layout editor.

 

There is a FAR easier way to do this that doesn't involve any third party software. Open up system prefs and go to keyboard and mouse. Once there, click the Keyboard tab and then select the modifier keys button. This will allow you to switch the Alt and windows key easily by switching the option and command keys. You can even change it per keyboard as well.

Share this post


Link to post
Share on other sites

These forums are great, but I do get lost in all the information. Good example is I just stumbled onto this topic.

 

I spent a lot of time last night installing 10.5.2 and upgrading to 10.5.5. I found out my problem was the infamous CPU=1 flag needs to be set or I get the jerky inconsisant handling. Yet my sound still doesn't work. I hope this installer works on my STAC9200.

 

My question is the duo core thing. I looked at the image of the installer, and am I correct in seeing that 9.5 for my 10.5.5 is not yet there? Does this mean I have to manually do this process as stated in this topic: http://forum.insanelymac.com/index.php?showtopic=117558 ? Also would vanilla kernel work on my machine? I have a Latitude D420 (Intel Core Duo U2500 1.2 GHz 2MB L2 Cache, 533 MHz FSB (Speedstep, SSE3)).

Share this post


Link to post
Share on other sites

I am hopelessly confused. (I never thought too much information would have been so detrimental.) I've downloaded the .iso file from the OP but I honestly don't know what to do with it. Do I need to burn the ISO to a CD and then re-install OSx86? I'm not adverse to reading instructions so even an RTFM link would be greatly appreciated. I've read through the first 7 or so pages of this thread but still was unable to determine the proper next steps.

Share this post


Link to post
Share on other sites
i've got this 2 errors. what is the problem?

os kalyway 10.5.2

 

problem is files permissions with packagemaker3...

To fix it copy kext from /System/Libray/Extensions to your desktop then install them with kext helper.

I've reuploaded a fixed intallation package.

My question is the duo core thing. I looked at the image of the installer, and am I correct in seeing that 9.5 for my 10.5.5 is not yet there? Does this mean I have to manually do this process as stated in this topic: http://forum.insanelymac.com/index.php?showtopic=117558 ? Also would vanilla kernel work on my machine? I have a Latitude D420 (Intel Core Duo U2500 1.2 GHz 2MB L2 Cache, 533 MHz FSB (Speedstep, SSE3)).

 

The screenshot is old but the 9.5 kernel is inside.

Share this post


Link to post
Share on other sites

Hey Sonotone,

 

Was wondering....is the nvidia geforce go you are using the modded one to allow for vga out? When I use this I have still been updating with the one I got...

 

I have given it to many people and it works for everyone who has grabbed it so far :D

 

And this one is to ANYONE,

 

Fix for the broadcom ethernet problem? What about display sleep? Has anyone had any luck with those issues or are we still S.O.L.

Share this post


Link to post
Share on other sites
And this one is to ANYONE,

 

Fix for the broadcom ethernet problem? What about display sleep? Has anyone had any luck with those issues or are we still S.O.L.

 

have not seen anything but problems reported by other people on the same topic :D

Share this post


Link to post
Share on other sites
have not seen anything but problems reported by other people on the same topic :huh:

 

Damn....I was hoping.

 

Deceiver, what's the best install for us now? I'm still using my old original kalyway 10.5.2 disc and then updated...

 

So still using darwin and pcefi. No chameleon or anything. Would love move onto that, put the kexts we need in there and not have to worry about updates :lol:

Share this post


Link to post
Share on other sites
Damn....I was hoping.

 

Deceiver, what's the best install for us now? I'm still using my old original kalyway 10.5.2 disc and then updated...

 

So still using darwin and pcefi. No chameleon or anything. Would love move onto that, put the kexts we need in there and not have to worry about updates :thumbsup_anim:

 

same here. I have not tried any new installs (deneb or XxX 10.5.5). I have not done a reinstall since I upgraded from 10.5.2 kalyway all the way up to 10.5.5 either. System is working nicely except sleep and broadcom. but I can live with it. I am using my laptop Vista 70/OSX 30. I may try the new XxX sometime in Dec when I have more time and see how that goes.

Share this post


Link to post
Share on other sites
same here. I have not tried any new installs (deneb or XxX 10.5.5). I have not done a reinstall since I upgraded from 10.5.2 kalyway all the way up to 10.5.5 either. System is working nicely except sleep and broadcom. but I can live with it. I am using my laptop Vista 70/OSX 30. I may try the new XxX sometime in Dec when I have more time and see how that goes.

 

For me it will be when I need to wipe and start from scratch. Since everything is working nicely here no rush. Just trying to figure this all out ahead of time. May try that instahackintosh program, throw all the kexts in there and voila. But that's only if it can use the modded dual core enabled kernel.

 

Also if powermanagement also worked properly it would be great :thumbsup_anim: No more external programs like cookbook.

Share this post


Link to post
Share on other sites

You can try the retail method. I've posted my own ISO on the first post, it should be ok for your 6400. then you install my chameleon for hard-drive, it install chameleon + DFE boot, extra folder with Extensions.kext and kexts.

Speedstep is working with last superhai kext, and it don't need any application. (included in chameleon installer)

Share this post


Link to post
Share on other sites
You can try the retail method. I've posted my own ISO on the first post, it should be ok for your 6400. then you install my chameleon for hard-drive, it install chameleon + DFE boot, extra folder with Extensions.kext and kexts.

Speedstep is working with last superhai kext, and it don't need any application. (included in chameleon installer)

 

sonotone, sorry for not doing my research on chameleon. how does this affect a dual boot with vista? is there a chance of hosing the bootloader with the chameleon?

Share this post


Link to post
Share on other sites

Depend if you are with MBR or GUID partition table.

The bootloader (wiith DFE part) can't to see my XP partition on GUID table, but you can easily manage boot with easybcd under Vista.

A new chameleon is comming soon, with many merged functionnalities, i hope it will fix XP dual boot on GUID with DFE 132 support.

Share this post


Link to post
Share on other sites
Depend if you are with MBR or GUID partition table.

The bootloader (wiith DFE part) can't to see my XP partition on GUID table, but you can easily manage boot with easybcd under Vista.

A new chameleon is comming soon, with many merged functionnalities, i hope it will fix XP dual boot on GUID with DFE 132 support.

 

 

Sounds pretty sweet. Will have to give it a try the next time I have to wipe out this thing. Until then everything is working nicely :)

 

So with the iso...you boot with it....then put in the leopard disc (can it boot the leopard disc if the disc was extracted to an 8 gig usb?). After which you boot again with the iso, go into OS X and then run the post-installer to install chameleon and the other items? Or are the kexts kept within chameleon? So we can update without having to worry about breaking the damn thing? Would this load the modded kernel?

Share this post


Link to post
Share on other sites

thanks a ton to sonotone for excellent package. i have got almost everything working on dell inspiron 1520 (x3100) with IATKOS 4i. if anybody knows these two things

please help me -

1. I have installed gma x3100 from dell post installer 1.3.1. Now, my graphics works at full 1280x800 and resolution change also works well. but whenever my system boots into mac i dont get all the icons on desktop. Moreover, the right mouse click doesn't work on desktop. but as soon as i change my resolution to 1024x768, all the icons also come and then i revert back to 1280x800 so the problem solves there. Is there ny simple solution to this problem ? and i already repaired disk permission

with sudo diskutil repairPermissions /. So, plz help me.

 

2. Sleep for my dell inspiron 1520 is not working, but then also i used the "lid sleep" fix from 1.3.1 installer. Then also

the problem of sleep still exists. my laptop doesn't get sleep, when my laptop goes to sleep it doesn't come out of that.

So is there any solution to get sleep working on dell inspiron 1520 with iatkos 4i. Superhai had released some usbehci kexts for iatkos 2i. Will they work on iatkos 4i. if yes/no how to install those kext and also provide link. And also tell if installing those will stop my usb ports from working. (i dont wanna lose the whole system for getting sleep working).

 

Can lid sleep fix cause problem, if yes how to remove them. since my sleep is not working.

 

Dell inspiron 1520

IATKOS 4i

T5250 1.5 ghz

Intel g965 with gma x3100

2 GB RAM

sigmatel 9205 completel working with inbuilt mics and internal speakers (thanks to sonotone)

shutdown fix working (thanks to sonotone)

Not working :

1. Sleep ( how to fix it, Plz somebody have a look on this)

2. Trackpad scrolling not working (Plz somebody have a look on this)

3. small artifact on boot which doesnt show desktop icons + right click disabled

Share this post


Link to post
Share on other sites

i cannot change my desktop background and dont see desktop icons on my dell inspiron 1520 after installing gma x3100 frm dell post installer. i have repaired disk permissions. default wallpaper comes blue only.

if i change my screen resolution once then my wallpaper changes which i had selected before resolution change, so everytime i want to change my background i need to change screen resolution for that and also for getting all icons on desktop

Share this post


Link to post
Share on other sites

I have two Dell Latitudes a D820 and a D830.

 

I am on 10.5.2 with Guid and pc_efi_v8 for intel

 

I have not tried this new installer of yours. I have to pass cpus=1 for the D820 but I seem to be able to get around not having to pass the cpus=1 for the D830.

 

I have some idea why I don't really have to pass cpus=1 on the D830. It has ACPI SATA mode and there is some special cache chip for that sata chip not sure what its called. Those two things might actually help the CPUS shuttering issue not sure?

 

Will the latest OSX 10.5.5 and your Installer resolve the Core 2 Duo shuttering?

 

Quote

 

Installer v1.3 (updated 10/06/2008)

- Add SpeedStep support

- Add patched Kernels for Dual-Core Shuttering (tscsync)

 

 

It does say patched Kernels for DUal-Core Shuttering (tscsync) the shuttering or mouse not responding and slowness is all related to the Dell Bios so this Installer v3 has a Kernel that works around the Dell Bios issue causing this SHuttering?

 

I am hoping and have not tried yet this installer to see if I no longer have to pass cpus=1?

 

Thanks

Share this post


Link to post
Share on other sites
I have two Dell Latitudes a D820 and a D830.

 

I am on 10.5.2 with Guid and pc_efi_v8 for intel

 

I have not tried this new installer of yours. I have to pass cpus=1 for the D820 but I seem to be able to get around not having to pass the cpus=1 for the D830.

 

I have some idea why I don't really have to pass cpus=1 on the D830. It has ACPI SATA mode and there is some special cache chip for that sata chip not sure what its called. Those two things might actually help the CPUS shuttering issue not sure?

 

Will the latest OSX 10.5.5 and your Installer resolve the Core 2 Duo shuttering?

 

Quote

 

Installer v1.3 (updated 10/06/2008)

- Add SpeedStep support

- Add patched Kernels for Dual-Core Shuttering (tscsync)

It does say patched Kernels for DUal-Core Shuttering (tscsync) the shuttering or mouse not responding and slowness is all related to the Dell Bios so this Installer v3 has a Kernel that works around the Dell Bios issue causing this SHuttering?

 

I am hoping and have not tried yet this installer to see if I no longer have to pass cpus=1?

 

Thanks

 

the bios of your D830 is new enough to run with 2 cores in a C2D, the D820 is not. In this case you need to install the kernel for your 10.5.2 and you have it fixed. It is not necessary to upgrade to 10.5.5 to get both cores. I think sonotone's installer provides kernels for several builds including 10.5.2, otherwise they are listed somewhere on the forum here. sorry, don't know where at the moment.

 

tgd

 

i cannot change my desktop background and dont see desktop icons on my dell inspiron 1520 after installing gma x3100 frm dell post installer. i have repaired disk permissions. default wallpaper comes blue only.

if i change my screen resolution once then my wallpaper changes which i had selected before resolution change, so everytime i want to change my background i need to change screen resolution for that and also for getting all icons on desktop

 

I had a similar behavior on a system with no login pw. when you log off and back in does it fix itself? if yes, set a password to login and it should fix the problem.

Share this post


Link to post
Share on other sites
the bios of your D830 is new enough to run with 2 cores in a C2D, the D820 is not. In this case you need to install the kernel for your 10.5.2 and you have it fixed. It is not necessary to upgrade to 10.5.5 to get both cores. I think sonotone's installer provides kernels for several builds including 10.5.2, otherwise they are listed somewhere on the forum here. sorry, don't know where at the moment.

 

tgd

 

 

 

I had a similar behavior on a system with no login pw. when you log off and back in does it fix itself? if yes, set a password to login and it should fix the problem.

 

 

 

Thanks for the reply. So one of Sonotones Kernel in the 1.3 installer will fix the C2D in the D820? If not what search string would you suggest? I usually google it because I am not real happy with the search function in the forum.

 

Example

 

D820 10.5.2 shuttering fix site: forum.insanelymac.com

 

That search string usually gets me better results don't know why?

 

I am on pc_efi_v8 intel. Should I swich over to this new chameleon? I heard everyone is switching over to it because there is a larger support team where as the EFI is only Netkas, one person and has not updated it for a while.

 

Is CHameleon EFI like? Will this help me in the D820 C2D shuttering or only the kernel upgrade will? Or will both the chameleon and kernel upgrade together do a better job?

 

Sorry about a slightly off topic question.

 

Thanks again!!

Share this post


Link to post
Share on other sites

Hey Sonotone, I've just installed the hole Power Management pack (installer v1.3.1) in my Dell Studio 1535 with Kalyway 10.5.2.

 

After installing it, even before rebooting, while repairing permissions the machine freezed.

Now I can't get the system to boot. The only way to boot it is in safe mode.

 

Could you tell me how could I uninstall it? I see a PowerManagement.bundle in a backup folder, but can't figure out how to use it to restore to previous state.

 

Thanks in advance for your help,

 

more

Share this post


Link to post
Share on other sites
Thanks for the reply. So one of Sonotones Kernel in the 1.3 installer will fix the C2D in the D820? If not what search string would you suggest? I usually google it because I am not real happy with the search function in the forum.

 

Example

 

D820 10.5.2 shuttering fix site: forum.insanelymac.com

 

That search string usually gets me better results don't know why?

 

I am on pc_efi_v8 intel. Should I swich over to this new chameleon? I heard everyone is switching over to it because there is a larger support team where as the EFI is only Netkas, one person and has not updated it for a while.

 

Is CHameleon EFI like? Will this help me in the D820 C2D shuttering or only the kernel upgrade will? Or will both the chameleon and kernel upgrade together do a better job?

 

Sorry about a slightly off topic question.

 

Thanks again!!

 

when you start sonotone's installer there is a package item "others". Under that you will find DualCore Kernels 9.2 -> 9.5. For your 10.5.2 installation you pick the 9.2 kernel.

 

I still have efi5 or so. chameleon will not help you get rid of the problem. the kernel should take care of the stuttering.

 

Hey Sonotone, I've just installed the hole Power Management pack (installer v1.3.1) in my Dell Studio 1535 with Kalyway 10.5.2.

 

After installing it, even before rebooting, while repairing permissions the machine freezed.

Now I can't get the system to boot. The only way to boot it is in safe mode.

 

Could you tell me how could I uninstall it? I see a PowerManagement.bundle in a backup folder, but can't figure out how to use it to restore to previous state.

 

Thanks in advance for your help,

 

more

 

once you are in safe mode. go to your /System/Library/SystemConfiguration folder and delete the newly installed PowerManagement.bundle. Then copy the backed up bundle into the same folder. You may have to verify with admin password. Once done with this, go into your Utilities folder under Applications and start Disk Utility. highlight your Leopard partition on the left and then click on Repair Disk Permissions. Reboot and hopefully it will start fine.

 

But, I just realized that sonotone's installer doesn't mess with that file at all. Under the PowerManagement package only things like speedstep enabler, battery meter, lid sleep ... are listed. I am pretty sure that the IntelSpeedStepEnhancer.kext and SpeedStep application is your problem for the kernel panic. you need to get rid of these. The kext is in the /System/Library/Extensions folder. The app maybe under autostart. go to system preferences/accounts and pick your account. check the tab login items to the right and delete the entry for the speedstep application.

 

advice for next time. only choose one item in from the installer and make sure it works before choosing several and then not knowing which one caused the problem.... Also, if your system has speedstep enabled in the bios you can use superhai's kext

good luck.

Share this post


Link to post
Share on other sites

Thanks for the help, dude.

 

I restored the original PowerManagement.bundle and repaired permissions but didn't find neither IntelSpeedStepEnhancer.kext nor the SpeedStep application... and after rebooting, the kernel panic comes back.

 

Any advice would be apreciated.

 

Thanks,

 

more

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×