Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
mithrantir

[HowTo] Fix a HFS+ error

3 posts in this topic

Recommended Posts

I don't know if people still have this problem, and if they do there are a lot of versions about solving it.

 

After reading lots of solutions, this one was mine:

 

From the bootloader, i had the boot option set to /dev/hda1 which was the partition of my osx86 BUT, after a lot of searching on the internet, i found out that the boot option has to be set to the HD of osx86 and not the particular partition. So, i changed it to /dev/hda and it worked, so simple...

 

And that is after trying 762340623636356 other things that didn't worked. I suggest that if none of the solutions you have come up with does not work, try this. Also, please the rest of you forumers, give your solutions to this problem.

 

Dunno if i was helpful, i hope i was :angry:

Share this post


Link to post
Share on other sites

To OS X, devices are also known as /dev/rdisk0 (rigid disk), and /dev/disk0 - partitions often known as /dev/disk0s1 and so forth.

 

I'll try editing the boot plist, but I think my HFS+ error is more basic than that, lack of a boot sector or something.

Share this post


Link to post
Share on other sites

Yeah, i was using a boot loader installed in a disket after setting it's parameters to boot from /dev/hda1 (it came with a CD, can't remember the name sry) and i found out this "problem" that caused my HFS+ error. In other words, if you are using a boot loader, this is probably your problem. Try changing the Boot Loaders options to boot on /dev/hda (or hdb or whatever your OS X disk is)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×