Jump to content

Dell Installation Attempt


6 posts in this topic

Recommended Posts

Hello folks,


First, I hope that I am posting in the correct section to get proper help. If I am not, I do apologize.

To start off I've attempted to install Kalyway's 10.5.1 Release on my Dell XPS 410n Desktop's external HD.


The specs of my machine are as follows:

Dell XPS 410n 
Processor: Intel Dual Core E6600, 2.4ghz, 4M cache
250gb SATA HD (Internal)
(My external USB drive is 130gb(IDE I believe))
Video: Nvida GeForce 83000 GS (128 mb)
Sound: On-board Conextant CX23880
USB Keyboard and Mouse.


Here's what I've done so far with some level of success: I boot off the Install DVD using the vanilla kernel (boot: vanilla -v). I formated my external drive with a single partition (GUID partition table)... It successfully formats the drive... I chose to Install the Vanilla kernel packages, along side with the GUID EFI bootloader (no extra drivers were picked at installation). I wait 20minutes or so for Leopard to complete install. I reboot - I get a nasty kernel panic! I asked a friend, he told me to remove the NVDAResman.kext. This got me loading the GUI correctly, I thought I might have a successful install after all.. Well.. I was wrong.. and here is where I need your help!


I boot up - It starts up with the "Before you begin screen", telling me it doesn't know what my keyboard layout is. I follow the instructions to initialize the keyboard. I chose U.S as my layout (as I am a silly American..). Next screen says "Welcome".. I pick once again U.S. as my language. All seems well.. Now here's where I get stuck. I get to the "Do you already own a Mac?" prompt - I leave it at the default value (that is I don't have an existing Mac I wish to restore data from). It sits for a bit.. I see/hear my HD doing something.. mean while it gives me the colorful wheel waiting icon.. Then it starts back over from the beginning asking me to initialize my keyboard again! I go through the process once again, same result happens.


I cannot seem to get it to move on to create my account and such.. any ideas folks? Do I need to upgrade from an existing install with this release? I've tried to debug with boot -v, but it does not seem to be very helpful. I do not see any errors that would cause a complete stop..FYI once I'm in single user mode - my keyboard does work! I'm also able to do command q and shutdown the while it has the setup screens up, keyboard works - as does the mouse.


Thanks in advance for any advice you all have to offer, I hope I can get this sorted.. This is as close as I've gotten to getting osx86 up and running! Last time I attempted, I got that stupid waiting on root file system {censored}.. Found out later it was due to me having SATA drives (even though I wanted to install on USB External, installer didn't wanna boot).

Link to comment
Share on other sites

Very funny... (Honestly my first install I forgot about this - I completely reinstalled for the second time..)

But.. sorry to burst your bubble.. The machine hasn't been connected the network.. Still no go.

Link to comment
Share on other sites

Okay.. I'll try that and reinstall again ;)

I'm so darn close to getting the bugger working, haha!


This is an idea I had come to me after I got some needed sleep... I think this time I'm not going to bother installing the vanilla kernel, I'll use the patched one with the release instead.


Now a quick question - I'm sure google has the answers, but I'll ask because its on my mind as I am writing this post... Do I have to use a vanilla kernel if I'm using the efi patched bootloader (..does it just enable me to do so..)?

Link to comment
Share on other sites

*small bump*

Any ideas here - I think it is due to my USB keyboard and mouse. Does osx86 have problems with Trackball mice?

..and I can migrate to a PS/2 keyboard/mouse because my motherboard does not have PS/2 ports on it.

I get the same issues even when I don't have Ethernet enabled..

Link to comment
Share on other sites


  • Create New...