Jump to content

Driver Atheros AR5007-EG para portatil


guaditano
 Share

30 posts in this topic

Recommended Posts

¡¡¡Hola amigos!!! Una vez solventado el problema que no me dejaba entrar en el sistema, ahora me dispongo a aprender (cada día se aprende algo más) como instalarle uno por uno los drivers al portátil. Para empezar por alguno... El driver de la tarjeta wireless es la Atheros AR5007-EG, pues bien, en este estupendo foro dentro la sección Hardware and Drivers / Land and Wireless (lo malo que está en inglés y me entero poco) hay un tema abierto sobre la Atheros... ¿¿¿Qué es lo que tendría que hacer??? ¿¿¿Por dónde empiezo a meterle mano??? Veo que hay un archivo zip para bajar y un code que seguramente habrá que pegar en el Terminal, no sé si me equivoco.

 

Pido ayuda a los geniales sabios de este foro. Perdonad, pero estoy más verde que un campo de fútbol. Saludos amigos.

Link to comment
Share on other sites

¡¡¡Hola amigos!!! Una vez solventado el problema que no me dejaba entrar en el sistema, ahora me dispongo a aprender (cada día se aprende algo más) como instalarle uno por uno los drivers al portátil. Para empezar por alguno... El driver de la tarjeta wireless es la Atheros AR5007-EG, pues bien, en este estupendo foro dentro la sección Hardware and Drivers / Land and Wireless (lo malo que está en inglés y me entero poco) hay un tema abierto sobre la Atheros... ¿¿¿Qué es lo que tendría que hacer??? ¿¿¿Por dónde empiezo a meterle mano??? Veo que hay un archivo zip para bajar y un code que seguramente habrá que pegar en el Terminal, no sé si me equivoco.

 

Pido ayuda a los geniales sabios de este foro. Perdonad, pero estoy más verde que un campo de fútbol. Saludos amigos.

 

 

¡Excelente!.Publica el link que encontraste para ver que pueden hacer por tí (es que hay muchísimos topicos y guías)... :)

Link to comment
Share on other sites

Bueno, si no me equivoco de driver te lo bajas desde aquí:

 

http://forum.insanelymac.com/index.php?showtopic=61260

 

lo descomprimes y tendrás un fichero que se llama IO80211family.kext

 

lo copias a la carpeta /Systema/Librería/extensiones

 

te pedirá la clave de usuario, la pones.

 

Luego desde terminal:

 

sudo -s (clave)

 

chmod -R 755 /LEO/System/Library/Extensions/*

chown -R root:wheel /LEO/System/Library/Extensions/*

 

donde LEO es el nombre del volumen donde tienes instalado leopard

 

salud

Link to comment
Share on other sites

Bueno, si no me equivoco de driver te lo bajas desde aquí:

 

http://forum.insanelymac.com/index.php?showtopic=61260

 

lo descomprimes y tendrás un fichero que se llama IO80211family.kext

 

lo copias a la carpeta /Systema/Librería/extensiones

 

te pedirá la clave de usuario, la pones.

 

Luego desde terminal:

 

sudo -s (clave)

 

chmod -R 755 /LEO/System/Library/Extensions/*

chown -R root:wheel /LEO/System/Library/Extensions/*

 

donde LEO es el nombre del volumen donde tienes instalado leopard

 

salud

 

Creo que debes editar esto...

chmod -R 755 /LEO/System/Library/Extensions/* 
chown -R root:wheel /LEO/System/Library/Extensions/*

Link to comment
Share on other sites

A ver amigos, vamos por partes. Chinasky me comentó que me bajara el driver IO80211Family (este archivo no tiene extensión) lo descomprimiera y lo copiara dentro de la carpeta /System/Library/Extensions, hasta ahí todo correcto.

 

Luego me puse en el terminal y escribí lo siguiente:

 

sudo -s

password: <----- le introduzco el pass

 

Aquí a lo que viene a continuación le añadi "/Volumes/Leo..." como me comentó Xxp/TuX:

 

chmod -R 755 /Volumes/Leopard/System/Library/Extensions/*

perfecto

chown -R root:wheel /Volumes/Leopard/System/Library/Extensions/*

perfecto

kextcache -K /Volumes/Leopard/System/Library/Extensions/

perfecto

 

Pues bueno parece ser que ya tengo algo en camino gracias a vosotros amigos, ahora me queda por comentaros que la luz del dispositivo Wireless la tengo encendida, creo que es buena señal verdad??

 

Ahora el siguiente paso cual seria?? crear una conexión wireless, y si es así, dónde?? Estoy mirando en la sección Preferencias del Sistema - Internet & Network y me sale un asistente para crear una conexión, la pega que le pincho en Assist me... luego en Assistant... se me abre la pantalla de How Do You Connect to the Internet?? se muestra en gris sin poder elegir nada y la opción que viene como predeterminada es (I use a telephone modem to dial my ISP). Si en cambio, me voy a Go - Utilities - Airport Utility en la pantalla de Airport me pone lo siguiente (Airport Utility was unable to find any Airport base stations. Plese make sure the Airport base station you want to set up is plugged in and in range of your computer, and then click rescan to try again), aquí tambien se muestra todo en gris sin poder seleccionar Manual Setup.

 

Saludos.

Link to comment
Share on other sites

Gracias por la información wfei_hong, jolines que putada pues nada a esperar toca. Pero se me sigue quedando una duda en el aire, entonces por qué se me enciende la luz del dispositivo Wireless?? Qiere decir que he instalado bien los drivers verdad?? Podria meterle los drivers del Atheros AR5006 y me funcionaría??

 

Otra cosita amigos, como se crea una conexión Inalámbrica en el Mac??

 

Saludos amigos.

Link to comment
Share on other sites

Gracias por la información wfei_hong, jolines que putada pues nada a esperar toca. Pero se me sigue quedando una duda en el aire, entonces por qué se me enciende la luz del dispositivo Wireless?? Qiere decir que he instalado bien los drivers verdad?? Podria meterle los drivers del Atheros AR5006 y me funcionaría??

 

Otra cosita amigos, como se crea una conexión Inalámbrica en el Mac??

 

Saludos amigos.

 

Si no existe un "driver",busca el más reciente y a lo mejor lo haces funcionar así. A lo mejor te funciona...

Link to comment
Share on other sites

Gracias Xxp/TuX, probaré a ver que tal, ya te contaré. Por lo menos ya he echado andar el driver del sonido, ya los únicos que me faltan son el de la Wireless y el de la Lan. Otra cosita, estoy mirando el link que me as puesto para que lo revise y los recuadros que ponen Code son los que tendré que ir escribiendo en el Terminal, verdad?? Saludos.

Link to comment
Share on other sites

Ojo: con el update 10.5.2...

 

EDIT: Sí...Menos estos:

 

 

drwxr-xr-x   3 root  wheel  102 Feb  2  2006   IO80211Family.kext

 

total 0
<div class="codemain">drwxr-xr-x   3 root  wheel  102   Feb  2  2006 AirPortAtheros5424.kext
drwxr-xr-x   3 root  wheel  102   Feb  2  2006 AppleAirPortBrcm4311.kext

 

Aquí el autor te está mostrando como debe estar los archivos para que resulte...

Link to comment
Share on other sites

  • 4 months later...
  • 1 month later...
  • 2 weeks later...

Hola, soy bastante nuevo en esto.

Leyendo en otros post me parece que alguien puede que a encontrado una solucion, pero no os puedo ayudar mucho, ya que mi ingles es bastante pesimo, y no me atrevo a tocar mas cosas de mi Hackinston, puesto que ya lo he instalado con 10 veces.

Si alguien es capaz de hacerlo por favor que lo explique, a qui os dejo el post.

 

http://forum.insanelymac.com/index.php?sho...0&start=140

 

Esta casi al final de la pagina.

Suerte.

Link to comment
Share on other sites

  • 2 months later...
http://forum.insanelymac.com/index.php?showtopic=138351

Parece que ya lo han consegudio, la historia esta en que alguien lo traduza y explique jajaj.

 

es una solución a medias.....en el cual se trata de mantener encendida la wlan entrando a otro SO y reiniciar y entrar en leopard/tiger y utilizar el programa kismac para poner la wlan en modo pasivo....

 

bueno yo he intentado ese tuto como cien veces....en las cuales solo 3 veces me ha funcionado la wlan tienes que estar instalando y desistalando los kexts a cada rato....bueno por lo menos ese es mi caso....solo es cuestión de probar no?

 

xD

Link to comment
Share on other sites

es una solución a medias.....en el cual se trata de mantener encendida la wlan entrando a otro SO y reiniciar y entrar en leopard/tiger y utilizar el programa kismac para poner la wlan en modo pasivo....

 

bueno yo he intentado ese tuto como cien veces....en las cuales solo 3 veces me ha funcionado la wlan tienes que estar instalando y desistalando los kexts a cada rato....bueno por lo menos ese es mi caso....solo es cuestión de probar no?

 

xD

 

yo lo he intentado pero la verdad no sabia eso que dices de encender la wifi, que hay que encenderla en xp?

 

 

 

 

si sabes algo mas te agradeceria que lo explicases, de todas maneras creo que temporalmente lo mejor es buscar otra tarjeta wifi y cambiarsela.

Link to comment
Share on other sites

yo lo he intentado pero la verdad no sabia eso que dices de encender la wifi, que hay que encenderla en xp?

si sabes algo mas te agradeceria que lo explicases, de todas maneras creo que temporalmente lo mejor es buscar otra tarjeta wifi y cambiarsela.

 

oks...intentaré traducir lo que dice en el post...

First, make sure the card is on in another OS and restart. Those of you hoping to not have to dual boot are out of luck right now.

 

eso es lo importante....nos dice que primero que nada la tarjeta debe de estar encendida en otro sistema operativo y reiniciar desde ai y que para aquellos que no tengan dual boot de momento no tendrán suerte.

 

1. empezar desde 10.5.5 y con vanilla kernel..........((((según el, no se si funciones en otras versiones de leopard o con otros kernels)))

 

2. descargarse el Airport Update 2008-004 y reiniciar.

 

3. descargar e instalar el IO8211Family.kext que esta al inicio de topic http://forum.insanelymac.com/index.php?showtopic=135572 utilizar kexthelper al menos que te sientas seguro de instalarlo manualmente.

 

4. descargar e instalar Kismac trunk r319.

 

5. reiniciar. tienen un 40% de posibilidades de iniciar sin un kernel panic. simplemente vuelvan a intentar y eventualemnte va a reiniciar normalmente. ((((ojo....reiniciar......no apagar y volver a encender))))

 

6. abrir kismac primero que nada. ir a preferencias y entrar en la ventana de drivers. añadir el driver de Airport Extreme Passive mode. el modo activo no funciona. salirse de ese menu y dar click en Start scan. empezarás a ver redes inalámbricas ((((supuestamente))). una vez que veas redes cierra kismac.

 

7.ir al icono de airport en la barra superior y dar click en unirse a otra red ( si no ven el icono ir al panel de preferencias de redes y habilitar el icono). dar click en mostrar redes. tu red aparcera, dar click en ella, unirse, poner contraseña, después se conectará y será estable. tendran que configurar una red en el panel de preferencias de redes para la tarjeta airport como se haría normalmente.

 

bueno después dice que el tiene una compaq presario c771 y aunque la luz de la red en su laptop no la marca como encendida, la tarjeta funciona.

 

cada vez que inicies se deben de repetir los pasos 6 y 7

 

y según el....la tarjeta sigue funcionando cada vez que prende su lap siempre y cuando el botón o switch de la tarjeta no haya sido oprimido...(((este no es mi caso, ya que siempre tuve que entrar en windows primero, encender la tarjeta y después volver a entrar a leopard para ver si de casualidad funcionaba)))

 

creo que tienes toda la razón, de momento lo mejor es utilizar otra tarjeta, ya sea interna o externa(usb) el problema que tengo yo es que mi laptop es compaq y no le puedo meter otro tarjeta inalambrica ya que me marca error al bootear diciendome que no es compatible y que debo de retirarla y reiniciar.....alguien sabe la solucion a este problema? 8-)

 

espero les sirva de algo

 

(Y)

Link to comment
Share on other sites

Descarga el archivo que se te ha presentado, el cual debe ser un archivo de extension kext. La forma mas facil de instalarlo es usando aplicaciones como Kext Helper o el OSX86Tools... La otra seria que intentes instalarle lo que es el iDeneb 1.3 ya que este tiene el soporte para Atheros y lo mas probable seria que te funcione.

Yo tambien dispongo de una tarjeta wireless Atheros... no es la misma de la tuya pero en mi caso me funciona en su totalidad.

SALUDOS

Link to comment
Share on other sites

Descarga el archivo que se te ha presentado, el cual debe ser un archivo de extension kext. La forma mas facil de instalarlo es usando aplicaciones como Kext Helper o el OSX86Tools... La otra seria que intentes instalarle lo que es el iDeneb 1.3 ya que este tiene el soporte para Atheros y lo mas probable seria que te funcione.

Yo tambien dispongo de una tarjeta wireless Atheros... no es la misma de la tuya pero en mi caso me funciona en su totalidad.

SALUDOS

 

 

 

Claro pero la diferencia de tu chip a uno de los nuestros es un mundo en cuanto a drivers, por lo que no todos valen, lo unico que nos queda es seguir esperando para ver acontecimientos.

 

 

 

 

Saludos.

Link to comment
Share on other sites

Claro pero la diferencia de tu chip a uno de los nuestros es un mundo en cuanto a drivers, por lo que no todos valen, lo unico que nos queda es seguir esperando para ver acontecimientos.

Saludos.

OK..... Pero en realidad me fije que en la instalación del iDeneb viene un parche general para Atheros.... No indica clase ni modelo. Valdria la pena que lo intenten. :blink:

Link to comment
Share on other sites

 Share

×
×
  • Create New...