Jump to content

Core 2 Duo boot hangs at BSD root only from internal drive


1 post in this topic

Recommended Posts

Have Leopard successfully installed on my Dell Inspiron XPS M1710 and running great with the exception of a disabled core. Booting without cpus=1 results in the system hanging during the boot process at "BSD root", sometimes giving a SIGFPE error, other times saying "Syncing disks... Killing all processes" then rebooting. Maybe 1 in 50 boots it will actually somehow get by this point and boot fully into the OS, which is also strange.


I tried an install from scratch to my external USB hard drive and noticed that I do not get a hang at this point and the OS boots fine. Thinking maybe I had kexts or bundles causing the issue, I used Disk Utility to block copy the partition to my external drive. After repairing the bootloader to boot from the duped partition, I let the partition boot. Guess what? No lockup. Interesting, considering nothing else is different between the internal and external drive data. I even duplicated the setup by having an NTFS partition first on the external drive. This happens with both the iAtkos and Kalyway 10.5.1 installs.


I've also tried various kernels, from ToH to nForce patched 10.5.1 and 10.5.2 speedstep, all do the same thing, booting beyond this point interally only with cpus=1 but fine from the USB drive. DVD boots of both install disks do not hang here. I even made a backup of the Kalyway install DVD to an extra 4GB Sandisk pen drive, and that boots without cpus=1 everytime without fail too. With all of this testing, I can safely say all non-internal HDD drives boot fine, while internal HDD boots fail 95% of the time.


Other things I've tried:





physically removing 2GB of my 4GB

removing every non-vital kext and bundle that I could find (ended up without 16 required kexts in the end)

no option in the bios to change between IDE and AHCI mode (AHCI is perma-disabled bleh!)

tons of other things that I'll probably say I've tried when you suggest them (lol)


So.. anyone have any input on this one? My goal is to at least get into the OS everytime without cpus=1, because then I have been able to successfully Sleep/Wake and use both cores without problems.

Link to comment
Share on other sites


  • Create New...