Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 

iPhone SDK seems to ruin OSX86 install

29 posts in this topic

Recommended Posts

installed the default SDK including CHUD, fixed permissions reboot - Success


My system:

Dell XPS M1330


iAtkos 5

sleep display workaround

Share this post

Link to post
Share on other sites

I need some help here, I run the Iphone SDK installation package but it fails just after I type my password required for begin the installation, it shows the message "Installation failed", help would be appreciated. Thanks

Share this post

Link to post
Share on other sites

Problem solved, I did install iphone_sdk_9a2151.dmg (you can find it in any torrent site) and everything seems to work fine, I didn't have to patch the file or replace Iphone SDK.mpkg inside the dmg, I have Kalyway 10.5.2 running on a Turion 64 X2 Laptop. Thank you anyway and keep sharing knowledge.

Share this post

Link to post
Share on other sites
The whole point of getting OSX86 running was so I could download the iPhone SDK and play around with that. When the install was finished, I got a new alert I've never seen...it put a transparent black overlay on the screen, with a power button in the background, and said to restart my machine by holding down the power button. Funny thing is, it repeated this message in various languages.


I figured it was just Mac's way of saying to restart after an intense install. So I restarted...now everytime it boots up, I get the same screen. So now I'm guessing something seriously bad happened. I have a feeling it's related to gcc, but it's just a guess.


Is there some kind of known issue, or a patch already that can fix this?


hmmm...downloaded the sdk today and every time it starts mounting the dmg, I get the same screen you are getting (but you get it later on in the process, I don't even get to start the actual install...)


the only problem with my install that I know of is the graphics card driver (865g, can only use 1024x768) - and possibly that my itunes is slightly outdated, though I don't think that would crash anything that early in the process.


ps: is it safe to update itunes?


I run the 10.5.6 xxx distribution.


EDIT: I now have an ATI2400 pro card that works well with all other apps. Everything except SDK installer seems stable. Hope I find a way around this crashing problem....apparently not graphics card related.... the only other thing I have to do is due to my P4 version, I have to put in a couple of parameters every time I boot (fsb=133000000 and one other one..). Still everything (besides sdk) works like a charm!


On a sidenote, installed iTunes latest version as well as some other updates. Except for not helping with the sdk installer problem, everything else works great.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.