Jump to content
Kabyl

Modified BIOS to get all cores working

1,885 posts in this topic

Recommended Posts

Hey Kabyl, I'm also using an MSI P35NEO, I was on the brink of replacing it even though it's pretty much new. But i'm holding it off now thanks to your work. I've done so many rebuilds now it's silly, trying alsorts of permutations, i'd be more than happy to suffer a few more rebuilds for the sake of testing some of your magical kext's to help us msi users.

 

Keep up the awesome work man :(

Share this post


Link to post
Share on other sites
Advertisement

Do you think there's a problem with my bios?

'Coz i've installed leopard (leo4all 10.5.2) over and over again. It's installing properly, but after restarting, this is what appears:

 

Using 9175 buffer headers and 4096 cluster IO buffer headers

 

My laptop is on my signature. and this is the link to its bios. thanks! :-)

 

http://global.msi.com.tw/index.php?func=do...8&type=bios

Share this post


Link to post
Share on other sites

After updating my BIOS I was able to use both CPUs however when I use both CPUs the system is slow and laggy. If I run with cpus=1 no lag, but obviously I want to use both my cores.

 

I have a ASUS G1S can anyone point me in the right direction on getting this fixed?

Share this post


Link to post
Share on other sites

Kabyl, mayby you can enable or add option enable/disable XD - eXecute Disable in Phoenix FirstBIOS (Compal FL90), this option is hidden or not exist in bios option for change. I think can't use vanilla kext ( shutdown/restart ) on may notebook :-( . Link to spec. http://www.compal.com/Product/Html/notebook/IFL90.htm and bios http://www.compal.com/asp/driver_dnd/index.htm http://www.compal.com/Download/NB/IFL90_91/BIOS/JFT02116.zip. Sorry I know it isn't Assus family but maybu you can try. Thank you in advance.

Share this post


Link to post
Share on other sites

so the problem in solving the dell issue is that we have no real way to edit the bios rom since its a custom dealt one? I found some instructions on how to at least extract the rom if that's an issue an yes its a phoenix based bios.

 

Otherwise I will be looking forward to this bios inject you are referring to!

Share this post


Link to post
Share on other sites

Does anyone can help me with my lg e500, I do not edit bios. There is a modified bios for lg e500 but for vga nvidia, I have vga x3100. Thanks

 

--------------------------------------------------------------------------------------------------------------------------------

Alguien me puede ayudar con mi lg e500, yo no edito bios. Hay un bios modificado para lg e500 pero es para vga nvidia, yo tengo vga x3100. Gracias

Share this post


Link to post
Share on other sites

please help me!

got a 7100 (core2duo 1,8ghz) on my laptop (ms-1719).

i'm new in this scene but i tried to run leopard for month and been sucessfull.

so..where do i have to change the bios to run the dual core?

where do i change THIS?!

CODE

Scope (_PR)

{

Processor (P001, 0x01, 0x00000810, 0x06) {}

Alias (P001, CPU1)

}

 

THANK U VERY MUCH FOR HELP

Share this post


Link to post
Share on other sites

Hi ,

 

cannot believe it (!) :huh: ... have been hacking my leo4allv2 install for a week now to see both core of my T7500 (was successfully installed right from the beginning) (no troubles with firewire ... just rebooting if no cpus=1 as kernel option EXACTLY after MAC Framework initialization)

... tonight I tried all 5 available bioses for my ASUS V1S-AJ033E ...

all have to be booted with cpus=1 (fxxxx)

Odd : system profiler identifies CPU Name and freq correctly ...

I even get ACPIids for both cores during bootup despite setting cpus=1

 

even with this last one :

http://dlsvr01.asus.com/pub/ASUS/nb/V1S/V1Sn301AS.zip

 

PLEASE ...PLEASE ...

... myself and many others would be sooooo thankful !

Thx in advance ! :wacko:

Share this post


Link to post
Share on other sites

chmo,

 

I do not understand, with the installation of leo4allv2 no problem with the two core? :rolleyes:

Share this post


Link to post
Share on other sites
Can someone post the modified bios for Asus G2S,please !

I searched the whole thread but I couldn't find it.

http://rapidshare.com/files/103965528/G2S300AS_mod.zip.html

 

Hello, Kabyl, My bios is Asus Striker Extreme for desktop, is it possible for u to modify it to fix that cpu=1 issue??? Thank u very much for help...

 

here is the address....http://dlsvr02.asus.com/pub/ASUS/mb/socket...reme/SE1503.zip

http://forum.insanelymac.com/index.php?showtopic=87901

 

Kabyl, mayby you can enable or add option enable/disable XD - eXecute Disable in Phoenix FirstBIOS (Compal FL90), this option is hidden or not exist in bios option for change. I think can't use vanilla kext ( shutdown/restart ) on may notebook :-( . Link to spec. http://www.compal.com/Product/Html/notebook/IFL90.htm and bios http://www.compal.com/asp/driver_dnd/index.htm http://www.compal.com/Download/NB/IFL90_91/BIOS/JFT02116.zip. Sorry I know it isn't Assus family but maybu you can try. Thank you in advance.

Will see what I can do..

 

so the problem in solving the dell issue is that we have no real way to edit the bios rom since its a custom dealt one? I found some instructions on how to at least extract the rom if that's an issue an yes its a phoenix based bios.

 

Otherwise I will be looking forward to this bios inject you are referring to!

No, it's not about editing the BIOS, the problem is we don't know what's the _problem_ :P

 

Does anyone can help me with my lg e500, I do not edit bios. There is a modified bios for lg e500 but for vga nvidia, I have vga x3100. Thanks

 

--------------------------------------------------------------------------------------------------------------------------------

Alguien me puede ayudar con mi lg e500, yo no edito bios. Hay un bios modificado para lg e500 pero es para vga nvidia, yo tengo vga x3100. Gracias

Post a link to the BIOS file.

 

please help me!

got a 7100 (core2duo 1,8ghz) on my laptop (ms-1719).

i'm new in this scene but i tried to run leopard for month and been sucessfull.

so..where do i have to change the bios to run the dual core?

where do i change THIS?!

CODE

Scope (_PR)

{

Processor (P001, 0x01, 0x00000810, 0x06) {}

Alias (P001, CPU1)

}

 

THANK U VERY MUCH FOR HELP

Same here, a link to the BIOS file.

 

Hi ,

 

cannot believe it (!) :huh: ... have been hacking my leo4allv2 install for a week now to see both core of my T7500 (was successfully installed right from the beginning) (no troubles with firewire ... just rebooting if no cpus=1 as kernel option EXACTLY after MAC Framework initialization)

... tonight I tried all 5 available bioses for my ASUS V1S-AJ033E ...

all have to be booted with cpus=1 (fxxxx)

Odd : system profiler identifies CPU Name and freq correctly ...

I even get ACPIids for both cores during bootup despite setting cpus=1

 

even with this last one :

http://dlsvr01.asus.com/pub/ASUS/nb/V1S/V1Sn301AS.zip

 

PLEASE ...PLEASE ...

... myself and many others would be sooooo thankful !

Thx in advance ! :P

http://rapidshare.com/files/103968562/V1Sn301AS_mod.zip.html

Feedback would be nice..

Share this post


Link to post
Share on other sites

Thanks Kabyl for the Asus G2S bios.I got it earlier,flashed and now I have Leo4All working with two cores.Great work !

 

No issues in windows for now,with this bios.

Share this post


Link to post
Share on other sites
chmo,

 

I do not understand, with the installation of leo4allv2 no problem with the two core? :D

 

 

GED,

 

of course I had problems with two cores : thats why I need the bios :D

But the probs where no "show stoppers" ...

with kernel option "cpus=1" I was able to startup Installer DVD and to install MBR Method on extarnal USB HD drive.

check http://osx86leo4all.wikidot.com/forum/t-49...d-boot-problems for the whole story.

 

@kabyl ... THX A LOT ... will flash and give feedback this evening (CEST) :))

 

good luck !

Share this post


Link to post
Share on other sites

Sorry, Kaby, I don't understand, does it mean Asus Striker Extreme's bios can't be modifid to let leopard recognise 2 cores....

Share this post


Link to post
Share on other sites
Sorry, Kaby, I don't understand, does it mean Asus Striker Extreme's bios can't be modifid to let leopard recognise 2 cores....

Your board is nforce (Intel edition) based, you just need to use a kernel patched for nforce.

Share this post


Link to post
Share on other sites
http://rapidshare.com/files/103965528/G2S300AS_mod.zip.html

 

 

http://forum.insanelymac.com/index.php?showtopic=87901

 

 

Will see what I can do..

 

 

No, it's not about editing the BIOS, the problem is we don't know what's the _problem_ :P

 

 

Post a link to the BIOS file.

 

 

Same here, a link to the BIOS file.

 

 

http://rapidshare.com/files/103968562/V1Sn301AS_mod.zip.html

Feedback would be nice..

 

OK ... here is the Feedback ... flash ... reboot ... cpus=2 ... 28 sec. later : 2 cores in system profiler visible :mellow: ... xbench (w/o disk) 165,79 ...YOU ARE MY HERO !

for full story of my leo4allv2 expriments check : http://osx86leo4all.wikidot.com/forum/t-49...d-boot-problems

leo4allv2 rocksssss .

:P:P:P

Share this post


Link to post
Share on other sites
OK ... here is the Feedback ... flash ... reboot ... cpus=2 ... 28 sec. later : 2 cores in system profiler visible :P ... xbench (w/o disk) 165,79 ...YOU ARE MY HERO !

for full story of my leo4allv2 expriments check : http://osx86leo4all.wikidot.com/forum/t-49...d-boot-problems

leo4allv2 rocksssss .

:D:):)

You don't need to use cpus=n :)

And thanks for the feedback.

Share this post


Link to post
Share on other sites

I have a macbook now and I like its power management features and now since I realize all that I am missing I would like to know if anyone on the Asus laptops were able to run the vanilla kernel with power management working fully after loading one of these BIOS? On my Asus G2S I am still running a hacked kernel. I had ran the vanilla kernel for a short while, but I do not remember my power management working.

 

Thanks

Share this post


Link to post
Share on other sites

Oh, I got it...Thanks Kably...But the kernel with nforce patch also causes the shutdown, restart and sleep problems, doesn't it... Anyway, Thank u very much :P

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×