Jump to content
Kabyl

Modified BIOS to get all cores working

1,885 posts in this topic

Recommended Posts

Hi Kabyl.

 

I´m here to do what most of people comes here to.

I need to ask you to get me a modified BIOS. I own an MSI P6N SLi Platinum - wich is known to had bad bios for OSX - and Mysticus tried all the ways to help me, but we got stuck to a point that we can only go further if I mod my BIOS.

So I hope you can help me with that.

 

Here is my link to my original BIOS

========================================================

http://global.msi.com.tw/index.php?func=do...8&type=bios

========================================================

 

I´d like to thank you in advance. I know you have a lot of requests and you maybe be busy with the others.

 

I´d like to say you do a good job on this project OSX.

 

[]´s

Share this post


Link to post
Share on other sites
Advertisement

We have modified BIOS to make Vista work in our DIY X86 computer. Now we are interested in Mac OS. But as you know that the CPUS=1 problem makes us sad cause the dual core waste one. I have heard that the modify BIOS can make us use both cores working under MacOS system. Can anybody help me to modify my BIOS? Thank a lot.

 

My mother board is MSI P35-neo2-Fr, Pheonix BIOS.

 

Or anybody can tell us where i can download that modified BIOS?

 

Thanks!

Share this post


Link to post
Share on other sites

Hey Kabyl-

 

I also have the MSI P6N SLI Platinum mobo. I've managed to do a retail Leopard install on it, and I'm using your nforce kernel. I should be able to run the vanilla kernel as I have a core 2 duo, but it panics.

 

My main issue is my firewire audio interface. When I turn it on it works but after about a minute my system locks up. However, if I boot with cpus=1 flag, I have no lock ups and my device behaves properly.

 

After looking through the topic/issue that your bios mod addresses, it seems that this will fix my firewire issue and let me boot vanilla style.

 

Here is the original MSI P6N SLI Platinum BIOS

 

I would greatly appreciate your time and effort.

 

---------------------------------------------------------------------------

MSI P6N SLi Platinum

• NVIDIA® nForce 650i SLI (C55) Chipset (North Bridge)

• NVIDIA® nForce 430i (MCP51) Chipset (South Bridge)

Intel C2D - E4500 2.2 Ghz

2 x 1Gb RAM DDR2 800 MHz - Running @ 667 Mhz because About this Mac reports 667 even at 800

Evga Geforce 7600GT - 256 Mb

HDD: 500 Gb SATA

---------------------------------------------------------------------------------------

Share this post


Link to post
Share on other sites

Hi Kabyl,

 

Thanks in advance, when you manage to wade through all these requests and get to mine. :excl:

 

I have the ACPI Platform problem you've described, and can only boot with the "cpus=1" flag. I am happy that it is functioning, I would very much like to see how it runs with two cores functioning.

 

Laptop Model: Asus F8SN-A1

Intel Core2 Duo T5450

Intel P965M Chipset

nVidia 9500M GS Video

BIOS File: http://dlsvr01.asus.com/pub/ASUS/nb/F3Sg/F8SNG303AS.zip

 

Thanks!

Share this post


Link to post
Share on other sites

Hello Master Kabyl, thank you so much for everything! What you're doing for the community is great work!

 

Please here's my bios file: http://dlsvr02.asus.com/pub/ASUS/nb/M70Sa/M70SA204AS.zip

 

Here's the asus notebook specs.

 

The CPU is Duo T8100.

 

The Chipset is PM965.

 

The Graphic card is ATI Mobility radeon 3650.

 

Thank you so much man... Keep up the good work! I'll give feedback as soon as I try... promised! And man If your interested in building a website I offer my help! :rolleyes:

Share this post


Link to post
Share on other sites

Hey all :(

I will be posting the files here, for now, it's just a small list (in progress, and I know, it looks ugly)..

Share this post


Link to post
Share on other sites

Hi Kabyl!! Thanks heaps for posting up the modded bios's thus far!!

 

Wondering if I could ask for mine to be modded too please? Thanks!!

 

Here's my bios file: http://dlsvr01.asus.com/pub/ASUS/nb/F3Sg/F3Sg305AS.zip

 

Here's the asus notebook specs: http://www.asus.com/products.aspx?l1=5&amp...amp;modelmenu=2

 

The CPU is a Intel Core 2 Duo T8100, chipset is PM965, video card is an NVIDIA GeForce 9300M G.

 

Thanks heaps!! Will post up my results once I give the flash a run! :P

Share this post


Link to post
Share on other sites

Hi Kabyl!

Can you help me modify BIOS?

 

My system : asus x55sv

 

Current original BIOS link: http://dlsvr02.asus.com/pub/ASUS/nb/X55/X55SV207AS.zip

 

Config:

BIOS AMI

CPU type Mobile DualCore Intel Core 2 Duo T7500, 2200 MHz (11 x 200)

Chipset Intel Crestline GL960/GM965/PM965

Memory 2048 Мб (DDR2-667 DDR2 SDRAM)

Display:

GeForce 9500M GS (512 Мб) vid 10de dev 0402

NVIDIA GeForce 9500M GS (512 Мб)

Sound Realtek ALC888 @ Intel 82801HBM ICH8M - High Definition Audio Controller

Storage:

Controller IDE Intel® ICH8M 3 port Serial ATA Storage Controller - 2829

Controller IDE Intel® ICH8M Ultra ATA Storage Controllers - 2850

Controller IDE Ricoh Memory Stick Controller

Controller IDE Ricoh SD/MMC Host Controller

Controller IDE Ricoh xD-Picture Card Controller

Controller Raid JMicron JMB36X Controller

HDD Hitachi HTS542516K9SA00 (160 Gb, SATA)

Optical drive TSSTcorp CDDVDW TS-L632H

 

Network Intel® Wireless WiFi Link 4965AGN

Network Marvell Yukon 88E8055 PCI-E Gigabit Ethernet Controller

Modem Motorola SM56 Speakerphone Modem

 

Please help me.

Thanks

Share this post


Link to post
Share on other sites

Hello ! Is it possible to unlock this bios to have access to all the settings please ?http://global.msi.com.tw/index.php?func=do...7&type=bios

 

This bios does not allow me to install leopard on my laptop MSI gx700 extreme because all the settings are locked. This is my config :

 

Intel® Core2 Duo CPU T7500 @ 2.20GHz

2.19GHz

 

Micro-Star International GX700

Intel Centrino Duo Mobile

MSI MS-1719x

Bus : ISA PCI PCIe IMB PCMCIA USB FireWire/1394 i2c/SMBus

Support MP : Non

APIC MP : Oui

American Megatrends Inc. 080014

2Go DDR2

 

MSI Mobile PM965/GM965/GL960 Express Processor to DRAM Controller

4x 199MHz (796MHz)

2Go DDR2

2x 332MHz (664MHz)

 

NVIDIA GeForce 8600M GT (512Mo DDR2, PCIe 1.00 x16, SM 4.0)

 

Please help me.

Share this post


Link to post
Share on other sites
Hi, could you please try modding this bios for ECS G31T-M?

 

http://www.ecsusa.com/ECSWebSite/Downloads...d=2&LanID=9

 

Thank you so much!

 

PC specs: Intel Q6600, G31, Nvidia 7200GS PCI-E

 

I decompiled the DSDT table using iasl under Linux and I saw those alias entries for the CPUs... unfortunately I can't seem to figure out how exactly to replace it in the AMI bios... Award looks easier.

 

It would be great if you could mod it for me so I can use more than one core. Your work is really appreciated!

 

You can't use the DSDT entry from linux. You have to extract/uncompress the 1B section from the AMI bios and retrive/modify the DSDT entity there.

 

Here is the modified AMI bios for ECS G31T-M. Unfortunally, the newer version of the bios do not work correctly and will get "unable to load driver" for "ACPI". So I have to stick with the older version of the bios. This has been tested on a quad core. But USE AT YOUR OWN RISK! I AM NOT RESPOSIBLE AGAINST ANY DAMAGE! PLEASE IF YOU MESS UP YOUR BOARD I REALLY CAN NOT HELP YOU.

 

Thanks

-DTsu

ecs_mod.zip

Share this post


Link to post
Share on other sites

Hi Kabyl

 

Ran into the same problem, running osx 10.5.2 Kalyway+Jas 10.4.8 sse2 patch+cpus=1 (vanilla kernel) on this hardware:

Asrock4Core1600P35-WiFi+

Intel q6600

2gb ram

Radeon hd2600XT.

 

Installation works fine, without boot flags, but when starting to boot from harddisk , it gets stuck on the "using 10485 buffer headers and 4096 cluster headers" line.

 

after installing the jas sse2 patch it no longer hangs, but will reboot loop if i don't use cpus=1 flag.

Is there any workaround for it apart from modifying the bios? you were mentioning a kext earlier in a post....

 

And here are the bios files:

windows version link: http://www.asrock.com/mb/from.asp?Model=4C...T=B&ID=1653

dos version link: http://www.asrock.com/mb/from.asp?Model=4C...T=B&ID=1652

 

Thank you!

Share this post


Link to post
Share on other sites

Today I found my modded BIOS in the list.

:happymac: && :D

 

Kabyl, you are a true ;)

 

 

(but I have to try it out first ...)

Share this post


Link to post
Share on other sites
MOTHERBOARDECS P35T-A motherboard embedded Intel® Bearlake P35 and ICH9DH chipsets,Support by Intel® ICH9DH6 x Serial ATAII 3.0Gb/s devicesSupported by JMicron® JMB361CPUIntel Pentium E2180 Allendale 2.0GHz 1MB L2 Cache LGA 775 65W Dual-Core Processor VIDEOCARDMSI NX8500GT-TD256E GeForce 8500GT 256MB 128-bit GDDR2 PCI Express x16 SLI Supported Video Card MEMORY:G.SKILL 4GB (2 x 2GB) 240-Pin DDR2 SDRAM DDR2 800 (PC2 6400) Dual Channel Kit Desktop MemoryNETWORK:pci 8139SATA and IDE HDs and SATA DVDISSUE;I have to start with cpus=1I have 10.5.2 running via iAKTOS 10.5.1 r3 (bad bios version) updated with kaly 10.5.2 combo updater...graphics leo update and then KVHush for graphics...everything working...except the second core. (ToH 9.2.0)BIOS LINK:http://www.ecsusa.com/ECSWebSite/Products/...D=7&LanID=9I am running original bios at the present time.thank you....no rush...cheers

 

spylinux,

I have only worked on ECS with the AMI bios so far so I can help you (P5A131A_OSX.zip). Following the instructions on this thead plus fixing some existing DSDT bugs. Let me know how this one goes. Same as my previous BIOS edits. Use at your own risk. I am not responsible for you messing up your motherboard. Alway have a floppy with an autoexec ready to auto flash your original image back in. As in all bios flashing, you can damange your motherboard if this task is taken lightly.

 

Also, Forgot to mention this, please make a backup copy of the rom you are using now if you can. Because an upgrade bios from the manufacture is not always a good thing. Like the ECS G31T-M, the upgraded bios won't run os x no matter what I did. I had to back track to a earlier revision of the bios. But since there is only one revision on ECS's website for your motherboard, I would suggest you make a backup now.Thanks,-DTsu

 

 

 

Hey Kabyl,Do you think you could make a modified BIOS for ECS 915G-A/915P-A. You can download the BIOS from here: http://www.ecsusa.com/ECSWebSite/Downloads...d=2&LanID=9Thank you very much!

 

Andrew,

I do not see any Alias entries for your processors in your DSDT. We might need Kabyl to help us explain this one. You might need to play with some settings in your bios to get things going. I have attached below (ECS_915G-A.zip) a copy of the .dsl containing your decompiled dsdt. Hopefully someone can help.

P5A131A_OSX.zip

ECS_915G_A.zip

Share this post


Link to post
Share on other sites

HI Kably! Thank you for you work!

 

I need your help for my laptop: HP 530

 

I have a Core Duo T2600

 

My videocard is integrated and is a GMA 945 - Chipset HP Mobile 945GME

 

Latest bios you can find it here: ftp://ftp.hp.com/pub/softpaq/sp38501-39000/sp38863.exe

 

I tried to modified by my self but i haven't understand how program i must use to modify rom file (hex editor?)

 

Thanks a lot! BYE

Share this post


Link to post
Share on other sites

ATOMBIOS Samsung R20 laptop

ATI x1250 (aka AMD 690g) chipset All-In-One (controllers + GPU)

Intel Duo Core2

 

Detailed description and installation here:

http://www.insanelymac.com/lofiversion/index.php/t86094.html

 

http://wiki.osx86project.org/wiki/index.ph...les#Samsung_R20

 

BIOS update is here:

http://org.downloadcenter.samsung.com/down...81_15SH_WIN.exe

Share this post


Link to post
Share on other sites

hi kabyl!

 

i have the asus notebook x51l-ap034a

 

this is the components list:

 

cpu: Intel Pentium Dual-Core T2370, 1.73 GHz, 1MB cache L2, FSB 533 MHz

Memory: 3072 MB DDR2 533

lcd: 15.4 pollici WXGA (1280 x 800) Asus Splendid - Glare Type

Video card: Intel Graphics Media Accelerator (GMA) X3100 chipset intel gm965

Hard Disk: 200 GB SATA

Drive Ottico: Masterizzatore DVD DL Super Multi

Porte: 1 x VGA Port/Mini D-sub 15 pin per display DDC esterno, 4 x USB 2.0, 1 x Headphone-out, 1 x Mic-in, 1 x RJ45, 1 x RJ11, 1 x Express Card, 4in1 Card Reader

Networking: LAN 10/100 Mbps (realtek 8139), Wireless Integrato 802.11b/g(broadcom 913411), Modem v.92

 

the computer dont start osx if i don't put the code cpus=1

 

this is the link for the bios:

 

http://dlsvr01.asus.com/pub/ASUS/nb/X51L/X51L204AS.zip

 

or this new one

 

http://dlsvr04.asus.com/pub/ASUS/nb/X51L/X51L205AS.zip

 

thank you very much for your job!!!!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×