Jump to content

No desktop disk icons


metrognome
 Share

7 posts in this topic

Recommended Posts

(sigh) I'm pretty new to osx86 (XP and work and Ubuntu at home) so lets just get that out of the way. I'm sure I've done something dumb here but I can't figure out what that might be.

 

I successfully installed iAtkos on my GA-965P-DS3. I've done patches for sound and networking (posting from it now) and I'm running dual monitors on a 7900GS. Things run great.

 

So, a couple of sessions ago I was exploring - this is still pretty new. I remember changing the lable colours of the disk icons on the desktop; the system disk and my data disk. These icons disappeared on the next reboot.

 

Now I don't think anything has actually happened to the disks. Obviously I'm booting and can see all my files through the finder. Interestingly enough neither disk appears under devices even though I can find all my apps and files on the system disk with the finder. I can manually open either disk via the disk utility.

 

Here's what I know:

disk0s1 is system disk. disk1s1 is data disk.

Show hard disks is checked in Finder Preferences.

I have verified and fixed (minor errors) both disks.

Both devices appear normally in the disk utility.

I can mount and unmount my data disk but the icon still won't appear on the desktop.

A df in the terminal shows:

/dev/disk0s1 mounted on /

/dev/disk1s1 mounted on /Volumes/disk1s1

 

Please please please. How do I get the icons back? I've searched the forums and Googled to no avail.

 

Thanks much!

Link to comment
Share on other sites

I think you can go in to the diskutility and then rightclick on the correct disk there (or partition if you have'em) and choose "reveal in finder". I'm not a 100% sure about this since i don't have my sweet hackintosh besides me now and can't check it. But i think i did this when my usb wouldn't show up.

Sorry if im wrong here.

Link to comment
Share on other sites

Hi guys (or gals)... Thanks for taking the time to help me out.

 

@Stubbfan

Yeah, I try that and it opens a new Finder window but doesn't actually show my drive. Note that I don't see the drives under "DEVICES" in the finder either. However I can use the finder to browse my applications and data which, of course, are on disk0s1. It even shows the right amount of space available on the bottom of the finder window. Also, search will find files on both disks.

 

@vaporATX

Yup. That was one of the first things I looked at. I've probably checked and unchecked that thing 20 times now...

 

Also, a friend thought it might be a problem with my desktop settings and suggested logging in as another user. I created a new user and logged in but still no drives on the desktop.

 

I can still use these drives via "Go->recent" in the Finder or "open" drive in the Disk Utility. I'd just like the icons back on the desktop and they won't come back.

 

Appreciate any help.

 

Thanks!

Link to comment
Share on other sites

@qbattersby

 

You are DA MAN! I've got my drives back!

 

Only the system drive came back with the script so I had to do some of the command line stuff further down in the article for the data disk but I've got them both back now.

 

Thanks again. Much appreciated!

Link to comment
Share on other sites

 Share

×
×
  • Create New...