Jump to content
xpertvision

logic pro 8.1 "audio&midi out of sync" and "system overload" (HOWTO SOLVE THIS)

23 posts in this topic

Recommended Posts

looks like the most talked bug ever in logic history is system overload and audio/midi out of sync (with no aparent reason, processor spikes give the error messages and lock logic)

 

theres people buyng new macs coreduo with 4gb ram with good firewire cards and then 2 simple audio tracks give system overload messages and crashes, i think its related to some specific modos and processors, many users simple cant run more than 2 tracks on logic pro 8 on the new macs (not hackintoshes) its ridiculous!

 

apple simply ignore this problem sinze 7.2 and now it got very worst on the new version, the topics on apple help foruns are getting deleted , and nobody talks about a solution, many people are downgrading to 7.2 becouse of this

 

this is a solution i find , and solved the problems for me (logic was giving me overload messages with one midi track only , now i start a track full of effects with 8 midi tracks and i dont have problems, even using my onboard card ac97 :) )

 

 

so this is the solution: (there is 2 ways of doing this)

 

1º way: (the console way)

 

1. run LP8

2. run Activity Monitor and look for the PID for Logic 8 eg. 15655

3. run terminal

4. enter : sudo renice -20 xxxx

where xxxx is the PID of Logic ie 15655

 

What this does is tells OSX to give TOP priority to Logic. then just keep logic running.. I did this over the last 2 days and spent 18 hours solid working and not one Overload and not one crash - lovely !!

 

 

2º way: (the automactic script way)

 

1. Go into Applications and open the 'Apple Script' folder.

2. Open/Launch the 'Script Editor' App.

3. You will see a window divided it two - in the top window, copy (apple > 'c') this text as written below;

 

 

tell application "Logic Pro"

run

end tell

set the_lines to paragraphs of (do shell script "ps -U $USER")

set the_app to "Logic Pro"

set the_line to ""

repeat with this_line in the_lines

if this_line contains the_app then

set the_line to this_line

end if

end repeat

if the_line is "" then return

set the_pid to word 1 of the_line

do shell script "renice -20 " & the_pid password "putyouradminpasswordhere" with administrator privileges

 

 

4. On the bottom line where it reads "putyouradminpasswordhere" type in your admin password - keep the quotation marks

and the last three words exactly as written. Just change the putyouradminpasswordhere text.

 

5. Go to 'File' and 'Save As' -- give it a name and choose a location to save to. In the dropdown menu labelled 'File format',

I saved mine as an application, ticked 'Stay Open'and Saved to my Apps folder.

 

6. Double click on the the Script/App. and wait....

 

7. The script will launch itself and then LP8 - the 'Stay Open' save option keeps this running while you use Logic. I keep an alias of the script (with a cool icon)

in the Dock next to my LP8 alias.

 

 

make nice tracks :P

Share this post


Link to post
Share on other sites
Advertisement
Guest Snowski

I compiled the script a few days ago but have not tried it yet. I also combined the Quit all open apps script with this so when I click my script app (with logic icon) it closes all running apps and then boots logic with tweak.

 

Hopefully this will solve some of my audio probs.

Share this post


Link to post
Share on other sites

How about this... Just go into Logic Pro> Preferences> Audio> select the General tab and un-check the first box you see that says "Display audio engine overload message"

 

 

Edit:

 

Maybe this is something completely un-related... Sorry

Share this post


Link to post
Share on other sites

LOL it is...

 

you uncheck the error message, but the problem still there , the logic stops and all sounds get muted...

 

if was that simple nobody lost time making a script...

 

there are millions of posts about this problem , and this is the only solution at the moment

 

in apple forums i saw people with 9GB ram (new macs not pc´s) and they get overloads with 3 midi tracks...

 

logic sends strange red spikes and logic stops with overload , and looks like somethimes only uses 1 processor

 

 

i heard very good things about logic (7.2) but this new logic is a disaster... crash many times... sometimes just changing a preset crash...

 

i only tested build in plugins! i dont have nerves to test third party plugins there LOL

 

the weird thing is some people have this problems and others simple dont have nothing... and looks like the old MACs have better performance then new INTEL MACS with 9GB ram... apple people never talked about the problem or a fix... the posts are everywhere and sometimes getting deleted by admins... crazy stuff to see people buy new macs and logic 8 and now tryng to switch to 7.2 becouse the software simple doenst work...

 

by the way logic 8 is not a professional solution anymore, i read a interview about the sucess of sales of mac computers becouse of logic 8 with no dongle, the interface was changed becouse of that , its more simple and user friendly for beginers , and from now on the apple target is normal home users and not professionals artists (i will try to find the oficial news link and post it here)

 

until someone releases a update for this problems im stick with sonar 7

Share this post


Link to post
Share on other sites

Hi guys!!!!!!!

 

I´m a cubase user from 10 years ago. Recently i changed to hackintosh & Logic (Original Copy). My soundcard was a M-audio Fast Track.

When i begin this new experience all was a hell, my machine don´t work fine, logic was the system overload message every five minutes, the famous message audio midi syncro lost appears constanly.

I think to return to windows, sell my logic copy and buy Ableton Live.

I try my Logic copy in a real macbook pro & Steinberg SYSTEM 4 from a friend. Result = :( System overload every 2 minutes.

But all change with :D Kalyway Leopard, Logic 8.0.1 & My new RME HDSP 9632 PCI with Original Intel driver.

No more system overload messages

Incredible midi timing

The best sound i never taste in a DAW

Last week work in a project over 10 hours every day, mail always open when i login, time machine working, no problems.

Really i found a big difference to work with this new plataform, cubase have a lot of problems (midi timing, shifted notes, too many bugs).

 

Cheers

 

P.S. I try with the script in my system: I have not noticed the difference.

Share this post


Link to post
Share on other sites

Never had the problem on my Mac Pro. I did have it on my Hackintosh. And for the record that "script" is not a 100% sure fire fixed. It has worked for some people and not for others.

Share this post


Link to post
Share on other sites
by the way logic 8 is not a professional solution anymore, i read a interview about the sucess of sales of mac computers becouse of logic 8 with no dongle, the interface was changed becouse of that , its more simple and user friendly for beginers , and from now on the apple target is normal home users and not professionals artists (i will try to find the oficial news link and post it here)

 

until someone releases a update for this problems im stick with sonar 7

 

Well this is not really true Logic´s (hope you don´t mind me saying this, nothing personal but I feel I have to be honest) still the same powerfull program, looks a little different only, some like the new look I don´t but it still rocks for sure. It´s well worth the money they charge for it, they halfed the price and you get a couple of good extras to. If they would just leave it be and not fix the bugs well I dont think apple would last long then. But sure it´s irritating for sure and the fact they delete critiques is just so strange, I just would´nt dare do that if I had a buisnes running I´d adapt to what the market says as soon as I could. In the meantime I´d be sure to keep the comunication with my customers wide open.

Share this post


Link to post
Share on other sites

sure its still a professional app ,and i must confece i love the new interface i was a 5.5.1 pc user years ago

 

im just telling what i read , looks like they win more money with home users , so the new logic updates will be in that direction

 

 

dont get me wrong i recomende logic 8 to anyone , just test it in your system first before you buy

Share this post


Link to post
Share on other sites

I can verify penarol's post about Logic 8 with Kalyway's 10.5.1 release. I have a core2duo 2.67 with 2 GB ram with 10.5.1 installed without Vanilla and on MBR partition. I started up Logic and put on 3 sculpture's and drew in chords to play on each of them and looped for a bar. I also put 4 space designers on each channel along with a fat eq. I then added an ultrabeat and put 3 space designers on it and programmed a little beat to test it out.

 

My CPU spike barely reached half on one core and the other core was barely engaging (although, both would react equally some times but it was still low.). Also, I had the sequencering constantly running while I was adding new channels, instruments, effects and what not. I believe I read somewhere that Logic Pro was made for Leopard.

 

Anyways, get on the Kalyway 10.5.1 if you want your {censored} to run proper

Share this post


Link to post
Share on other sites
This video may shed some light on the matter

 

http://uk.youtube.com/watch?v=GNUR3ZUIwUo

 

Yes thats very true what he say - I have the latest LS running on an "old" single core amd64 cpu with 2 gb ram with an usb audio interface and i realized that the channel strips lib are very imposant bloated but very useful, too. there is also a "for G4 optimized" channelstrip/soundlib which helps to reduce system load.

 

but realtime audio creation with a lot of synths, fx and samplers is one of the last claims for the best and fastest computer.

 

Compare to windows asio, my hackmac coreaudio acts more performant with the nearly same load of realtime audio processing. but if i use 10 spacedesigner , audio stops -thats way of life and not a problem of apple -the user have to take care for the ressources of his system

Share this post


Link to post
Share on other sites

the new patch is out ! update 8.2

 

anyone with "audio&midi out of sync" and "system overload" have tested the patch?

 

its is finaly solved?

 

im asking becouse i format my pc recently and im not using hackintosh , i just have XP SP3

 

its safe to install hackintosh again just for logic pro 8.2 ?

 

 

thanks

Share this post


Link to post
Share on other sites

ok, just wanted to give some info for anyone with similar problems. I was getting the audio and midi out of sync sample rate error when trying to record and playback tracks. I am running 10.5.3 and kernel 9.3.0 vanilla. I switched my kernel to speedstep 9.2.0 and it seemed to fix it. this is at least a temporary fix

Share this post


Link to post
Share on other sites
the new patch is out ! update 8.2

 

anyone with "audio&midi out of sync" and "system overload" have tested the patch?

 

its is finaly solved?

 

im asking becouse i format my pc recently and im not using hackintosh , i just have XP SP3

 

its safe to install hackintosh again just for logic pro 8.2 ?

thanks

nope, I get system overloads anyway...

I'll try to use the script of the top,

that's simply copy-paste the text to script editor, and save as an application changing the password user? that's all?

cool i'll try to do something serious to look if it works

 

Anyway, in script mode, i don't need PID, true?

But anyway I don't found it... how i can found?

 

thanks!

 

something else, Logic gents on playing 21tracks of a drum, each with compresors, limiters, EQs, etc, only 35% of CPU, GarageBand gets 50% CPU.... I don't understand why logic make this {censored} with audio system overloads...

Share this post


Link to post
Share on other sites

I fixed this problem by not doing this method but by ditching mbr and going to guid partition table. WORKS AWESOME.

Share this post


Link to post
Share on other sites

Mattrb,

 

Please explain this step by step (ie. non tech speak!). I'm desperate for a solution to this. Logic pretty much unusable at the moment.

 

TRhanks

Share this post


Link to post
Share on other sites

Hey!

 

Thank You, today night I will try it :lol:

 

I can use in my Leo only my AC97, becouse I do not have driver for M-Audio Delta 66 ... and Logic crash a lot...

 

Thank You, I will post You the feedback, tomorro ;)

Share this post


Link to post
Share on other sites

Well, good try, but the script didn't work on my vanilla 10.5.4 (EFI bootloader and GUID partioned) with logic pro studio 8.0.2

 

I always get audio midi sync notification. Tried it with Edirol FA-66 Firewire and M-Audio Audiophile Firewire cards.

 

Updated now to vanilla 10.5.5 ,solved some other problems for my Gigabyte GA-P45-DS4, but nothing for logic audio midi sync notification.

 

I still have somewhere an older M-Audio AP192 PCI audio card and let's hope that the Leopard 10.5.3 drivers work on 10.5.5.

 

Anyway on Motu software Digital Performer 6.0, I don't get errors, but I don't like the program that much. I am desperate, have some

 

projects coming and they need Logic or Protools program. I paid already enough for Logic Pro Studio.

 

I remember that with an older version of Leopard, Kalyway 10.5.2 and my old, now broken, gigabyte with ICH-8R, Logic worked, anyway

 

I remember that I played the demo songs that where included.

 

My last possibility is using another kernel.

Share this post


Link to post
Share on other sites

I can confirm that switching to the speedstep kernel fixed my audio/MIDI out of sync problems, on both my ASUS P5KC/Q6600 and HP dv9000 laptop.

 

I started with Kalyway 10.5.1 on the ASUS and 10.5.2 on the laptop, and did all of the upgrades to 10.5.5, and Logic 8.02 (which doesn't show up after doing the update by the way). I used the speedstep kernel from 10.5.2 to fix it.

 

Also had CPU overload problems on the laptop. Fixed that with renice -10 -p 222 (222 being the process ID of Logic) from a terminal window as root (sudo sh). You can find your PID with ps -ef|grep Logic.

 

The man page for renice shows usage of -p to renice a PID. Not sure if it's absolutely necessary.

 

The only remaining issue I have is that only one core of my duo 2.1Ghz CPU is being used on the laptop. All four cores show usage on the Q6600.

 

If anybody sees an answer for that floating around, post it here, if I don't find one and post it first.

 

Almost forgot - I had absolutely none of either problem on my Gigabyte/Q6600 systems (I have four) built up from Kalyway 10.5.1.

 

I can just see Apple Support saying "Oh yes, you just need to switch to the 10.5.2 Kalyway speedstep kernel" to regular Mac users with the sync problem.

 

UPDATE - Ok, I think I may have just had a problem with a couple of Logic audio preferences settings on my laptop. I had the I/O buffer set to 32, the minimum. Bumping it up to 256 got rid of the CPU overloads, even without the renice. Then, I unchecked the I/O safety buffer checkbox, and it worked fine with the I/O buffer set back down to 32. That allowed the song to play in far enough for me to see that both cores were actually being used.

Share this post


Link to post
Share on other sites

Does anyone know if this issue has been solved already?

I just found out that plugging my laptop to AC power dramatically improves the one core cpu spike behavior.

Can someone try it out, just to confirm that AC/Battery power is affecting Logic performance?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×