Jump to content
-DuNe-

AppleIntelPIIXATA kext fully working for all ICHx Mobo (All Sata Channels working)

418 posts in this topic

Recommended Posts

ok i have found more about my problem. leopard will not recognize my HD in the Disk Utility during installation. I thought it was my HD kexts that was the issue. It is really my Mobo. I have an ATI Chipset Mobo.

 

Problem: Tiger installs fine but Leopard does not have my ATI Chipset support.

Solution: Inject Tigers ATI Mobo kexts into Leopards installation disk (which i already know how to do)

 

What i need help on is i need to know which kexts do i take from Tigers install to make Leopard support my Chipset?

 

 

 

 

P.S. Screenshot below are my Tiger Kexts from a working install on my PC (you may need to zoom in)

post-195491-1208819491_thumb.jpg

Share this post


Link to post
Share on other sites
Advertisement

How about RAID0 config? I have Kalyway 10.5.2 and it does see two drives in disk utility on install, but not 1 single drive as array.

Seems intel uses fake raid (software raid), a file that defines the array and must be read.

 

On a Dony AR290G with 2 100GB drives.

Share this post


Link to post
Share on other sites

I have a problem wiht my Asus P5LD2 SE with 10.5.2. When I use 2gb , everything runs perfect, but when I put 2gb more for a total of 4gb, I have a kernel panic when the sistem use more than 1.67 gb.

With only 2gb of ram I can use the whole 2gb but with 4gb only 1.67?

Any idea? I have my sata HDD in IDE mode. I used the Dune Kext, nothing happend. I limited the ram in 3gb , the same issue.

help!!!!!!!

Share this post


Link to post
Share on other sites

Ok I got one step further. I successfully installed it on a 500GB USB drive and it wont recognize my internal IDE\ATA drive. If i can find out my problem then i can clone it and restore it to my internal drive.

 

Here is how I got this far, and step 4 is what I need to do still

Step 1: "still waiting on root device"

Step 2: used EXTERNAL USB DVD drive to get to installer but it didn't recognize HD

Step 3: installed to USB hard drive

Step 4: need to find out how to make it read my IDE\ATA internal HD then clone it to it.

 

can somebody pleeeze help me get Leopard to recognize my Internal ATA Hard Drive? fyi I am using a ATI chipset Mobo.

Share this post


Link to post
Share on other sites

Hi

I did exactly as instructed, deleted AppleViaAta kext, used kext helper to install IOATAFamily kext. Touch/delete Extensions.mkext. When I reboot the system couldn't find my IDE OSX install drive. It stays in the gray screen until an icon telling me the boot drive isn't available. I started in single user mode, the same thing, i get a message 'still waiting for root device. I had to revert back to the old AppleViaAta kext.

 

any help is very much appreciated.

 

my set up: Gigabyte P35 DS3P

2 SATA

1 IDE - OSX install

Share this post


Link to post
Share on other sites

SUCCESS on Gateway MT3707 "still waiting on root device" problem

 

Here is the problem and the solution:

PROBLEM: "still waiting on root device"

Step 1: used EXTERNAL USB DVD drive to get to installer screen but it didn't recognize my HD

Step 2: successfully installed to USB hard drive

Step 3: injected some kexts from Tiger 10.4.9 which seemed to work

Step 4: once it recognized my Internal HD I then cloned the Leopard installation from my USB HD to my Internal HD

 

List of Kexts I injected:

-AppleACPIPlatform

-ApplePCCardATA

-ApplePS2Controller

-AppleStorageDrivers

-AppleVIA

-AppleVIAATA

-ATINDRV

-ATIRadeon.....(all of them)

-IOACPIFamily

-IOATAFamily

-IOPCIFamily

 

I dont know which one of these did the trick but all I know is is that it worked!

 

JT, the son and partner of trf on the (OQO now has the worlds smallest MAC!) project

Share this post


Link to post
Share on other sites

Same here. IDE drives disappear... :-( ASUS P5B

AND SATA 0 stops working. 1-4 works though.

 

Any way to get IDE drives back? 

Share this post


Link to post
Share on other sites

Dune,

 

:thumbsup_anim:

I applaud you for what you have done and been doing for the OSX86 community.

your .kext totally fixed my >3GB memory problem.

i used to enable memory remap in the BIOS for KP-free environment, but now, with memory remap disabled, i'm finally totally utilizing 8GB and flying.

 

my config:

 

Q6600 3.6G

P5K Premium

4 x 2GB Adata

7900GTX 512MB (flashed BIOS for darwin to recognize the full 512mb)

250G HDD x 2

Share this post


Link to post
Share on other sites

would this fix be relevant for my nforce430 board with 4 gb i know the panics i get are caused by the ata drivers and the motherboard manual mentions ich (but its not intel). So what does anyone think should I use. The board is a asus M2N-vm dh. PS the panics go when i limit mem

Share this post


Link to post
Share on other sites

I didnt used this before.

Updated from 10.5.2 to .3 , using 10.5.2 HD .kexts.

 

Question:

I have an MSI P965 NEO-F

Device IDs of my INtel (965) SATAs:

2820:8086, Intel 8201H (IHC8) 4 Port SATA IDE Contr

2825:8086, Intel 8201H (IHC8) 2 Port SATA IDE Contr

Whats the difference between them (confuseing because also JMICRO has one SATA in my board)?

 

I know there are 2 or 3 .kexts i must add / change dev-ID in their info.plists.

I looked in but not in all are those IDs already listed.

 

On my Board the is one SATA connection which is controlled by JMICRO (i dont use that)

and 4 SATA connections i think controlled by INtel .

 

How can i use them as ICH8 ?

How can i see in which mode (the ICH8 Mode or the other/my mode(i dondt now how you all it) they are used ?

 

I added my Systemprofiler output of the Serial ATA and IoRegeister Screen.

MY DVD is on the ATA (IDE) JMIRCO i know thats not good, will buy sometimes an SATA DVD.

 

 

Thanks

Share this post


Link to post
Share on other sites

I am using your AppleIntelPIIXATA on 10.5.3

But i get kernel panic (only if i clone).

Normal work with HD no kernel panic.

 

My current situation:

is hown with IOREGISTRY screenshoot in end of the tread AppleIntelPIIXATA

 

 

Question:

 

It may be the fastest UMDA Mode 5, that be an problem (timing to hard for that software).

Kernel panic mostly comes up when large / high transferof file (Cloning!).

Normaly work with HD didnt give kernel panic.

 

 

So can you (which made this AppleIntelPIIXATA.kext (within IOATA.familiy) limit UMDA to 4 ?

Would give no big performance problems on normal work and work with small files.

 

 

 

I found that in AppleIntelPIIXATATiming.h it may the easiest way to change that.

change line

{ 5, 1, 16, 1, 20, kPIIX_PCI_IDECONFIG_FAST_PCB0 }

into

{ 5, 2, 8, 2, 30, kPIIX_PCI_IDECONFIG_PCB0 } (same as 4)

 

 

orig.

static const PIIXUDMATiming

piixUDMATiming[] =

{

/* Mode CT RP UDMATIM Cycle U-DMA Clock */

{ 0, 4, 6, 0, 120, 0 },

{ 1, 3, 5, 1, 90, 0 },

{ 2, 2, 4, 2, 60, 0 },

{ 3, 3, 8, 1, 45, kPIIX_PCI_IDECONFIG_PCB0 },

{ 4, 2, 8, 2, 30, kPIIX_PCI_IDECONFIG_PCB0 },

{ 5, 1, 16, 1, 20, kPIIX_PCI_IDECONFIG_FAST_PCB0 }

};

 

Sure, would be better to change/limit UMDA to Mode 4 in some .cpp code, because

IOREGISTRY would show UMDA 5 Mode, and we didnt know if it is an Patched Mode 5 (to 4)

 

 

Thanks

Share this post


Link to post
Share on other sites

Hi,

 

I am currently running 10.5.2 with this KEXT. If I update to 10.5.3 will my kext be overwritten and are tehre any known issues caused by the 10.5.3 update that might break things with this kext?

 

thanks

Share this post


Link to post
Share on other sites

Hi all, I have little question. I have LG-GSA-H55N dvd-rw not connected with Sata cable, I think it is Pata/ the old big and {censored} cable like for the old Hard disk with Jumpers,master,slave and etc./. I installed Leo4All 10.5.2 v2 but I haven't DVD-rom. It is showing me : No drivers. I understand this one can help me, or it is only for Sata devices? I read there are problems with the memory if the DVD-rom is not Sata. Or I need to remove little memory?

Share this post


Link to post
Share on other sites

I know this is an oldish thread, but thank you very much, it fixed my problem completely!

 

I had an issue that was tough to track down because it only appeared occasionally - my system would freeze up (no kernel panic or error messages, just a frozen gui and no hdd activity) during some operations, such as compressing a large file (I used my aperture library to test). Oddly enough, most of the time the computer functioned, even in iMovie.

 

Anyway, just wanted to let you all know that this kext (the 10.5.2 one) works in 10.5.4 on my Asus P5K system with 4 GB RAM.

Share this post


Link to post
Share on other sites
When I installed the IOATAFamily.kext, cleared caches, and did a boot -v, I got an error missing AppleGenericAta.kext. I added it to Dune's plugins. While it works via AppleGenericAta, I am trying to get the secondary SATA port "seen". This is a Lenovo ThinkCentre M52, so no AHCI option. There is a "automatic" and a "native". Both BIOS settings yield the same results. Thanks.

 

Have you had any luck with this since? I get the same errors on my M51.

Share this post


Link to post
Share on other sites

I don't know if -Dune- or anyone else is still reading this thread. But I'm at a loss for how to get my system stable as far as this >2GB kernel panic. I've had my install of the iATKOS v2.0i Leopard 10.5.2 working for several months now. But from the beginning, it's given me a kernel panic whenever more than 2GB is saved out (like exporting video in Quicktime Pro). It's not that it has a problem with large files. I don't know if I need a new kext for the IDE controller or what. This panic does NOT show up when I transfer to an external firewire drive, though. I've transferred over 500GB to that drive in OSX. It's only when files are utilized by my OSX system drive (an IDE drive). I've done a lot of research about this problem, but I'm not really sure how to narrow down what's causing it on my system (memory issue, HDD issue, etc). I have just now deleted the JMicron.kext file and I now get a circle with a slash through it when I try to boot into OSX. I had tried -Dune-'s new kext and it didn't get rid of the panic. But I'm not even sure I properly injected it and did the steps in the correct order. I'm a little unsure about the process of using kexthelper, terminal, and rebuilding permissions, and what order all that needs to happen in order to insure that kexts are injected properly. What I did was to download the kext from this thread, reboot into OSX, delete the AppleViAATA kext in System/Library/Extensions, delete Extensions.mkext, reboot, repair permissions, delete IOATAFAmily.kext, open terminal, type the commands from the first post in this thread, reboot, repair permissions again. Nothing seemed to change.

 

Here are my hardware specs in hopes that someone can offer a suggestion for what I need to do.

 

iATKOS v2.0i Leopard 10.5.2

 

GA-P35-DS3L Mobo

8GB RAM (OSX recognizes all of it)

Core 2 Quad Intel processor

NVidia quadro FX 370

30GB Western Digital IDE Master HDD (running OSX)

80GB Seagate Barracuda 7200.10 IDE Slave HDD (running Windows XP)

Intel ICH9 Serial ATA storage controller

 

 

Let me know if there's any other info needed. Thanks for any help.

Share this post


Link to post
Share on other sites

Hi

I succesfuly installed from retail dvd using boot-132 method and updated to 10.5.1, next 10.5.5 (ComboUpdater from Apple) and installed needed kexts.

Everything seemed to work, but I noticed that DVD drive stoped respond (no ejected) after few minutes with disk in it (can't eject other removable drives too).

Tried different combinations, various of kexts, no results. I've the same problem with GA-G33-DS3R. Both mobos has ICH9R.

Anybody noticed that issue? How can I resolve it?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×