Jump to content
-DuNe-

AppleIntelPIIXATA kext fully working for all ICHx Mobo (All Sata Channels working)

418 posts in this topic

Recommended Posts

to Matthewmak:

 

I installed the newest IOATAFamily.kext, and deleted AppleVIAATA.

But my ide DVD driver doesn't work.

And then, i seem the AppleIntelPIIXATA coundn't load.

How can i do, Please help!

 

My motherboard is ASUS P5Q-E.

OSX 10.5.7.

 

It seems your motherboard has an ICH 10 chipset. I think AppleIntelPIIXATA should work with it but you must add ICH 10 ID into the info.plist. I am not sure about the result and i haven't any ICH10 Motherboard for testing.

 

 

to zzzainus :

 

For 10.5.4 use the IOATAFamily.kext for 10.5.2 to 10.5.5 or the one you can found on the Kalyway 10.5.2 (it is the same). not the 10.5.7 one. Did you install the kext correctly following the instructions on the first page ? did you repair permissions ?

 

Hi,

 

I am noob in Retail Leo install, currently using Leo 10.5.4 retail install disc.

 

my motherboard is Gigabyte GA-EX38-DS4.

 

I am installing retail via Boot 132 method and My BIOS setup is like this:

 

- Limit CPUID - Disabled

- No Execute Memory Prot - Enabled

- CPU Enhanced Halt - Enabled

- CPU EIST Func - Enabled

- Virtualization Tech - Enabled

- ACPI Suspend Type - S3

- PME Event Wake up - Enabled

- Power on By Ring - Disabled

- HPET Support - Enabled

- HPET Mode - 64 bit

- SATA RAID/AHCI Mode - Disabled

- SATA Port Native Mode - Disabled

- Onboard SATA/IDE Device - Enabled

- Onboard SATA/IDE Ctrl Mode - Disabled

 

Unfortunately, in this board I donot have option for Legacy IDE, only AHCI which i don't want to change as I have more than 2 SATA HDDs and

 

it seems that SATA Port Native Mode - Disabled means Legacy IDE.

 

when I used this 10.5.7 IOATAFamily.kext and boot from boot 132 CD i cannot see my SATA HDD, only IDE DVD is detected in Diskutil.

 

Strangely though when i boot via kalyway i can see my HDD without any problem with same BIOS settings.

 

system Ram is 2 GB which i guess is not a problem anymore. but can anyone help me what i need to do in order to be able to see my HDD during install?

 

btw my SATA is ICH9-R when i see via Kalyway install. its strange when i used all the kexts provided in the kalyway disc same result came :P

 

may be its because i am using 10.5.4 retail and kalyway is 10.5.2.

 

please also specify all the kexts needed along with IOATAFamily.kext for my ease as may be this problem would require some other kexts.

 

Thanks for your help in advance :)

 

edited on : 28-may-2009

Share this post


Link to post
Share on other sites
Advertisement

I'm having issues with my ICH9 motherboard (P5K Pro). I've done a clean install of 10.5.4 using Boot-132, then upgraded to 10.5.7 using the combo update and switched to Chameleon 2.0rc1. I've installed the latest version of IOATAFamily.kext.

 

My harddisk containing the OS works like a charm (first SATA port), but the second hard drive and my optical drive (ports 2 and 5 respectively) are really slow. When try to open the second hard drive, Finder takes about a minute to give me my root-folder contents. When I start to copy a large file from this disk, transfer rates are limited to a couple MB/sec interrupted by spontaneous halts.

 

To verify this is not a hardware problem, I booted an Ubuntu LiveCD and copied some large files from one drive to another and got transfer rates of 100MB/s without interruptions. Therefore, I think it is safe to say that my hardware is OK.

 

Concerning the IO kexts, I have installed only IOATAFamily.kext, and the kexts that come with Chameleon 2.0rc1 (AHCIPortInjector.kext, ATAPortInjector.kext and IOAHCIBlockStorageInjector.kext). I also tried disabling these three kexts, but I got the same results.

 

My install is 100% vanilla, I use my EFI partition for Chameleon and the custom kexts.

 

Does anyone reconize, and maybe know a solution to these issues?

Share this post


Link to post
Share on other sites

Quick question for Dune or others who might know, I am using the kext for 10.5.7 in 10.6, but it is keeping me in 32 bit mode, is the patch that was done to IOATAfamily to enable the use of all SATA and IDE devices a hex hack or a recompile fix? is there a patched 64 bit IOATAFamily?

 

just wondering.

Share this post


Link to post
Share on other sites

Here is Dunes kext I edited to work with ICH10:

 

Download Kext

 

Only works for me on my Asus P6T7 board with Sata set to IDE & Compatible. For some reason it does not work in Enhanced mode (Still waiting for root device) even though I put that device id in there as well. I cannot get AHCI working either (Still waiting for root device) when editing AppleAHCIPort.kext, but Dunes fix works well in compatible IDE mode.

 

Snow Leopard works fine in AHCI mode though!

Share this post


Link to post
Share on other sites
Quick question for Dune or others who might know, I am using the kext for 10.5.7 in 10.6, but it is keeping me in 32 bit mode, is the patch that was done to IOATAfamily to enable the use of all SATA and IDE devices a hex hack or a recompile fix? is there a patched 64 bit IOATAFamily?

 

just wondering.

 

It is a recompile. no patched 64 bit version until now.

Share this post


Link to post
Share on other sites
For some reason it does not work in Enhanced mode (Still waiting for root device) even though I put that device id in there as well. I cannot get AHCI working either (Still waiting for root device) when editing AppleAHCIPort.kext, but Dunes fix works well in compatible IDE mode.

 

Same problem with ICH6 and 10.5.7 :P

Share this post


Link to post
Share on other sites

Can you make a no-AHCI version for 10.5.7 please ?

Like in 10.5.5 on iATKOS 5i :)

Share this post


Link to post
Share on other sites

hi guys

 

Can i add this file for installer DVD or any other way to let installer recognize my hard drive ICH9M controller

i can't even install in my laptop. hp DV5 1135ee. it's give me Still waiting for root devices.

 

I use many version like IATKOS v7 and Idenb 10.5.6 and IPS

 

Thanks

Share this post


Link to post
Share on other sites
hi guys

 

Can i add this file for installer DVD or any other way to let installer recognize my hard drive ICH9M controller

i can't even install in my laptop. hp DV5 1135ee. it's give me Still waiting for root devices.

 

I use many version like IATKOS v7 and Idenb 10.5.6 and IPS

 

Thanks

Yes is the answer. Use this guide as an example:-

TriBooting - NForceATA Kext-Patched JaS 10.5.4 DVD Install of Leopard 10.5.4 on External SATA HDD on an Asus P5N32-E SLI Plus MOBO

http://mac.blogdig.net/archives/articles/September2008/09/TriBooting___NForceATA_Kext_Patched_JaS_1054_DVD_Install_of_Leopard_1054_on_Exte
rnal_SATA_HDD_on_an_Asus_P5N32_E_SLI_Plus_MOBO.html

(in one line)

Or you can use Boot-132 method.

 

kizwan

Share this post


Link to post
Share on other sites
Yes is the answer. Use this guide as an example:-

TriBooting - NForceATA Kext-Patched JaS 10.5.4 DVD Install of Leopard 10.5.4 on External SATA HDD on an Asus P5N32-E SLI Plus MOBO

http://mac.blogdig.net/archives/articles/September2008/09/TriBooting___NForceATA_Kext_Patched_JaS_1054_DVD_Install_of_Leopard_1054_on_Exte
rnal_SATA_HDD_on_an_Asus_P5N32_E_SLI_Plus_MOBO.html

(in one line)

Or you can use Boot-132 method.

 

kizwan

 

I think boot-132 mush more easy, can you help me with easy way please .

 

Thanks for your help

Share this post


Link to post
Share on other sites
I think boot-132 mush more easy, can you help me with easy way please .

 

Thanks for your help

Please forward your request in this thread because it is much appropriate:-

Boot-132 Loaders for Retail Vanilla Leopard Install in a Disk Partition

 

I will try to help you there. Also look at my blog to learn how to modify Boot-132 base on your hardware specification. Link is at my signature.

 

kizwan

Share this post


Link to post
Share on other sites

Thanks! Works perfectly! OS X works much faster now. The controller is now shown in system profiler as Serial-ATA (was ATA).

Highly recommended! B)

Share this post


Link to post
Share on other sites

Well, after a system update to 10.5.8, a little problem with the kext appeared.

Its no longer functional. Maybe I need to change something in the extensions folder.

Share this post


Link to post
Share on other sites
It was probably overwritten, try reinstalling it.

 

Yes it was. Reinstalling the IOATAFamily.kext (Vendor/Device ID inserted to AppleIntelPIIXATA.kext) from backup solved the problem.

Share this post


Link to post
Share on other sites
NOw that the sources for 10.5.8 kexts are out, could someone update these fixes to the new driver

 

i will do it next week :)

Share this post


Link to post
Share on other sites
Quick question for Dune or others who might know, I am using the kext for 10.5.7 in 10.6, but it is keeping me in 32 bit mode, is the patch that was done to IOATAfamily to enable the use of all SATA and IDE devices a hex hack or a recompile fix? is there a patched 64 bit IOATAFamily?

 

just wondering.

 

+1...

Hi DuNe. Could do it please, much needed in -64x mode.

Share this post


Link to post
Share on other sites

hi everyone,

 

I know all of you are waiting for a new release. Don't worry i will do it. The problem is that actually i am very very busy at my job so i have to find the time to correct AppleIntelPIIXAta.

So please be patient and again sorry for late ;)

Share this post


Link to post
Share on other sites
hi everyone,

 

I know all of you are waiting for a new release. Don't worry i will do it. The problem is that actually i am very very busy at my job so i have to find the time to correct AppleIntelPIIXAta.

So please be patient and again sorry for late :)

 

Don't worry, we are patient :D

 

Google, you lazy asses...

http://netkas.org/?p=125#comments

 

Don't work in -x64 mode.

Share this post


Link to post
Share on other sites

NEW 10.5.8 VERSION AVAILABLE (with ICH10 added too :rolleyes: )

 

Look at First Post !!

 

Enjoy,

 

DuNe

Share this post


Link to post
Share on other sites
NEW 10.5.8 VERSION AVAILABLE (with ICH10 added too :P )

 

Look at First Post !!

 

Enjoy,

 

DuNe

Thank you very much.

 

Hope Snow Leopard sources will be available soon :P

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×