Jump to content

Acer 5002WLMI OSX86 Installation Progress

Chaos Storm

1 post in this topic

Recommended Posts

I figure I would post this here for any who have similiar notebooks to let them know some options for OS X86 on the Acer notebooks.I tried many ISO releases but in the end the only one that would boot properly was HOTiSO.It's not advisable to boot from the internal DVD drive, I never got it to work. Even though the BIOS for the Acer 5002WLMI does not mention any ability to boot from USB DVD drives, my friend's did. I couldn't quite figure out why, but here's what to do to test it out:Make sure the boot settings allow the DVD to boot first then HDD. Hook up your USB DVD drive while the unit is off. If you plug it in while it's on and in the BIOS, it may crash. Acer's Pheonix BIOS has very buggy and patchy support for this, it seems you have to perform several incantations and rituals to make it work and wait for a sign from within.... ;-)Insert your Mac OS X DVD into the external USB drive, then immediately power the unit on. If your Acer supports booting from USB DVD, the Acer logo should appear to "hang" untill the USB DVD has finished spinning up and recognized the disc. It then should boot from the DVD. If it doesn't, I'm afraid I don't know how else to proceed.Now that you can boot, it's very important to press F8 as you need to enable verbose mode "-v" as this will allow you to note certian errors and correct them.Certian USB devices will cause timeouts, I am unsure if it's faulty USB chips or just the devices that push the limits. You will need at least a USB Mouse connected. If it keeps timing out, keep it unplugged, Mice can be plugged in at any time.At some point during the boot sequence, it will list your Synaptics Trackpad and wait. If you leave it long enough it will say "Still waiting for root device."Unplug the USB cable from your DVD-ROM drive and plug it back in. If it worked a message should say that IOUSB has no kernel dependancy and it should say it got the root device. I believe this is similiar to when Mac OS X originally shipped (OS X Server 1.2) how it would try to "reset" SCSI devices and resync them, but would fail. Thankfully since USB is hot swap, we can reset the device itself.You will probably see alot of text and probably errors. You should be able to safely ignore them. The graphical screen should load at some point and you can plug your USB mouse in and partition the hard disk and select the required packages. The 5002WLMI I tested only had SSE2, so a patch was required. (Included on the DVD)It takes a while to install, about an hour and half from what I recall.Upon first boot you will need to plug in a USB Keyboard because the built-in one won't work. It should be plugged in by itself, along with the DVD USB drive, as somehow the HDD is not always made bootable. I haven't made any progress beyond installation but thought I would give this info to others.I am taking photos of the motherboard chips as I have a dead MB from this notebook so I can see what chips need drivers etc.




Here are the chips used by this Acer










SWAPNET C0545 / NS681685




Unknown Chips:MAXIM 97S5E / TI539VS542BF


PCI BUS PCI1410APGE / 7F59A8XTW / G4ICS CA532405

Link to comment
Share on other sites


  • Create New...