Jump to content

Injecting kexts from Linux


5 posts in this topic

Recommended Posts

I use gutsy with XP in virtualbox. I have searched all over the forums, and found nothing. So I am wondering that if you are a linux user, how did you go about injecting kexts into your iso/dvd. I thought the only way possible was to run XP in a virtual machine and use transmac to do it, but I just discovered that hfsplus (in gutsy repositories) can read my tubgirl 10.4.10 disc with the command-


sudo mount -t hfsplus /dev/scd0 /media/dvd-ram
sudo umount /dev/scd0 <b>(to unmount)</b>


I can now see the HFS+ folders/files on my tubgirl disc and I assume that I am able to add/remove kexts at will (couldn't figure out how to do that in transmac). Right now though I am in the slow process of getting zepyhroth's leo iso so I can install it on my harddrive, but I want to see if I can get tubgirl 10.4.10 (which I already have) running in vmware. Since that didn't work the first time, I want to see if changing the kexts will work. I know that it probably won't, but I also want to practice doing it since I never had to before and I am probably going to need to for zepyhroth. Also just in case zepyhroth's dvd fails, I could try tubgirl again.


Is this the right tutorial for injecting MeDevil's kexts. If so, can I use those same commands on linux. Also I read here that you can enter those commands from the os x install dvd. Is this true, and how would I go about. I mean do I reboot while keeping the dvd inside or what?






HP Pavilion a6230n PC

Asus M2N68-LA Motherboard

Nforce 430


Nvidia GeForce 6150 SE Graphics

Hitachi 400GB SATA


If you need more info, just ask.

Thanks for any help and I hope I wasn't too confusing. :unsure:

Link to comment
Share on other sites

sorry I can't help with your specific issue, I'm not too familiar with working with dmgs and hfs images etc...


but I can't help but wonder why you're going to all this effort to build things into the cd... can't you use a flash drive or another cd or a floppy or something?


I'm not sure if osx has support for ext2/3 or riserfs or whatever, but I know it supports ntfs and fat32.. when I needed kexts I left them on my windows partition and I was able to get to them from osx just fine. on another setup where I only had one drive, I used my ipod to transfer kexts... worked fine.

Link to comment
Share on other sites

Thanks for responding. The reason I am going this far is because I am confused as to when I am supposed to do the permissions part of the obsidianx tutorial. I can now do the 'moving the files around' part with hfsplus. He says I need a mac (probably in vmware), but m0rb0 says that I can do it from the mac install disc. Probably should have mentioned this, but I tried installing 'Tubgirl 10.4.10' months ago, but it couldn't format my HD. That is why I am so worried about the kexts this time around. I still need a small quick tutorial for a linux user who cannot get tubgirl (or the other osx's I tried) running in vmware. Every tut I came across assumed you either had a mac or that you had mac running in vmware.


A few questions-


Just how do I go about setting permissions?

Can I do it with the linux terminal?

Does osx install disc gives me a chance to do it and if so when do I do it?

Or am I supposed to do it after I have installed and removed the disc?


Once again thanks for the help. I finally got zephyroth, and will be trying it after school.

Link to comment
Share on other sites

I now just need this one question answered now. As said here you need a mac for the permissions. If my short term memory serves me correctly, the os x install disc has a terminal. So can I move the kexts into the tubgirl or zephyroth disc with poweriso, then boot into tubgirl or zephyroth, and use the terminal to set permissions?


PS- I just got an idea at what inedible was getting at. I forgot to mention that when I tried tubgirl, it wasn't able to format my drive to hfs+. All I need is to be able to format my partition in hfs. If that is even possible?

Link to comment
Share on other sites

I finally found the info I was look for here and here (roisofts help).


If I got this correctly, I use transmac to mv AppleNForce.ATA.kext to /system/library/extensions/IOATAFamily.kext/Contents/Plugins in the iso. Then I burn the iso and boot with the flags -f (reloads all the kexts and rebuilds the kextcache) and -v (verbose). If that install is a sucess, I reboot and use the boot flag -s and type "mount -uw /", then "cd /system/library/extensions/IOATAFamily.kext/Contents/Plugins", then "chmod -R 755 AppleNForceATA.kext", then "chown -R root:wheel "AppleNForceATA.kext", and reboot with the boot flag -f.


I am burning the iso right now. Can someone tells me if this is right? Also I plan on using my meizu m6 to transfer to kext once the install is done. Where do I mount it in the terminal, or am I getting this wrong. Do I first reboot into OSX after the install is done, move the kext to my desktop (or somewhere), then reboot, and use the -s flag? Once again thanks for any help.


Edit- Okay I followed this method and got the "still waiting for root device" error. Now trying to find a solution.


Edit2- No ahci to disable in my bios.

Link to comment
Share on other sites


  • Create New...