Jump to content

Home Volume suddenly 'Unformatted' and unable to mount. Need to recvover files..


4 posts in this topic

Recommended Posts

I hope any of you can save me a lot of time and pain lol.


I went to reinstall iAtkos, so with Partition Magic in Windows I deleted an old NTFS partition, resized my Windows partition and didn't touch my Home partition of Leopard, I didn't do anything with it.. only now it shows up as 'unformatted' in Partition Magic, I don't dare to do anything with it.. and I tried DiskWarrior, which can't do anything apparently.


Now scanning with some other applications, hopefully they'll show up with something.


But anyway, I need my Home partition restored.. anyone know how?


This is the output of diskutil list :




0: FDisk_partition_scheme *74.5 Gi disk0

1: Windows_NTFS System 9.8 Gi disk0s1

2: Apple_HFS Leopard 15.7 Gi disk0s2

3: Windows_NTFS 37.3 Gi disk0s3 << The one I need restored.


Also tried the following command :


sudo fsck_hfs -rfd /dev/disk0s3


Which finally outputs :

** The volume Home was repaired successfully.


Only at disk util it still shows as disk0s3 and NTFS partition, can't mount it and can't use First Aid on it either since it shows up as 'unknown file format'.


Anything else I can try? I really need the data recovered,. I figure it's a simple partition table error since I didn't touch anything else.


Thanks alot in advance. :)

Link to comment
Share on other sites

It's sata, the other partitions work normally. iAtkos r2 is installed together with XP. Both booting normally via the efi bootloader. Win XP on /dev/sda1 and osx on /dev/sda2 now, /dev/sda3 (disk0s3) is the partition that's unrecognizable now, and after that there's some free space too but I plan to recreate the partition to fill it all up after I get my data off it.. I know I should make backups, always do. But I felt like 'I'm not gonna touch that partition anyway'.


It won't recognize the partition as hfs+ only says it's ntfs or whatever while it isn't x.x


And lol, good point.




Good news =D I tried to boot with my Fedora Live CD to see what Gparted would say about the partitions, (your last comment made me think lol =p). And it recognized it normally as 'hfs+ partition', shortly after I found out I could mount the volume in Fedora and copy all of my stuff over to my external HD. So now I did that and I'm reformatting the home volume.. everything's okay. yay :) Thanks!

Link to comment
Share on other sites

  • 1 year later...

Serphi - if you copy all the files and overwrite after a fresh installation - would it restore everything?


I'm having the same trouble as you were before...


I'm going to run the fsck_hfs command and see what that does...

Link to comment
Share on other sites


  • Create New...