Jump to content

Anyone try Leopard on ASRock 4CoreDual-SATA2?


6 posts in this topic

Recommended Posts

  • 2 months later...

I have that motherboard, an E2160, and GB of DDRII 667 RAM. The only build that worked for me was Leo4All. I had to use AppleHDAPatcher v1.20 and the ALC662.txt Linux dump from this site to get the sound working.


Also, I only was able to use one core, or else my ethernet would die after 5 minutes after boot time, using both a PCI card, and the onboard LAN. Not sure how to fix that.

Link to comment
Share on other sites


I saw a leopard moving.


Install method: Kalyway.


CPU : Core2Duo E4400

M/B : 4coredual-sata2

Memory : DDR2 800 1G×2

LAN : onboard

audio : onboard

VGA : Geforce 5200(AGP)

HDD : 80G(IDE)

Drive : LG (IDE)


Check boot_efi_mbr.

Without vanilla,Drivers.


Drivers are introduced after leo install.


Lan driver is viarhine-rel.tar.gz(ver.10.4.8)(See X86 HCL. http://wiki.osx86project.org/wiki/index.ph...L_10.4.8#ASRock )


Audiodriver is ALC888.


VGA driver is NVinject ,0,1,5-Leo.zip.


No problem is the installation.Boot from the Hdd.





Link to comment
Share on other sites

Actually, on the 4CoreDual-SATA2 which I have, Kalyway will not boot, but it could be my IDE drives, or other problems, but the only build I've got working is Leo4All.


As for the Audio, it's not ALC888, it's actuall ALC662, and the only way to get it working is with a linux dump and AppleHDAPatcher v1.20.


It works great, EFI + 9.2.0 Kernel, no Vanilla, even though my E2160 supports it, it won't boot for some reason.


Also, the onboard ethernet will stop working after random times using the Via Rhine II from above, the only fix so far is to boot with the "cpus=1" flag at boot.


There are some USB and PCI cards that are said to have legit mac drivers, one of which is a Linksys WUSB54GC, which you can find at Walmart.

Link to comment
Share on other sites



Why ?


I can see Leopard moving.


Install method: Kalyway.


Boot from the Hdd


No problem is the installation.


No problem in the network.


Do you use another router or the hub between a router and a PC?


There is possibility of the problem in it if you use it.

Link to comment
Share on other sites

  • 1 year later...

After countless hours, finally got this board fully stable and working.


This is the only way i got it working


MB= 4coredual-sata2 rev. 2


bios= 1.9






Distro: IPC 10.5.6 PPF5




Kernel = 9.5.0 Voodoo


Chipset = VIA (it is the universal 1 for many other chipsets)


Ethernet = VIA Rhine


Sound = Didn't bother with onboard sound since i used external sound.


Notes: I didn't choose any video kexts because that was the option that kept giving me trouble. I have a GeFroce FX 5200 AGP 128MB and the way i got it working is by not selecting any kexts at install, and using NVKUSHcomplete package after install and it worked great!


I tried to update to 10.5.7 and bricked it!! so i stayed at 10.5.6 and upgraded kernel to 9.6.0!

Link to comment
Share on other sites


  • Create New...