Jump to content
InsanelyMac Forum
  • Announcements

    • Allan

      Solution to create a topic or post.   04/24/2018

      Hello guys. The majority of you are having issues to create a topic or post here. This are a problem with our current theme InsanelyMac.  Now the theme will be the Default IPS. Sorry for any inconvenience.
booger_sniffer5000

Wireless Driver Developer Help Needed

Recommended Posts

Alright, this has been an issue for quite sometime now. And we need help from somebody who can write wireless drivers for osx86. There have are two theories to why this card is not working. Here they are:

 

1. Firmware is needed (Based on the fact that the card is made to work in linux by the bcm43xx project which loads firmware into the card in order for it to work)

 

2. Power is not getting to the card (This could be caused by no firmware being loaded which contains power information to turn the card on)

 

We have tried editing the plist file in AppleAirPortBrcm4311.kext, used all the tutorials there are, dual booting with windows and rebooting into os x which leaves the light on but it doesn't work, editng the NetworkInterfaces.plist, used the kext files mentioned by IO80211Family.kext which causes kernel panics at shutdown, Updating IO80211Family.kext to the 10.4.9 version, and used relevant kext files from 10.4.3. None have worked or even given us progress. Note: when we install we have to remove the card during installation and not install IO80211Family.kext during setup. We have to install IO80211Family.kext from the disc manually and then shut down and install the card. Otherwise, it causes a kernel panic. We are in desperate need of help as I am good with computers and know a tiny bit of C, I am far from a driver developer. If someone with driver knowledge or thinks they know the problem and is willing to help, I would be glad to give you any info needed.

Here is a page with info:http://forum.insanelymac.com/index.php?showtopic=63024 Thank you for your help.

 

Note: This is for the Mini PCI-Express version of the Broadcom card with the pci id of 14e4,4311 , NOT for the Mini Pci version. If your card is a 4311 card and it worked out the box, yours is not a Mini PCI-Express card and please DO NOT post here with your sucess stories of how yours works and how ours should work with just a quick following of a tutorial or adding a pci id, it is not that simple. This card is present in computers like the Compaq c500 and c300.

Share this post


Link to post
Share on other sites
Advertisement

Yeah, my card is the 4311 picked up from an compaq 6720s put it in my hp dv 6395ea, never detected but from dpcimanager also it was picked up in the NETWORK in system profiler on the dvd of iATKOS but not in airport nor after the installation itself with all 802family kexts.

 

oh and installation with the card in the laptop had no problem but a kernel panic on shutdown in 10.4.8 before the airport updates of apple software updater.

 

we really need a help from a developer to debug the peoblem correctly.

Share this post


Link to post
Share on other sites

Some people are using a USB adapter for their wireless. Which one? I can only find $50+ adapters, and that's a little on the expensive side. Is there anything cheaper?

Share this post


Link to post
Share on other sites

All usb adapters are expensive, I have used both the Linksys WUSB54GC and the ASUS usb wireless adapter (I forgot the model name but it is black) although anything with the rt73 chipset will work. Although you have to be careful with the usb wireless adapters as they can bend and eventually stop working I have broken both of mine because of this. Although I did fix one by taking off the case and bending it up until it was detected.

Share this post


Link to post
Share on other sites

I ended up getting the WUSB54GC from target. $70 but pretty small, and gauranteed to work. I'm hoping we can fix this by the 90 day return limit haha, then I can just take this thing back and say it didn't work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



  • Posts

    • Monitor EDID often contains OEM string in Details Timing section. For example Extracted contents: header: 00 ff ff ff ff ff ff 00 serial number: 06 10 df 9c 00 00 00 00 1a 15 version: 01 04 basic params: 95 1d 12 78 02 chroma info: ef 05 97 57 54 92 27 22 50 54 established: 00 00 00 standard: 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01 descriptor 1: c2 23 a0 d4 50 84 1a 30 40 2a 36 00 1e b3 10 00 00 18 descriptor 2: 00 00 00 10 00 00 00 00 00 00 00 00 00 00 00 00 00 00 descriptor 3: 00 00 00 fe 00 4c 50 31 33 33 57 50 31 2d 54 4a 41 37 descriptor 4: 00 00 00 fc 00 43 6f 6c 6f 72 20 4c 43 44 0a 20 20 20 extensions: 00 checksum: 7a Manufacturer: APP Model 9cdf Serial Number 0 Made week 26 of 2011 EDID version: 1.4 Digital display 6 bits per primary color channel DisplayPort interface Maximum image size: 29 cm x 18 cm Gamma: 2.20 Supported color formats: RGB 4:4:4 First detailed timing is preferred timing Established timings supported: Standard timings supported: Detailed mode: Clock 91.540 MHz, 286 mm x 179 mm 1440 1504 1546 1652 hborder 0 900 903 909 926 vborder 0 -hsync -vsync Dummy block ASCII string: LP133WP1 Monitor name: Color Checksum: 0x7a (valid)  
    • "copy to clip board" - "скопировать" "log copied to clip board!" - "журнал скопированного"   First one is better.   Good! I think to reduce EDID as talking above. 
    • And my config.plist I will also try iMacPro1.1 SMBIOS on my build. This may help clarify something
×