Jump to content
shriek

owners thread: Asus C90 / C90S

21 posts in this topic

Recommended Posts

[uPDATE] I've posted updates down the thread

 

[uPDATE] I decided to make this into a Asus C90 thread. I'll try to report everything I know and find about OS X on this upgradeable laptop. It'd be great if others could contribute to this.

 

In january I installed iATKOS 1.0 and for the 1st time I got a computer with osx with both (partial) sound and graphics working (please read the greyed text below). But because of instability I never used it more then to show to some people that it is possible.

 

Now during springbreak I got my hands on Kalyway & new version of NVinject (this time I used NVinstaller 4.1) and decided to give osx86 another change. I got now a stable system that runs quite smoothly (it gets 142 points at xbench) along with parallels. I still can't get proper audio with my built-in audio card and speakers so I'm using a external USB audio-card (C-Media based, check ebay) along with AzaliaAudio.kext which gives me basic built-in speakers sound (no mic, nor headphones, though). I've been using OSX86 full time for the past week now and I'm loving it. I boot into windows every now and then just for Assassin's Creed or some FPS. I had 3 partitions initially (FAT32, NTFS, HFS+) but decided to merge the NTFS one with the FAT32. I'm planning to convert it to NTFS soon as I'm getting some 4GB+ files which I can't handle via NTFS. I have macdrive installed on windows partition so that when I boot into windows I can still have access to my HFS+ filesystem (and thus, share my firefox profile).

 

Also, only 256MB of my Graphic RAM is being detected so I need to find a way to use the full 512MB.

 

This is the state of the union right now.

 

Hi,I finally managed to get iATKOS to install and dual boot with vista on my new Asus C90S. (I followed this guide)

 

I managed to get full resolution and acceleration by installing 10.5.2_NVkexts.pkg. And wireless (Atheros) worked out of the box. The Marvell Yukon Ethernet kext had to be tweaked (can't recall the post I followed but it won't be hard to find).

 

Now I can get audio. I have Realtek HD Audio and following some related posts I tried AzaliaAudio.pkg and managed to get audio only on my speakers (not for line out). So I tried the ACL883Audio.mpkg and later AppleHDAPatcherv1.20+ACL883 dump, both to now effect.

 

Also, I noticed that although graphic acceleration seems to be working I can't play youtube files for more than 2 second before it stops and I have to drag the seeking bar to get another 2 secs of video. In stage6.com (after installing divx plugin) I can get the file to load (and I can seek the video by moving the seeking bar) but can't get it to play. Pressing the play button doesn't do a thing. I tested both in safari and firefox. Interestingly, though, I can get the same stage6 files to play in VLC if I download them.

 

UPDATE: Apparently the streaming video issue was related to the lack of audio (according to this post). So after I restored AzaliaAudio (the driver I could use to get audio through speakers but not through line-out) I managed to play youtube and stage6 flawlessly.Also very annoying is the freezing after screesaver is turned on or when the machine goes to sleep. It just won't restart. I have to force shutdown.

 

Could anyone suggest solutions for the audio, video and freezing issues?

 

PS. Ricoh card reader is not working, just like the webcam and fingerprint sensor but are detected as USB devices. I didn't test eSATA. Firewire seems ok. graphic memory shows only 256MB of the 512MB. I read some solution to this somewhere but can't recall. Any help on these minor issues are welcome as well.

Share this post


Link to post
Share on other sites
Advertisement

I'm bumping this because I have the same laptop with the same problems. Audio doesn't seem to work no matter what I do. My webcam although recognized doesnt work neither.

Share this post


Link to post
Share on other sites

OK, I'm using 10.5.3 now. For that I did this:

 

Using Kalyway 10.5.3 Combo update I updated my Kalyway10.5.2 install. REBOOT

- bakup and delete all NV*kext and Geforce*kext and *bundle.

- install nvinstaller .41 using 512MB option (I didnt choose nvinjectGo this time). DO NOT REBOOT

[from Krazubu post]

- Open the info.plist of the injecter (/system/library/extensions/xxxx.kext/contents/info.plist)

- find IOProbeScore and replace its <integer>XXXX</integer> with <integer>0</integer>

- save to Desktop and replace the original Info.plist with this one (you'll need to authenticate)

- in terminal

sudo chown -R root:wheel /system/library/extensions

sudo chmod -R 755 /system/library/extensions

sudo rm /system/library/extensions.mkext

- REBOOT

 

All these was necessary so that I could keep QE and CI after the Combo update. Still have a lot to test.

 

Continued issues: Sleep not working, Sound still not at 100%

Share this post


Link to post
Share on other sites

Hi Shriek,

 

I have the c90s too and I have also problems with the sound. But I even don't have sound from my speakers.

I also tried the Azalia divers but with no result. Could you give me a short workthrough?

 

Thank you very much in advance.

Share this post


Link to post
Share on other sites
Hi Shriek,

 

I have the c90s too and I have also problems with the sound. But I even don't have sound from my speakers.

I also tried the Azalia divers but with no result. Could you give me a short workthrough?

 

Thank you very much in advance.

 

sorry for the late reply but i didn't get the notice.

 

Yeah, sometimes azaliaaudio doesn't load for some reason. I noticed that after entering single user mode (-s at boot) and running the suggested 2 commands and then exit (will load into OS X) the audio kext will load. Check SYS preferences.

Share this post


Link to post
Share on other sites

Hi, I posted this in another part of the forum before discovering this thread. Hope it helps, and anyway it's a good idea to regroup our c90s experiences together.

 

After many tries with many different 'distros', I managed to install Leo4All v2 on my C90s.

 

Here are a few specs :

Chipset : Intel® 945 G Chipset + ICH7

Proc : Intel Core 2 duo

Graphic Card : NVIDIA Geforce 8600M GT

Sound Card : Realtek

DVD Burner : Mat{censored}a DVD-RAM UJ-850S

Wi-fi : Atheros AR5008

 

For those who have the same laptop, here is how I managed to install Leo4All V2. You will also need a copy of Leo4All V3, although this might not be a necessity, as you will see below, but as this is how I got things working, I've included it.

 

In Customize Install I chose :

 

- Vanilla Kernel 9.2.0

- 3rd Party Drivers/Chipset Drivers/Via and SB Chipset Driver

- 3rd Party Drivers/Audio Drivers /Azalia Audio

- 3rd Party Drivers/Graphics Drivers/NVIDIA Drivers/NVIDIA 10.5.2 Kexts

(Note : ONLY install these Kexts for now)

- Network Drivers/SKGE Drivers

 

Straight after installation, boot back into the Leo4All DVD and repair permissions. Do NOT skip this.

 

You should now be able to boot into OS X, but with low resolution only. So here is what you do :

In the Applications folder there is a nifty app called InVisibles 1.5 engl. Start it and click on visible.

Insert Leo4All V3, all the installation packages should be visible.

Install System/Installation/Packages/NVidia/0.1.3/NVinject-512.pkg

(Note : 0.20 and 0.2.1 also work, but this is the one I chose the first time I got the installation right.)

 

Now this gave me full resolution BUT .... suddenly I had lost my keyboard and touchpad, bummer.

 

Luckily I found the solution here : http://forum.insanelymac.com/index.php?sho...mp;#entry689578

 

Download the PS2Controller.zip file and place ACPIPS2Nub.kext, AppleACPIPS2Nub.kext, ApplePS2Controller.kext in /System/Library/Extensions, keep the original kexts file just in case.

Now repair Extensions with the other nifty app provided with Leo4All aptly called Extensions-Repair. Do NOT skip this.

 

Voila, you should have your keyboard and touchpad back, and a working OS X installation.

 

By "working", I mean it is the bare minimum to comfortably use it.

So far this is what I have found that works :

-Full resolution graphics

-Internal Speakers (Sound is very low)

-USB

-Wifi (Straight out of the box, I tip my hat to the osX86 comunity, even Ubuntu does not do this.)

-Firewire (Not tested but detected)

-Bluetooth (Not tested but detected)

 

Not working :

-Microphone and headset jacks. (This is a bit of a bummer as I use Skype a lot, but no biggy. I found a workaround using a USB Mike and headset, however this uses up my last USB port.)

-Battery indicator

-Webcam

-Card reader

-S Video

-Express card

-VGA port

-LAN

-Modem

-HDMI

 

Some apps do not work :

-Toast (But Firestarter works)

-VLC (PLaying AVIs in Niceplayer or Quicktime give varying results but nearly always involves a long time for the files to load.)

 

About the Leo4All V3 video drivers, I have not tried reinstalling using the Leo4All V2 drivers which did not work the first time around. However, it may be I did not repair permissions at the correct moment. Try it first with the V2 drivers first if you want to avoid the hassle of downloading two versions of Leo4All, and if it does not work, use the drivers in V3.

 

Also, Leo4All V3 does not seem to work for this laptop as the computer hangs at startup after instalation, which is why I went back to Leo4All V2.

 

 

Lastly, thank you to all you osX86 developers, and to Eddie11c especially. Great job guys, keep it up.

 

In "about this mac", it says that Quartz Extreme is not supported. Is there a solution to this?

Share this post


Link to post
Share on other sites

I installed Leo4All v.3 in my c90s

installed intel chipset 3d party drivers

 

CI / QE Working and 512 VRAM

installed nvida kext and nvject 0.1.3 512

 

Battery Display, not full tested but displayed (Sais 8h left)

My brother has an MacBook and batery displays shows 4h. I guess it's without usage at all...

Camera, sound jacs, fingerprint, cardreader not working

Share this post


Link to post
Share on other sites

Thanks, a little kext tweaking and I got 10.5.8 running.

 

Issues:

Audio - speakers only, no headphones.

Wireless - unencrypted 802.11g only.

Built-in Webcam

Fingerprint Reader

 

Good:

Everything else.

Only sees half the ram of the gpu - but I have all the graphics acceleration enabled and working flawlessly.

 

Word of Caution - ALWAYS backup your kexts prior to updating via Apple. Thankfully I did.

Share this post


Link to post
Share on other sites

I stopped using my hackintosh for a while because I need to work with several windows-only 3D CAD packages.

 

Anyway, I've been back for 2 weeks now and I found out that the new VoodooHDA audio kexts improves ALOT the audio support on my system: audiojack out allows me to plug my external speakers, internal speakers are usable, and even the mic gets some audio in. The internal speakers seem to be as loud as in windows, but the mic capture is low and with lotsa background noise. But overall I;m glad I can finally leave my USB audio soundcard.

 

Also, the latest install I've got is an iPC 10.5.6 and it was giving me Kernel Panics everynow and then (using Voodoo Kernel 9.5). I'm not sure what was causing those KP but last week I installed VoodooPower (for Speedstep support) and not only I get a lot lower CPU temp (average 55C Vs previous 67C) I haven't had a KP since then.

 

Hope this helps others C90S users out there

Share this post


Link to post
Share on other sites

... just got a USB2expresscard adapter and I'm charging and syncing the iPod with my extra USB 2.0 port.

 

So support for expresscard: OK

Share this post


Link to post
Share on other sites

I got an Asus C90S from a friend for installing Snow Leopard on it. After some trial and error I finally did it. Here's a little guide:

 

  1. Download this C90S package. It contains BootCD.iso, Chameleon RC4, Kext Helper, the needed Extensions and a com.apple.Boot.plist file. Apart from that you'll need a Retail Snow Leopard DVD.
  2. Burn C90S BootCD made with Traumas BootCDMaker 1.6. I used the kexts of abdersfisch3r post for it. Big thanks to him and Trauma!
  3. Boot from the BootCD, insert Retail Snow Leopard DVD and install it.
  4. Because SL doesn't boot on its own yet, we use the BootCD as a bootloader. Simply choose the fresh SL install to boot from.
  5. Install Chameleon ( I did it manually with Terminal)
  6. Replace the original /Library/Preferences/SystemConfiguration/com.apple.Boot.plist with the one from the package.
  7. Add the kexts with Kext Helper.

I got everything working apart from the Built-in Webcam and the Fingerprint Reader. Good Luck ;)

Share this post


Link to post
Share on other sites

Just found this thread.

 

I'm glad to hear you could use what i've found out.

 

I just managed to dual boot (Windows 7 and SL 10.6.3), the only thing that's not working 100% now is shutdown.

 

I think the only way to achieve a fast, reliable shutdown is with DSDT patching. Does anyone here know how to do this, or know anyone who can, because i have no idea how to do it.

Share this post


Link to post
Share on other sites

BIG UPDATE:

 

I decided i wanted to share a complete guide how to get a 99% working system dual booted (Windows 7), running like a real Macbook Pro.

 

 

 

 

 

First create a USB install stick (can be done with a external harddrive too):

 

a. Find ( from the web) or make a .dmg of your Snow Leopard install disk.

 

b. Partition your USB in 2 partitions using Disk Utility. Both Mac OSX Journaled in a GUID scheme. BOOTLOADER shuold be at least 200 MB.

 

c. Name the first one BOOTLOADER and restore the Snow Leopard dmg to the second one.

 

d. Install chameleon RC what-ever-is-current to the BOOTLOADER partition. Then when it's done, copy everything from my extra folder (at bottom of post) to the BOOTLOADER partition. Let it overwrite everything.

 

e. Create a Windows 7 USB install stick (needs to be min. 4 gb) (google for how-to)

 

f. Boot your SL install USB up (hold esc at boot). Click extra tools at the top (Hjælpemidler in danish, dunno what it is in english) and open Disk Utility. Partition your harddrive in 2 partitions, one Mac OSX Journaled and one FAT32. IT HAS TO BE IN GUID PARTITION SCHEME!

 

g. Install SL to the Mac Journaled partition. It's gonna say it's failed, but don't worry. Shut down and plug your WIN 7 USB in.

 

h. Boot your WIN 7 USB. Choose custom install, and format the FAT32 partition. If it says it can't install to it, reboot, and try again (that fixed it for me). After it's done reboot again, and boot you Snow Leopard USB. In Chameleon choose your Mac partition.

 

i. Set up your Mac. Afterwards, download this package: Mediafire link run it, and just click "next, next, next". Afterwards, install UpdateEFI app. Open UpdateEFI after it's done installing (it's in Applications > Extra Tools or something like that("Hjælpemidler" in danish - again, don't know it's english name).

 

j. Choose Basic Changes, type your password, and copy my Extra folder (attached at bottom of post) to the Finder window that opens. Overwrite.

 

K. Click "Unmount partition and finish" in UpdateEFI. Leave it until the UpdateEFI icon dissapears from the dock.

 

L. Now boot into the Windows 7 USB again. Select language and click "Repair my computer". Select Windows 7 and then choose Command prompt.

Write this: (Partition Y is your windows partition, disk X is your harddrive (don't choose your USB)

diskpart
list disk
select Disk X
list partition
select Partition Y
active
exit
exit

 

Then you should be at the recovery menu again. Choose the first option. When it's done, click shut down.

 

m. Boot into Mac again and download this folder: ChamInstaller and unzip it.

 

n. Now open Terminal.

Write:

sudo -s
(Type your password) 
cd ~/Downloads/ChamInstaller
./EFI_Active.sh

 

 

 

When it's says it's done, you're DONE!

 

You can now boot your mac or windows partitions as you want when you boot up.

 

 

 

 

EXTRA FOLDER: http://www.mediafire.com/?wgdyfvhnwgo

 

 

 

 

THE ONLY THING MISSING NOW is a reliable shutdown. Sometimes the shutdown works, sometimes not.

 

THIS CAN BE FIXED with DSDT patching. If you know a geek who can fix this, LET US KNOW. -_- Then we will have a 100% working Hackbook Pro.

 

 

 

 

 

If something isn't working right, or there's errors in the guide, let me know.

Share this post


Link to post
Share on other sites
Sounds really great.

 

Is the webcam working?

 

Nope, no webcam. The sound is also a bit weird, we need a more customized voodoohda. Right now you have ~20 diffrent options in the sound pref. panel.. But it's working.

 

Any progress on DSDT?

Share this post


Link to post
Share on other sites

Hello all,

after 2 or 3 different installations without success,

i've seen this thread, tried once and voila :cold:

It's not at 100% it is very good for me.

Thank you.

Share this post


Link to post
Share on other sites

Hi any news on the c90s front ? After running a 10.5.7 iatkos for about a year just to have logic and traktor (no wifi , bluetooth , webcam , pci express) looks like something messed my sound system , i plan to move on to leopard installation , is there any updated ways of installing it , and is there a way to activate the pci express card support dropped in leo , (so i could use my rme soundcard via a pcmcia (duel) adapter). Thanx

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×