Jump to content

Dual boot Vista with iATKOS already installed


5 posts in this topic

Recommended Posts

I have iATKOS up and running perfectly on a 250 gig hard drive split into two partitions. The first 95 gigs have iATKOS on it right now. I'd like to install Vista to the other partition and have the ability to dual boot so I can use Vista for gaming. How should I proceed without having to lose my up and running iATKOS install. Most of the guides I see are for installing OSX86 after you already have Vista installed. I need to do the opposite.

Link to comment
Share on other sites



Well I did it, and included it in my guide.


what are your specs? have you installed pc_efi? Did you format GUID or MBR?


here is the section, if you have installed pc_efi...


obtain a copy of 64-bit Windows Vista (I tested) or 64-bit XP (others say it works), or 32-bit Vista ultimate (and possibly other 32 bit versions...)


- you have a free partition to install windows (or linux) on. it doesn't matter what formatting it has


reboot into the windows install disk. go through the installation process, and when you choose which drive, pick the partition you created. It will say that you can't install to it (wrong formatting), but you can erase and format that partition (not the whole drive), so do it. Then install onto that drive.


once you are done, you should have a working windows install. however, you can't boot OS X because it doesn't give you a chance. Windows changes something in the boot sector (don't worry). so:


reboot into you Mac OS X install dvd, open disk utility, unmount all partitions on that drive (with OS X and Windows). write down the disk identifier (disk1 or disk0 (or any other number) ). Make sure you check this, as it can change from boot to boot.


start terminal


plug in your thumbdrive, which should still have your "EFI Pack" on it. (if you don't have efi pack, just download pc_efi_v80. its the same thing)


cd /Volumes/thumbdrivename <press enter>


cd EFI\ Pack/pc_efi_v80/guid <press enter>


-this next one is the important one


dd if=./boot0 of=/dev/diskX bs=400 count=1 <press enter> -the X is your number (1 for me)


-make sure you got no errors. "Resource Busy" means that you need to unmount ALL partitions from that hard drive. if you still get it, reboot and try again


reboot <press enter> (if it freezes, pull the plug)


as it starts up, hit "Delete" to go into the bios menu, go to "Integrated Peripherals", and enable "Onboard LAN Boot ROM". this will allow your ethernet to work in OS X after using windows. there is a reason why, but it doesn't matter. ask if you want to know...


now boot into OS X!


to boot into windows, mash F8 as OS X is starting up (Right after "Verifying DMI Pool Data.....") and scroll to "Foreign Boot". this is windows.


everything should now work! however, you want more time to choose your os (mashing keys is hard and annoying). so:


open terminal (in the OS):


cd /Library/Preferences/SystemConfiguration <press enter>

sudo -s <press enter>

<enter password> <press enter>

nano com.apple.Boot.plist <press enter> (I think I got that name and path right. check in finder to make sure it exists, and that the capitalization is right.)




- at the end, before:



then hit <control-X>, and save.


-this gives you 8 seconds to open the boot menu when mac os x begins to start up, so you have time to choose to boot windows or mac. mac is default.

Link to comment
Share on other sites

  • 2 months later...
I installed using the iATKOS DVD. MBR. I did install the EFI option in iATKOS. Where can I find the PC_EFI 8.0? I have googled but not much luck.


I just did this - here is how I got it to work:


With OsX installed (iATKOS installed with Vanilla + EFI) - MBR type install...


Gparted CD - use the disk utility to take the second partition, format to NTFS, and flag that partition as "boot" - unflag your OsX partition as boot.




Put in VIsta disk - install fresh copy to the new partition.


Vista now boots naturally.


EasyBCD - add another boot entry - MacOs - x86 pc


Reboot - and pat yourself on the back. No chain0 - nothing - just worked (for me).


I don't check this forum daily - so if you have questions - let me know: Daniel @at@ dcweidman ... com



Link to comment
Share on other sites


  • Create New...