Jump to content
~Eureka

CardBus/PCMCIA PC Cards for Leopard

1,073 posts in this topic

Recommended Posts

I installed iAtkos v5i (10.5.5.) on my laptop w/ success but of course the pcmcia slot doesn't work out of the box!

 

I had installed IOPCCardFamily & IOPCIFamily kext's as supplied by the 1st post here and rebooted my computer. By booting directly into 10.5.5. I get the kernel panic. By booting under "-f, -v, -s", it freezes when loading the IOPCCard and I get the "Still waiting for root device" error. I do notice that though my wireless PCMCIA card does light up, as it didn't before.

 

Anyone know if I'm missing a step or if the kext's supplied in this thread even work w/ 10.5.5.?

 

Any help would be highly appreciated - as I feel like I'm getting close to having 10.5.5 Leo working just fine!

Share this post


Link to post
Share on other sites
Advertisement

Hi,

 

i have a samsung q70 with leopard 10.5.8 (ideneb) and works fine almost all, except the wireless card.

 

So i have bought a TL-WN811N that should to work, using an atheros chipset...

 

I've tried with many kext, but the led on the card doesn't turn on and the system cannot recognize it.

 

I don't know if the problem is the drivers of the wireless card or the slot PCMCIA, i guess the last but i'm not sure about it.

 

 

In what way can I verify if the slot PCMCIA works?

 

 

ps: sorry for my awful english

Share this post


Link to post
Share on other sites

Hello Eveyone!

 

I am having a tad bit of a problem.. Since my Ethernet isnt working anymore (Intel pro/100) it just cut out.. and my intel 3945abg doesnt work right now.. I have this cardbus..

 

My iAtkos Leopard 10.5.8 Does indeed detect my cardbus. But when i click on it the options are "Unknown Vendor Network controller and Power off card" But my leopard does indeed detect the card.

 

I have this Xterasys XN-2411B (ADMtek ADM8211)

 

on Mac this is the vendor id and device id:

 

pci1317,8201:

 

Function: Network Controller

Vendor: Unknown

Type: CardBus

Vendor ID: 4887

Device ID: 33281

 

Here is the hardware ids under windows 7

 

21aeexs.png

 

Please help!!

 

What should i download :\ i am very new to mac.. and kexts.. and all xD

 

Thank you thank you<3

Share this post


Link to post
Share on other sites

[报价名称=震南'日期= 2008年1月12日,日下午11:44'后= '576839]

喜等同,

 

尝试这样做是否有任何的变化:

 

1。打开IOPCCardBridge.cpp

2。搜索下列字符串 备注 它:

如果(!设置)设置= OSDynamicCast(OSDictionary,配置,“getObject(”试验机“));

3。打开信息,IOPCCardFamily.plist

4。在配置设置,使用相同的格式,并添加您的计算机名,I / O端口范围,和内存范围。

5。编译并加载它。

 

1。打开IOPCCardBridge.cpp

2。搜索下列字符串 取代 “试验机”与“ADP2,1”:

如果(!设置)设置= OSDynamicCast(OSDictionary,配置,“getObject(”试验机“));

3。编译并加载它。

 

让我知道结果。

 

春南

[/报价]

 

 

朋友我需要IOPCCardFamily - chunnan-leopard-rev8.zip and CardBus/PCMCIA PC Cards for Leopard, (2/7/2008) rev8 Updated~ downlode thankyou !! My EMAIL yinxiaodo@hotmail.com

Share this post


Link to post
Share on other sites

Help needed here Chun-Nan

 

Would there be any help for Snow on this?

PCMCIA AKE BC168

570.JPG

AKE Inside hide PCMCIA to Two USB 2.0 Ports

 

* Supports High Speed 480Mbps.

* Full Speed 12Mbps and low speed 1.5Mbps Data Transfer

* It can connect all kind of USB2.0/USB1.1/USB1.0 devices, removal hard disk. CF/SM/MMC/Memory Sticker, Scanner, Printer, Digital Camera, Camcorder, CD-R/RW, DVD-RW etc.

* Supports "plug and play" function. * It can be used for the laptop with 32-bit Cardbus and PCMCIA interface.

* Fully compliant with FCC and CE standards.

 

Features:

 

* Add 2 USB 2.0 ports to your windows-based notebook.

* Truly Plug and Play.

* You can Share with other Devices and Old Notebooks

* Supported Windows 98SE/ME/2000/XP/VISTA

I am certain 100% it works on an actual G3 PowerBook "Pismo" running OS 10.4 "Tiger", I haven't read anywhere if anybody with a newer mac has tested it.. but if it worked on that powerbook... it could probably work now

I contacted that very person who has it working to provide me print screens of his About this Mac.. more info... to see if you could try to help with it(he wasn't sure which one was it but he send allot screenies):

http://img411.imageshack.us/i/picture8qi.jpg/

http://img684.imageshack.us/i/picture7y.jpg/

http://img641.imageshack.us/i/picture6zt.jpg/

http://img62.imageshack.us/i/picture5mz.jpg/

http://img175.imageshack.us/i/picture4i.jpg/

http://img101.imageshack.us/i/picture3d.jpg/

http://img696.imageshack.us/i/picture2ld.jpg/

http://img534.imageshack.us/i/picture1zu.jpg/

 

Anyways I have yet not tried any kexts for PCI... trying to do this on my Acer 3680, which all usb ports died... the only way i have usb through Linux & Windows 7 is using a PCMCIA AKE BC168 <- it has 2 USB ports

 

That I know of Leopard 10.5.7 (I did not choose any PCI kexts) it already gives me Kernel Panics instantly from booting with it connected... I have to disconnect it for me to able to boot and use Leopard.. if I try connecting it... it freezes & creates a kernel panic as well... so simply I could not use it under Leopard 10.5.7

 

Now recently on Snow in which I'm currently on 10.6.2 I can actually have it connected but it isn't recognized at all.... So I think its best I get to try to have it working under Snow since I am not getting any kernel panics with it connected.

 

So I went into Linux through Ubuntu 9.10 Live CD, and got this through Terminal with: lspci

ubuntu@ubuntu:~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8038 PCI-E Fast Ethernet Controller (rev 14)
0a:03.0 Ethernet controller: Atheros Communications Inc. AR2413 802.11bg NIC (rev 01)
0a:09.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
0a:09.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)
0b:00.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 62)
0b:00.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 62)
0b:00.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 65)

 

I actually have no clue which one is it exactly... I'm guessing it is the last ones with VIA Technologies... not really sure yet, but any help would be greatly appreciated.

Share this post


Link to post
Share on other sites

I used a PCIFamily.kext from this post (maybe beta 2?) back when I used Leopard. It made my Marvell Ethernet work too. Can I do this in Snow Leopard?

Share this post


Link to post
Share on other sites

I have been trying to install this off of the same cd over and over again for 2 weeks. My computer took 10 min to start up . And because of your driver it works. I care about you. Thank you so much. I hope you are well.

 

My computer is an IBM T30 and it is old Iknow. But it has 10.5.5 and it starts up in about 25 seconds thanks to Mr Chun. He is a special man who creates special drivers for special people. Many have fixed drivers. I've downloaded them all. But nothing likek Mr Chun's drivers. No homo.

Hello,

 

Here is the IOPCCardFamily file that I have worked on today. I complied the source files offered from Apple and also fixed some bugs. You do not have to edit the info.plist to match your machine. If your pccard shows "IOPCCardBridge::start failed", you can give it a try.

 

How to use?

  • Backup your original IOPCCardFamily driver (and IOPCIFamily driver)
  • Replace your IOPCCardFamily driver (and IOPCIFamily driver) with the attached one that contains all necessary modifications
  • Reboot
  • As root, type "dmesg | grep PC"; you should see something being found

Welcome to try it. Don't forget to backup the old files before trying it.

 

[iMPORTANT]

If you get the kernel panic, PLEASE check if you have replaced the following files to make your cardbus slot working before:

 

AppleACPIPlatform

AppleAPIC

IOACPIFamily

 

If you did, you probably need to find a way to restore those files first.

If you still get kernel panic, you can take the picture of it if possible. Thanks.

 

[KNOWN ISSUES]

It may cause kernel panic with AGPGart installed.....

If you have the error message "IOPCCardBridge::checkBridgeBusIDs invalid sub/cardbus/pci settings of 0x0" before trying the rev3 file, it still may not work after trying the rev3 file.

Chun-Nan

 

Kext File: IOPCCardFamily_chunnan_rev3.zip

Source Code: IOPCCardFamily_48_chunnan.zip

 

[uPDATE]

1/17/2008: rev6 and source code update

Please replace IOPCCardFamily and IOPCIFamily at the same time.

You DO NOT have to edit info.plist because it will use "ADP2,1" by default.

If you are using other revisions, please update to rev6.

If possible, let me know the result. Thanks.

 

IOPCCardFamily_chunnan_Leopard_rev6.zip

IOPCCardFamily_chunnan_Leopard_rev6_src.zip

 

1/30/2008: rev7 and source code update

Please replace IOPCCardFamily and IOPCIFamily at the same time.

You DO NOT have to edit info.plist because it will use "ADP2,1" by default.

If you are using other revisions, please update to rev7.

If possible, let me know the result. Thanks.

 

IOPCCardFamily_chunnan_Leopard_rev7.zip

IOPCCardFamily_chunnan_Leopard_rev7_src.zip

 

2/7/2008: rev8 and source code update

Please replace IOPCCardFamily and IOPCIFamily at the same time.

You DO NOT have to edit info.plist because it will use "ADP2,1" by default.

If you are using other revisions, please update to rev8.

If possible, let me know the result. Thanks.

 

IOPCCardFamily_chunnan_Leopard_rev8.zip

IOPCCardFamily_chunnan_Leopard_rev8_src.zip

 

5/25/2008: beta3 installation package update

Please choose IOPCCardFamily and IOPCIFamily at the same time.

If possible, let me know the result. Thanks.

PCCard.10.5.2.beta3.zip

 

11/30/2008: beta IOPCMCIAFamily update

http://www.mediafire.com/chunnan

 

 

==========

{ "Cirrus PD6729", IS_CIRRUS|IS_PCI, ID(CIRRUS, 6729) }

{ "Cirrus PD6730", IS_CIRRUS|IS_PCI, PCI_VENDOR_ID_CIRRUS, -1 }

{ "Cirrus PD6832", IS_CIRRUS|IS_CARDBUS, ID(CIRRUS, 6832) }

{ "ENE 1211", IS_TI|IS_CARDBUS, ID(ENE, 1211) } <= new added

{ "ENE 1225", IS_TI|IS_CARDBUS, ID(ENE, 1225) } <= new added

{ "ENE 1410", IS_TI|IS_CARDBUS, ID(ENE, 1410) } <= new added

{ "ENE 710/2/4", IS_TI|IS_CARDBUS, ID(ENE, 1411) } <= new added

{ "ENE 712/4", IS_TI|IS_CARDBUS, ID(ENE, 1412) } <= new added

{ "ENE 1420", IS_TI|IS_CARDBUS, ID(ENE, 1420) } <= new added

{ "ENE 720/2/4", IS_TI|IS_CARDBUS, ID(ENE, 1421) } <= new added

{ "ENE 722/4", IS_TI|IS_CARDBUS, ID(ENE, 1422) } <= new added

{ "O2Micro OZ6729", IS_O2MICRO|IS_PCI|IS_VG_PWR, ID(O2, 6729) }

{ "O2Micro OZ6730", IS_O2MICRO|IS_PCI|IS_VG_PWR, ID(O2, 6730) }

{ "O2Micro OZ6832/33", IS_O2MICRO|IS_CARDBUS, ID(O2, 6832) }

{ "O2Micro OZ6836/60", IS_O2MICRO|IS_CARDBUS, ID(O2, 6836) }

{ "O2Micro OZ6812", IS_O2MICRO|IS_CARDBUS, ID(O2, 6812) }

{ "O2Micro OZ6922", IS_O2MICRO|IS_CARDBUS, ID(O2, 6922) }

{ "O2Micro OZ6933/711E1", IS_O2MICRO|IS_CARDBUS, ID(O2, 6933) }

{ "O2Micro OZ6912/711E0", IS_O2MICRO|IS_CARDBUS, ID(O2, 6912) }

{ "O2Micro OZ711EC1/M1", IS_O2MICRO|IS_CARDBUS, ID(O2, 7112) }

{ "O2Micro OZ711EC1", IS_O2MICRO|IS_CARDBUS, ID(O2, 7113) }

{ "O2Micro OZ711M1/MC1", IS_O2MICRO|IS_CARDBUS, ID(O2, 7114) }

{ "O2Micro OZ711MP1/MS1", IS_O2MICRO|IS_CARDBUS, ID(O2, 7134) } <= new added

{ "O2Micro OZ711EZ1", IS_O2MICRO|IS_CARDBUS, ID(O2, 7135) } <= new added

{ "O2Micro OZ711SP1", IS_O2MICRO|IS_CARDBUS, ID(O2, 7136) } <= new added

{ "O2Micro OZ711E2", IS_O2MICRO|IS_CARDBUS, ID(O2, 71E2) }

{ "O2Micro OZ711M2", IS_O2MICRO|IS_CARDBUS, ID(O2, 7212) }

{ "O2Micro OZ711M3/MC3", IS_O2MICRO|IS_CARDBUS, ID(O2, 7223) }

{ "O2Micro OZ711MP3/MS3", IS_O2MICRO|IS_CARDBUS, ID(O2, 7233) } <= new added

{ "Ricoh RL5C465", IS_RICOH|IS_CARDBUS, ID(RICOH, RL5C465) }

{ "Ricoh RL5C466", IS_RICOH|IS_CARDBUS, ID(RICOH, RL5C466) }

{ "Ricoh RL5C475", IS_RICOH|IS_CARDBUS, ID(RICOH, RL5C475) }

{ "Ricoh RL5C476", IS_RICOH|IS_CARDBUS, ID(RICOH, RL5C476) }

{ "Ricoh RL5C477", IS_RICOH|IS_CARDBUS, ID(RICOH, RL5C477) } <= new added

{ "Ricoh RL5C478", IS_RICOH|IS_CARDBUS, ID(RICOH, RL5C478) }

{ "SMC 34C90", IS_CARDBUS, ID(SMC, 34C90) }

{ "TI 1130", IS_TI|IS_CARDBUS, ID(TI, 1130) }

{ "TI 1131", IS_TI|IS_CARDBUS, ID(TI, 1131) }

{ "TI 1031", IS_TI|IS_CARDBUS, ID(TI, 1031) }

{ "TI 1210", IS_TI|IS_CARDBUS, ID(TI, 1210) }

{ "TI 1211", IS_TI|IS_CARDBUS, ID(TI, 1211) }

{ "TI 1220", IS_TI|IS_CARDBUS, ID(TI, 1220) }

{ "TI 1221", IS_TI|IS_CARDBUS, ID(TI, 1221) }

{ "TI 1225", IS_TI|IS_CARDBUS, ID(TI, 1225) }

{ "TI 1250A", IS_TI|IS_CARDBUS, ID(TI, 1250A) }

{ "TI 1251A", IS_TI|IS_CARDBUS, ID(TI, 1251A) }

{ "TI 1251B", IS_TI|IS_CARDBUS, ID(TI, 1251B) }

{ "TI 1410", IS_TI|IS_CARDBUS, ID(TI, 1410) }

{ "TI 1420", IS_TI|IS_CARDBUS, ID(TI, 1420) }

{ "TI 1450", IS_TI|IS_CARDBUS, ID(TI, 1450) }

{ "TI 1451", IS_TI|IS_CARDBUS, ID(TI, 1451) }

{ "TI 1510", IS_TI|IS_CARDBUS, ID(TI, 1510) }

{ "TI 1520", IS_TI|IS_CARDBUS, ID(TI, 1520) }

{ "TI 1620", IS_TI|IS_CARDBUS, ID(TI, 1620) }

{ "TI 4410", IS_TI|IS_CARDBUS, ID(TI, 4410) }

{ "TI 4450", IS_TI|IS_CARDBUS, ID(TI, 4450) }

{ "TI 4451", IS_TI|IS_CARDBUS, ID(TI, 4451) }

{ "TI 4510", IS_TI|IS_CARDBUS, ID(TI, 4510) }

{ "TI 4520", IS_TI|IS_CARDBUS, ID(TI, 4520) }

{ "TI 7410", IS_TI|IS_CARDBUS, ID(TI, 7410) }

{ "TI 7510", IS_TI|IS_CARDBUS, ID(TI, 7510) }

{ "TI 7610", IS_TI|IS_CARDBUS, ID(TI, 7610) }

{ "TI 7420", IS_TI|IS_CARDBUS, ID(TI, 7510) } <= new added

{ "TI 7620", IS_TI|IS_CARDBUS, ID(TI, 7610) } <= new added

{ "TI XX12", IS_TI|IS_CARDBUS, ID(TI, XX12) }

{ "TI XX21", IS_TI|IS_CARDBUS, ID(TI, XX21) } <= new added

{ "TI 6515", IS_TI|IS_CARDBUS, ID(TI, 6515) } <= new added

{ "Toshiba ToPIC95-A", IS_CARDBUS|IS_TOPIC, ID(TOSHIBA, TOPIC95_A) }

{ "Toshiba ToPIC95-B", IS_CARDBUS|IS_TOPIC, ID(TOSHIBA, TOPIC95_;) }

{ "Toshiba ToPIC97", IS_CARDBUS|IS_TOPIC, ID(TOSHIBA, TOPIC97) }

{ "Toshiba ToPIC100", IS_CARDBUS|IS_TOPIC, ID(TOSHIBA, TOPIC100) }

==========

I don't know if the new added devices will work or not. However, you can give it a try and let me know the result. In addition, if your pccard slot works under linux and it is not listed on the above the list (and if you believe it may work under mac), let me know the device id and I will try to add it to the next revision.

Share this post


Link to post
Share on other sites

Hello, i got a Acer 6930G laptop. Installed retail 10.6.4 and everything works fine except cardbus pcmcia or whatever it's called. I have a firewire card and when i plug it system gives me kernel panic of IOPCIFamily.kext. Tried Chun-Nan's kext but when Chun-Nan's kext installed system hangs and won't boot without giving errors.

My soundcard is M-audio Firewire 410 that's why i need firewire on this computer. It works fine on Windows 7. Please i need help.

Share this post


Link to post
Share on other sites
No luck again. (

In 10.5.2 i applied Chun_Nan.PCMCIA.CardBus.Driver. After that the Airport disappeared from Network prefpane at all.

 

In 10.5.6 i tried several approaches based on what you said:

 

1 Removed 88E8055 section in info.plist and inserted devid + manufacturer id in 88E8053 section without changing anything else. - Doesn't work.

2 After step 1 i replaced all references to 88E8055 chip in corresponding section of info.plist with text 88E8055. Doesn't work.

3 Applied 88E8055 patch that you send me. Doesn't work. Moreover, it appears that info.plist within it just lacks 88E8055 section and the 88E8053 section is intact including product ids. I tweaked it as described above, but with no effect.

 

The message concerning MSI interrupt is still displaying during each reboot. And the another warning that might do something with the problem:

 

localhost kernel[0]: Extension "com.apple.driver.ApplePCIConfigurator" has immediate dependencies on both com.apple.kernel and com.apple.kpi components; use only one style.

 

Also, some interesting thing revealed: if upgrading from 10.5.2 to 10.5.6 the Airport won't turn on if the ethernet (which comes down after upgrade) is still present in Networking prefpane. Remove it - and the Airport will work just fine. May be this is the reason why Atheros isn't working under 10.5.2. - it somehow conflicts with Yukon.

 

 

I installed IDENEB v1.4 on my pc and after the installation it asked to restart, so i did, after that it wont boot, theres the apple wheel rolling and the "no smoking kinda sign". So i tried typing -v on boot cause other commands wont work. well anyways i got the message failed to load apple acpi pci something. please help me. im really desperate. it says couldnnt alloc class apple acpi pci 12Appleacpipci is not compatible with its superclass 11iopcibridge supercalss. (yellow fonts) please help me. i already tried typing v -cpus=1 -noacpi but still nothing. Same problem. It just always gives me the same message.

 

PROCESSOR: Intel DUAL CORE 1.6ghz

RAM: 2gB Kingston 800

GRAPHICS: Nvidia 9400GT

MOBO: ASUS P5kPL-AM EPU

HardDrive- S-ATA 80gb Western DIGITAL

 

ATA/IDE Config: Enhanced

Enhanced Mode Support On: S-ATA

 

Plug and Play O/S: Yes

 

 

Suspend Mode: S3 Only

ACPI 2.0 Support: Enabled

Restore on AC Power Loss: Power Off

 

please help me sirs.

Share this post


Link to post
Share on other sites
No luck again. (

In 10.5.2 i applied Chun_Nan.PCMCIA.CardBus.Driver. After that the Airport disappeared from Network prefpane at all.

 

In 10.5.6 i tried several approaches based on what you said:

 

1 Removed 88E8055 section in info.plist and inserted devid + manufacturer id in 88E8053 section without changing anything else. - Doesn't work.

2 After step 1 i replaced all references to 88E8055 chip in corresponding section of info.plist with text 88E8055. Doesn't work.

3 Applied 88E8055 patch that you send me. Doesn't work. Moreover, it appears that info.plist within it just lacks 88E8055 section and the 88E8053 section is intact including product ids. I tweaked it as described above, but with no effect.

 

The message concerning MSI interrupt is still displaying during each reboot. And the another warning that might do something with the problem:

 

localhost kernel[0]: Extension "com.apple.driver.ApplePCIConfigurator" has immediate dependencies on both com.apple.kernel and com.apple.kpi components; use only one style.

 

Also, some interesting thing revealed: if upgrading from 10.5.2 to 10.5.6 the Airport won't turn on if the ethernet (which comes down after upgrade) is still present in Networking prefpane. Remove it - and the Airport will work just fine. May be this is the reason why Atheros isn't working under 10.5.2. - it somehow conflicts with Yukon.

Hi man

 

I installed IDENEB v1.4 on my pc and after the installation it asked to restart, so i did, after that it wont boot, theres the apple wheel rolling and the "no smoking kinda sign". So i tried typing -v on boot cause other commands wont work. well anyways i got the message failed to load apple acpi pci something. please help me. im really desperate. it says couldnnt alloc class apple acpi pci 12Appleacpipci is not compatible with its superclass 11iopcibridge supercalss. (yellow fonts) please help me. i already tried typing v -cpus=1 -noacpi but still nothing. Same problem. It just always gives me the same message.

 

PROCESSOR: Intel DUAL CORE 1.6ghz

RAM: 2gB Kingston 800

GRAPHICS: Nvidia 9400GT

MOBO: ASUS P5kPL-AM EPU

HardDrive- S-ATA 80gb Western DIGITAL

 

can you help me guys? like which patch should i check and stuffs. please im desperate.

Share this post


Link to post
Share on other sites

I'm sorry if this is a dumb question but do I need to delete:AppleACPIPlatform AppleAPIC

and IOACPIFamily before I install the chun driver? Every one I have tried causes kernel panic.

:P

Share this post


Link to post
Share on other sites

I had to remove IOPCMCIAFamily.kext from my Lenovo T61 after I updated from 10.6.7 to 10.6.8 due to the following KP;

kxld[com.apple.driver.AppleACPIPlatform]: The super class vtable '__ZTV11IOPCIBridge' for vtable '__ZTV12AppleACPIPCI' is out of date. Make sure that your kext has been built against the correct headers.

...

Share this post


Link to post
Share on other sites

Anyone has working IOPCMCIAFamily.kext on Lion (10.7.0 - 10.7.2)?

so far, I tested all available download version, they gave me kernel panic.

I have thinkpad x61 with Lion 10.7.2 running pretty stable, need this kext desperately, so I can use my PCCard on Lion.

 

Really appreciated.

Share this post


Link to post
Share on other sites

Hi all, 

 

I use Ideneb 10.5.8 on a sony vaio vgn-TX3XP. I got a Viking Interworks High speeds compact flash cardbus adapter. I use the Pcmcia fix from Ideneb and now i can see i sitecom firewire pcmcia card with no problem. But the Vikings Interworks doesn't work out of the box. I need a driver but the last OS X they supported was 10.2 but i guess that aint that much difference from the 10.5.8 version. 

 

I'm looking for that 10.2 driver too cause i can't find it anywhere and think it may work with 10.5.8.

 

If anybody got a clue please let me know. Txs! 

 

Edit: i found the 10.4 driver at http://www.driverguide.com/driver/detail.php?driverid=561488&auth=At82snaUidNtrCvtF7wFYmllar0f3%2BrewfY6ssl80ATfC%2BklQ0XtjzIdHUBrIXvaCH5RTEkqOIuYsgAI9XY4q73EjZbmshLrcrAxjYGMZv9yCZHqaionJU0%2BfxJmH41%2B

 

But it doesn't work. I get extra icon in the top finder bar but all i can select is power off card. And it says Unkown Vendor and mass storage card. It could be that the pcmcia driver from ideneb does this because i didn't pay attention to it before. 

Share this post


Link to post
Share on other sites

I checked the card bus with Wavelan silver wifi card and it detects it. Now i need a CF card reader in PC card format that works under 10.5.8. 

 

Anybody know a cheap[ card that works? Thanks! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×