Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sonique

[HOW TO] Leopard on Asus M2N-SLI + NVIDIA or ATI

13 posts in this topic

Recommended Posts

Hi !

I'm new there, i will make a brief HowTo Install Leopard On Asus M2N-SLI + Nvidia 7300GS

 

Which "distrib" :

- Tiger : 10.4.8 : JaS 10.4.8 Intel + AMD

- Leopard : Zephyroth DVD (Mac OS X Leopard 10.5.1 for AMD SSE2/SSE3 (32bits))

 

You need a IDE Hard Drive (> 10Go)

You need a IDE DVD reader

 

1) Get & burn your DVD

2) Boot DVD

3) Formating HD with HFS+ (Mac OS X extended journalised)

4) Install the System

- note : with JaS check NVIDIA or ATI Drivers)

- note : with Zephyroth check NVIDIA Drivers for 8xxx)

5) Reboot

- note : with JaS boot with "-x -v"

 

6) Install Good graphic drivers :

- get your Card ID from NVinject

- with JaS download NVInject 0.2.1 and Install them using KextHelper

- with Zephyroth download NVInject 0.1.5 for Leo and Install them using KextHelper

- Modify [ GeForce.kext & NVinject.kext : <key>IOPCIMatch</key> => <string>YOUR_CARD_ID ******* KEEP OTHER IDS ******</string> ]

- Modify [ NVDANV50Hal.kext & NVDAResman.kext :<key> IOPCIPrimaryMatch</key> =><string>YOUR_CARD_ID ******* KEEP OTHER IDS ******</string>

- launch terminal log you as root (sudo su) and run : diskutils repairPermissions /

- reboot

[ OPTIONAL IF doesn't works :AND remove or move /System/Library/Extension/GeForce* AND reboot in normal mode and remark step 6]

 

7) Install Audio drivers :

- You need download AzaliaAudio.pkg

- Open it, and follow instructions

- launch terminal log you as root (sudo su) and run : diskutils repairPermissions /

- reboot with -f option

 

8) Buy RLT-8139 (6$) ! Nvidia Network adapter doesn't works (for the moment !)

 

9) Get NForce SATA Controller by MedEvil (MedEvil Driver NForce SATA)

 

- I have a H@ck1nt0sh absolutly nice.

- Burning DVD works well (Dual Layer too)

- Quartz Extreme, Core Image, Rotation are OK

- Sound works

 

 

Sonique - sonique6784

Share this post


Link to post
Share on other sites

Dear Friend!

 

I have ASUS M2N-SLI Deluxe Mobo, AMD Athlon X2 6000+CPU, 8600GT 512MB VGA.

After instalation JAS 10.4.8 I have rebooted and system has crashed.

I would like to follow Your instructions, I´m new in mac, please I do not

understand how to do this:

 

5) Reboot

- note : with JaS boot with "-x -v"

 

What to press after reboot? How to set this option?

 

ThanX

Share this post


Link to post
Share on other sites

I have installed JAS 10.3.8, after instalation rebooted with -x -v and system had crashed :-(

 

I just could see to screen telling Reboot Your computer now in BlackNWhite window

 

My machine:

Asus M2N-SLI Deluxe

4GB RAM

Asus 8600GT 512MB Graphics

AMD X2 6000+ CPU

LG IDE DVD-RW

20GB IDE Maxtor HDD

 

 

Do You have any suggestion what to do, please?

Share this post


Link to post
Share on other sites

M2N-E here; I used Zeph's DVD (rev1) and got it working after making the partition bootable, and using the 640x480 resolution to get past the "Do you already own a Mac" loop.

 

But... Not a single network card works. They are detected (I see messages like RTL8139 : Hardware Address 00:(etc.) or Intel:

 

Tried:

 

Onboard Nvidia (not detected)

Intel Pro/100V

Intel Pro/1000GT (not detected)

3COM 3C905C-TX-M

RTL8139D

RTL8169

 

(Yes... I have a lot of cards sitting everywhere... :P

 

So, some are detected but they do not show up in System Preferences - Network

 

There is one nic there but it always has "network cable unplugged". What am I doing wrong?

 

It is even there when I have all NICs removed, so it must be some kind of dummy.

Share this post


Link to post
Share on other sites

Dear Hagen!you need to do this, to skip "Do you already own a Mac" loop: Solution 1: Importing an account from an existing (Tiger) installation. Solution 2: Booting with the flag "Graphics Mode"="640x480x32". The resulting low screen-resolution prevents the setup screen, thus skipping the "loop". As one is not able to create a new username, only the default "admin" is created. This can be changed later on. Solution 3: Some people reported success with disabling the network card in the bios or disconnecting the cable. Solution 4: Boot using "-s" flag then type -> /sbin/mount -uw / passwd root <- Type any password you want touch /var/db/.AppleSetupDone rebootMy computer Asus M2N-SLI Deluxe with Nvidia 8600GT won´t boot after step 5 in this guide.-x -s cpus=1, none of this flags helped! It hangs with mDNSResponder, but I have found solution:deleting NVDA* and GeFo* kexts system boots, but hangs with screen:there is no keyboard connectedI tried to check if I have ApplePS2 kext in system/library/extensions, but it was ok.I disabled USB in BIOS, but nothing helped. I need to buy USB keyboard.

Share this post


Link to post
Share on other sites

Hi, i have a m2n-e sli with an ati radeon hd 2600 xt. installing leopard 10.5.1 for AMD is ok. Just remove gef* and nv* kext rebooting in -x mode. No onboard lan.

The problems are kext for 2600xt. In about 3 months i have tried everything, every guide... but nothing. Do you think is a mobo problem? thanks to who solve my problem!

Share this post


Link to post
Share on other sites

Finally I GOT IT !!!

 

My ASUS M2N-SLI Deluxe with AMD X2 6000+, Asus Nvidia 8600GT Silent 512MB, 4GB RAM is working perfectly!

 

 

here are the instructions:

 

-You need IDE HDD and IDE DVD (i tried to install system to new SATA II Samsung HDD, but DISK UTILITY crashed while trying to partition!)

 

 

-You need USB KeyBoard and USB Mouse, I WAS not able to install system with PS2!

(copying ApplePS2 kexts HAVE NOT HELPED!!!)

 

1. boot from DVD, make partition HFS+ journaled, named for example MacHDD

 

2. install system, check Nvidia support

 

3. reboot, Eject DVD, start with pressing F8 from HardDisk, enter boot options:

-x -s (single user mode)

 

4. enter suggested commands (displayed after reboot) to be able to edit filesystem (fsck..., mount -uw ...)

 

5. cd /Volumes/MacHDD/System/Library/Extensions (MacHDD is name of YOUR partition)

 

6. rm -r GeFo*

rm -r NVDA*

 

7. reboot, boot normally from HDD, system should boot to default graphics

(system will ask something about Your USB Keyboard to recognize it)

 

8. install Nvidia support by Punk92, download from this link:

 

http://www.mediafire.com/?e1ncyveedim

 

 

 

9. Open System profiler from Applications folder, and find Your Graphics card ID, for example mine was:

Device ID: 0x0402

(Nvidia as vendor is always 0x10de)

 

10. open Terminal and follow:

 

cd /Volumes/MacHDD/System/Library/Extensions/

 

cd GeForce.kext/Contents/

 

sudo nano Info.plist

 

find the line with: <key>IOPCIMatch</key>

and edit line below, insert this code there:

 

<string>0x040210de ******* KEEP OTHER IDS ******</string>

 

save and quit

 

 

the same do with NVinject.kext

 

 

than with:

 

NVDANV50Hal.kext

 

and

 

NVDAResman.kext

 

where You must find

<key> IOPCIPrimaryMatch</key>

 

<string>0x040210de ******* KEEP OTHER IDS ******</string>

 

save and exit

 

 

reboot machine and it should work now ! Set resolution you need!

 

10. Install Apple azalia audio package, sound works!

Share this post


Link to post
Share on other sites

onboard lan works with a driver and a trick that you can find in my signature... but anyway i preferred to buy a cheap pci card.

Share this post


Link to post
Share on other sites

i got the m2n-sli as well and am using a RTL network card as well.

i gave up getting the onbord chip to work, it was to much a hassle :D

 

where to buy a nic (network interface card)? well, at your computer dealer

i think ;) depends where you are from..

 

btw: i got a gforce 8600gt running fine but got problems now with new

ati hd 3870 :)(

Share this post


Link to post
Share on other sites

I did not read the whole thread. I just want to post some kexts, which run my M2N-SLI Mobo with 10.5.8. Even Onboard- LAN is working now. If you incidently use the Ati Radeon HD 3650 512MB, search for "ATI x2000 source version 53410 plus natit for HD3650.pkg", it´s too big to upload. Kexte_fÃ_r_M2N_SLI__10.5.8.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • i think the "red light" you are referring to is that you have a optical SPDIF output (3.5 mm) combo jack. it most likely will be "red" when audio is active. 
    • Domanda , ma il tuo configplist lo ha settato cosi Gengik????
      Noto molte cose atipiche , tipo aperto con Clover configurator nella sezione ACPI il nome DSDT.aml NON è selezionato , quindi in teoria NON dovrebbe caricare il DSDT che hai in Clover ACPI Patch , se usi SSDT x la CPU NON dovrebbero servirti quelle personalizzazioni sempre in configplist sezione CPU ...
      Secondo me dovresti partire da un configplist pulito , xche sempre secondo me c'è rimasto delle schifezze di qualche tool x installare facile    EDIT
      Scaricando il configplist di jolly NOTO ha impostato +o- come intendevo fare io , sistemando quello  sopra elencato e bammmmm NON avvia , mi forniresti x favore Hack info che trovi nella mia firma ???
      Grazie
    •   Can you share the Clover folder that lets you boot?
    • yes it is. i can boot using a backup from a backup of my clover. i am just trying to fix the VGA /HDMI so i tried using the clover i got from Allan
    •     I mean't to fix that. The new attached EFI only contains new USB patch that will unlikely fix anything unless your hackintosh is installed on a USB drive. If it is installed on your hard drive, as I said, try playing with the patches I attached in the screenshot (i.e. disabling some of them).   Your SATA Mode is AHCI in the BIOS right?


×