Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 

AMD Gigabyte GA-M61P-S3 Install Guide

5 posts in this topic

Recommended Posts

For anyone else who has this motherboard, here are my notes for getting OSx86 working on it.


Motherboard: Gigabyte GA-M61P-S3 (nForce 430, GeForce 6100 video)

CPU: I'm using an Athlon64 x2 5600+ (2.8 GHz)


I installed from the Tubgirl 10.4.10 DVD. Everything works after the install except SATA, Ethernet, and the onboard video (limited to 1024x768, no QE/CI). Also, Shut Down and Restart halt the CPU, but don't power off or reboot. I have to use the power or reset switch to finish those jobs.


For video, I'm using a GeForce 7100GS or 7300GT with the NV40 add-on selected in the Tubgirl install.


I tried several supposedly supported PCI Ethernet cards, but either they weren't recognized at all (3com 3c905c, Netgear FA310/311/312) or the machine hung after using them for a few seconds (Intel PRO/1000 MT). There is an nForce Ethernet driver here, which currently almost works after adding the device ID 0x03EF10DE to its Info.plist:

nForce Ethernet kext

The forcedeth kext for Ethernet (doesn't work for nForce 430) comes with Tubgirl 10.4.10; I removed it.

I finally got a RealTek 8169 based gigabit Ethernet PCI card (LINKSKEY LKG-6100); Tubgirl 10.4.10 includes the open source R1000 driver for it, and it works fine.

I also successfully used a USB Netgear FA120 or Linksys USB200M with the USBAx8817x 1.0.3b9 driver from here: USB Ethernet kext


For SATA, I installed an nForce 430 MCP51 (and other nForce) driver which is available at:

nForce SATA kext

Because the Tubgirl 10.4.10 DVD doesn't include SATA support for the nForce 430, I installed to an ATA hard drive by booting from a USB DVD drive. Later I cloned the ATA drive to a SATA drive using Clonetool Hatchery.


To install, I had to format the hard drive using the Disk Utility from the JaS 10.4.8 DVD. The Tubgirl 10.4.10 installer's Disk Utility doesn't arrange for the boot loader to be installed correctly. The magic of formatting in FAT32 (MS-DOS) first leaves some space for the MBR Darwin boot loader.


1. Boot from the JaS 10.4.8 DVD.

2. Run Utilities>Disk Utility.

3. On the left, select the drive to install on. Click the Partition tab. Select 1 Partition (or however many you want). Select MS-DOS file system. Click Options and select MBR. Format the drive.

4. On the left, select the partition (not the drive). Click the Erase tab. Select HFS+ (Journaled) file system. Erase the partition.

5. Select the drive and click the Eject button at the top of the window.

6. Turn off the computer and reboot from the Tubgirl 10.4.10 DVD.


To make a bootable clone of an OSx86 hard drive, you can't use SuperDuper or Carbon Copy Cloner, because they don't know about its special boot requirements. You have to use Clonetool Hatchery. I used the package on the XXX 10.4.11 DVD, which comes with a script that modifies some frameworks on Tiger to make it work. Reportedly it doesn't work on Leopard yet.


It is possible to boot OSx86 from a USB hard drive, but when other high-speed USB devices are plugged in (such as the Ethernet I used at first), the system tends to hang, so I don't recommend it.


By default, Tubgirl 10.4.10 boots in text mode until it switches to the desktop, to aid debugging. To instead get the usual gray Apple logo screen during boot, after installation use Text Edit to edit /Library/Preferences/SystemConfiguration/com.apple.Boot.plist

and remove the -v (for Verbose mode) from the Kernel Flags string value.


To install a kernel extension after the OS install, e.g. AppleNForceATA.kext:

Copy the kext to /System/Library/Extensions.

Open a terminal window, "sudo bash", and run:


cd /System/Library/Extensions

chown -R root:wheel AppleNForceATA.kext

chmod -R 755 AppleNForceATA.kext

kextload -v AppleNForceATA.kext

kextcache -k /System/Library/Extensions


iDVD from iLife '08 doesn't work on AMD. It gets most of the way through preparing a project for burning, then aborts with a multiplexer error. So I'm using iLife '06.

Share this post

Link to post
Share on other sites

Here are my notes on installing Leopard on the Gigabyte GA-M61P-S3.

It performs better and more stably than Tiger.


Install from iPC 10.5.6 PPF5 Final ISO. Select:


10.5.5/9.5 Voodoo kernel

ALC883 audio

AppleSMBIOS-28 or AppleSMBIOS-27rev3-800 (doesn't matter)

Default Chameleon bootloader (PC_EFI v9)



Driver for your PCI Express video card

seatbelt 10.5.5


Works with both GUID and MBR disk partitioning systems.

Boot with -f first time. Repair permissions with Disk Utility.

Set sound output to first Line Out instead of Headphones in System Preferences.

Restart and shutdown work.


Not working: Sleep (didn't try the power management packages or speedstep kernel)

Untested: Builtin video, Time Machine

Share this post

Link to post
Share on other sites

I have the same motherboard, and have followed this guide faithfully but have run into a big roadblock.


For some reason, after I finish installing and reboot the appleNforceATA driver complains that it 'found 0 units'. It found the mcp61 chipset just fine during install.


I have tried:

removing RAM to bring it to 4gb (was 6gb)

Installing to SATA and IDE

installing from usb-dvd and ide-dvd


No ata chipsets

enabling RAID in bios (I couldn't find AHCI in the F7F bios)

repairing permissions via the applejack script


I don't know what else to try. Any ideas?

Share this post

Link to post
Share on other sites

Not sure what went wrong with my iPC disk, I never got any errors... I tried an XxX 10.5.6 disk with exactly the same settings and it worked the first time!




trying to install Snow Leopard Server to this box, I wiped out my successful Leopard install... After failing to reinstall I did a bit of googling and found that I should enable AHCI. Nothing labeled as such in this mobo's BIOS so I emailed gigabyte. Apparently just enable RAID on the SATA chipset and disable it for each specific drive. Et voila!

Share this post

Link to post
Share on other sites

Has anyone had success with 10.5.7? I have been trying for months. The only way I can boot it is with a rd=disk command.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • Yup that's fine! Oddly, when rebooting several times it is suddenly gone! Only thing I need to fix is getting 'Headphone' output to work, after sleep. Internal Speakers are working after sleep. I assume to fix this in CodecCommander.kext/ EAPDFix.kext? Anyway thanks for your help!   Yup I have a combo output, so there was something wrong I guess.
    • Nice @yapan4 then we can join forces to make this as good as possible.
    • I had a weird situation, after running great for a while: yesterday I did a reboot and got a KP. Turns out the AstekFusion2Adapter kexts were causing the KP, strange thing is I didn't recall applying any update or a like.  I had to boot with the USB installer, mount the EFI partition to delete the old AstekFusion2Adapter kexts and replaced with the patched version contributed by despeinao. I'm glad the system is working again, not having to reinstall OSX.
    • i think the "red light" you are referring to is that you have a optical SPDIF output (3.5 mm) combo jack. it most likely will be "red" when audio is active. 
    • Domanda , ma il tuo configplist lo ha settato cosi Gengik????
      Noto molte cose atipiche , tipo aperto con Clover configurator nella sezione ACPI il nome DSDT.aml NON è selezionato , quindi in teoria NON dovrebbe caricare il DSDT che hai in Clover ACPI Patch , se usi SSDT x la CPU NON dovrebbero servirti quelle personalizzazioni sempre in configplist sezione CPU ...
      Secondo me dovresti partire da un configplist pulito , xche sempre secondo me c'è rimasto delle schifezze di qualche tool x installare facile    EDIT
      Scaricando il configplist di jolly NOTO ha impostato +o- come intendevo fare io , sistemando quello  sopra elencato e bammmmm NON avvia , mi forniresti x favore Hack info che trovi nella mia firma ???
      Grazie   Ho creato un configplist , se vuoi provare , dovrebbe essere pulito da ogni impurità , se funziona dovrai adattarli tutte le tue personalizzazioni x il boot ..... config.plist.zip