Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
kericoul

Topic Shuttle SN25P - Leopard Kalyway

6 posts in this topic

Recommended Posts

Bonjour à tous,

Voici ma procédure pour installer dans les meilleures conditions Kalyway sur un Shuttle SN25P

Shuttle SN25P : http://eu.shuttle.com/fr/desktopdefault.as...169_read-10611/

Carte ethernet : Marvell® Alaska® 88E1111 PHY

Carte son : 7.1 Hardware Sound Controller (VIA Envy24PT)

Carte graphique : PNY Nvidia GeForce 7600GT 256Mo PCI-Express

Clavier NGS USB - Souris Logitech USB

Disque dur IDE 40Go Western Digital (installation de Leopard sur ce disque) uniquement

Câble réseau débranché

Désactiver la fonction Raid dans le bios si activé

Version de Leopard utilisée : Mac_OS_X_Leopard_10.5.1_for_AMD_SSE2_SSE3_32bits

Ne pas taper les guillemets " lors de la procédure

Graver Leopard sur un DVD, en faible vitesse de préférence (4x semble correct)

 

 

- Lancement de l'installation :

Configurer le bios afin de démarrer sur le DVD en premier

Insérer le DVD

Redémarrer le Shuttle

Une fois le démarrage effectué, taper sur la touche F8 à l'invitation

Taper "-v" afin de démarrer l'installation en mode v

L'installation commence

 

- Préparation et configuration du disque dur :

Une fois arrivé sur le panneau d'installation :

Aller dans : Utilitaire, Utilitaire de disque

Création de la partition

Effacer la partition Formater dans le format MacOS etendu journalisé

Donner un nom de volume à la partition

Effacer

Fermer

 

- Installation de Leopard :

 

Fenêtre Bienvenue, cliquer sur continuer (agree)

Choisir la partition, continuer

Cliquer sur Personnaliser puis décocher toutes les options (printers, X11...)

Terminer

Installer

 

Une fois l'installation terminée, le shuttle doit rebooter mais ne le fait pas. Faire un reset.

 

Configurer le bios pour que le démarrage se fasse sur le disque dur contenant Leopard :

Si cela ne fonctionne pas, rebooter sur le dvd, puis au boot, appuyer sur la touche F8 puis taper "–s"

Une fois le chargement effectué, taper ceci :

 

sudo -s

fdisk -e /dev/rdiskX => X est le n° du disque dur, donc 0 pour mon cas (1 seul disque dur)

update

f X => X est le n° de la partition d'installation de Leopard, donc 1 pour mon cas (une seule partition)

w

q

reboot

 

Maintenant, enlever le dvd, configurer le bios pour booter sur le dd

 

Résoudre le problème de "detection clavier + Do you Already Own Mac" qui tourne en rond :

 

 

Au boot, appuyer sur F8, puis taper –s

 

Une fois le chargement effectué, taper ceci :

/sbin/fsck -fy => initialier les etapes d'enregistrements

/sbin/mount -uw / => monter les périphériques

/passwd root => rentrer un mot de passe (ne pas l'oublier)

touch /var/db/.AppleSetupDone => fin de l'enregistrement

reboot

 

 

 

Redémarrer le pc, puis au boot, appuyer sur la touche F8 puis taper –x (mode sans echec)

 

Vous devez arrivez à l'écran de connexion.

Tapez "root" puis votre mot de passe précédemment rentré

 

Vous êtes arrivé sur Leopard :)

 

Installation de la carte reseau :

Sur votre PC muni de windows XP, telechargez le fichier nForceEthernetController.kext.zip (voir fin de ce post) puis le dézipper. Copier le fichier nForceEthernetController.kext sur une clé usb.

 

Démarrer sur Leopard en mode "–x" puis copiez le fichier nForceEthernetController.kext sur le bureau

 

Ouvrez le terminal (situé dans Applications)

Taper

sudo -s

tapez votre mot de passe root que vous n'avez pas oublié

cd Desktop

cp -R nForceEthernetController.kext /system/library/extensions/

chmod -R 755 /system/library/extensions/nForceEthernetController.kext

chown -R root:wheel /system/library/extensions/nForceEthernetController.kext

rm -f /system/library/extensions.*

diskutil repairpermissions /

exit

 

Fermer le terminal

 

Eteindre le PC et débrancher le câble d'alimentation, attendre 30 secondes (IMPORTANT!)

 

Redémarrez le PC.

 

Normalement, le démarrage se fait normalement sans avoir besoin de taper sur F8 (faîtes 2 fois entrer pour sauter les 30 secondes d'attente)

 

Bienvenue sous Leopard avec une connexion internet fonctionnelle

 

Pour l'installation de la carte graphique, je vous renvoie vers ce lien : http://forum.insanelymac.com/index.php?showtopic=47632

 

 

 

 

Problèmes non résolus pour le moment :

 

Pour l'installation de la carte audio, apparemment ce n'est pas possible à ce jour.

 

Si on clique sur "About this mac", ça plante et ça revient sur l'écran de connexion

 

Et... je n'ai pas encore eu le temps de tout tester :P

 

 

N'hésitez pas à poster vos commentaires, et à me corriger si erreur.

Je mettrais à jour la procédure sans soucis si changement.

Nota : je suis nouveau dans le monde du mac, allez-y molo

 

Kericoul

nForceEthernetController.kext.zip

Share this post


Link to post
Share on other sites

Hello there

 

I'm sorry to write in English, but I have a quick question. Where did you download "Mac_OS_X_Leopard_10.5.1_for_AMD_SSE2_SSE3_32bits" from?

 

Merci!

Share this post


Link to post
Share on other sites

Kericoul, sorry to post in english :( How did you cope with the no-sound problem?

I have a sn25p as well, and may convert it to hackintosh if it's usable as a mac!

Merci!

Share this post


Link to post
Share on other sites

The sound driver is not ready.

So, I've formated my shuttle for XP, it's more stable and a PC without sound, it's not terrible....

Is my tutorial is ok ?

 

Kericoul

Share this post


Link to post
Share on other sites

salut, et un grand merci pour ton tuto, car j'ai moi aussi un sn25P. Mais j'ai un problème.

Lors de l'installation ( que ce soit en mode v ou x ), une erreur apparait ( lié au firewire) et la la machine reboot, donc impossible d'aller plus loin. ( L'erreur apparait au chargement de tous les éléments au début)

Saurais tu d'ou sa viens ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • Hello MaLd0n,   Could you please make DSDT edits for my new Skylake desktop Lenovo M910t    RunMe files: https://www96.zippyshare.com/v/5bgqAiga/file.html
        Thank you very much in advance!
    • Have you tried adjusting the Khz in midi pref pane or editing the info plist to suit your needs. that sometimes corrects weird noise behavior.
    • Hello Mald0n:

      Nice to meet you, I have created a post about my problem on High Sierra before and I was redirected to this guide by Allan.

      As mentioned in the post, I was not able to get pass the login screen at initial boot and the system could not shutdown occasionally.

      However I solve the high temperature problem when I replace the clover folder you provide on first post, currently the cpu temperature is around 5x-6x'c after 10 mins up time.

      Attached is the clover folder, ioreg as well as the send me app, thanks for your help!

      p.s. I notice that your clover boot efi is a old traditional grey apple boot logo, Is there a version of modern dark and white logo one that I could replace with? Thank you!

      https://www.insanelymac.com/forum/topic/333867-cant-get-pass-2nd-stage-boot-logo-on-initial-boot-and-high-temperature/   My system:
      Gigabyte GA-X48-DQ6
      Core 2 Extreme QX9650 C0
      4 x Kingston DDR2 800ghz Ram
      Galaxy GTX460 1GB
      120GB SSD Leven JS500120C, high Sierra installed
      250GB seagate ST3250310AS
      250GB WDC WD2500JS-08NCB1
      File: https://drive.google.com/file/d/1_k3_jxvzGaLfDzin0zSAUT5ml16Hq15c/view?usp=sharing      
    •   Still garbled sound in earphone. The speaker is loud as previous. louder than 2.9.1   
    • Up for https://sourceforge.net/p/cloverefiboot/wiki,


×