Jump to content

compile bsd source in leopard


5 posts in this topic

Recommended Posts



Just wondering how's it done.. I know theres some ./configure / make / makeinstall cmds involved but not sure on the flags etc. I'm hoping to be able to use this: http://pldaniels.com/hpgl-dxf/ is there a noobs guide on how to do this about? Any help would be much appreciated!




1) Download hpgl-dxf-0.0.2.tar.gz from pldaniels.com


2) expand to desktop to get a folder hpgl-dxf-0.0.2


3) Open makefile with TextEdit

Instructions inside:

all: hpgl-dxf

hpgl-dxf: hpgl-dxf.c

gcc -Wall hpgl-dxf.c -o hpgl-dxf

install: hpgl-dxf

cp hpgl-dxf /usr/local/bin


rm hpgl-dxf *.o


4) Open Terminal


5) In terminal:

cd ~/Desktop/hpgl-dxf-0.0.2

~/Desktop/hpgl-dxf-0.0.2 : gcc -Wall hpgl-dxf.c -o hpgl-dxf

hpgl-dxf.c: In function ‘main’:

hpgl-dxf.c:313: warning: format ‘%d’ expects type ‘int’, but argument 4 has type ‘size_t’

hpgl-dxf.c:342: warning: format ‘%d’ expects type ‘int’, but argument 3 has type ‘size_t’

hpgl-dxf.c:342: warning: format ‘%d’ expects type ‘int’, but argument 4 has type ‘size_t’

~/Desktop/hpgl-dxf-0.0.2 : chmod +x ~/Desktop/hpgl-dxf-0.0.2/hpgl-dxf


6) In folder hpgl-dxf-0.0.2 you will get a file hpgl-dxf, your binary.


7) I guess but not sure that you will need the Developer Tools installed


As you can see there is 3 warnings, i don't think is important in case tha binary don't works,

you will have to modify the source to remove there warnings.



Link to comment
Share on other sites

Hi Alain...


Many thanks! -_- works just fine!!


I've just found something else to try (it's mentioned on the hpgl-dxf website): http://www.ribbonsoft.com/qcad_downloads.html - check the open source community edition. On this page http://zeitkunst.org/blog/2007/02/13/compi...os-x-with-fink/ it shows how to compile but with using Fink - Have you used that in Leopard?


Would be great to get this app going too :)


Thanks again for the hpgl-dxf bianry tho...



Link to comment
Share on other sites




Yeh, i tried the tiger version but even tho it runs in Leo i noticed some probs (display not updating or showing contents when zooming until the window is resized for instance*). Was just wondering if we could compile a Leo version from the sources as the demo is limited and i'd like to be able to print out without restrictions - looks like i need to install tiger to compile arrrghh!



Hohum... thanks for effort tho! :blink:


* Just found that it was a QuartzGL issue - disabling that with quartz debug solved the prob.

Link to comment
Share on other sites


  • Create New...