Jump to content

Invalid or unsupported executable format?


1 post in this topic

Recommended Posts

I am trying to install mac osx leopard (kalyway) on my laptop. in order of installed, i have vista, ubuntu gutsy, and leopard (kalyway).


Vista and ubuntu work fine with the grub boot loader, but when i install mac osx in another partition (all os's on one hard drive), it doesnt appear on the grub boot loader.


So i changed my menu.lst to have mac osx as another option, with various lines of code, but with no luck (root (hd0,2), makeactive, chainloader +1 etc and other variations).

I think it finds the partition, but cant boot, the error is : invalid or unsupported executable format. I have tried code such as makedefault which worked for some, but my system simply reboots.


I have read about some mapping, but with that is where they have 2 drives, where as all of my os's are on one.


Tried chainloader --force +1, but tries to load stage2, then get grub 18 error, rootnoverify does nothing for me ;)


Can anyone help?



Link to comment
Share on other sites


  • Create New...