Jump to content

How to get working shutdown Leopard 10.5.1 on Gigabyte 965P-DS3 rev.2


4 posts in this topic

Recommended Posts

I don't understand why, but it seems it works only for me :-( So this tuto is only for your own risk only!



I saw here many people who tried to find howto get working sleep and poweroff. However I met with this problem on my mobo Gigabyte 965P-DS3 rev.2 I've discused it with Netkas (many thanks to netkas from me!), then I find out idea how it should be possible to manage it to get working shutdown.

OK let's get started:

1. get sleep kernel mach_sleep from irc.osx86.hu #10.5 and save it on your desktop as mach_kernel

2. backup your kernel on / via: sudo cp /mach_kernel /mach_kernel.old

3. replace your kernel with new one:

sudo cp -f ~/Desktop/mach_kernel /

sudo chown root:wheel /mach_kernel*

sudo chmod 644 /mach_kernel*

4. in case of problems use F8 before boot and write mach_kernel.old

5. Download AppleACPIPlatform.kext.zip and IOACPIFamily.kext.zip and unpack on your desktop.

6. Backup kexts (AppleACPIPlatform.kext, IOACPIFamily.kext) in your /System/Library/Extensions and then replace via:

sudo cp -r ~/Desktop/AppleACPIPlatform.kext/ /System/Library/Extensions

sudo cp -r ~/Desktop/IOACPIFamily.kext/ /System/Library/Extensions

sudo rm -r /System/Library/Extensions.mkext

sudo chown -R root:wheel /System/Library/Extensions/IOACPIFamily.kext/

sudo chown -R root:wheel /System/Library/Extensions/AppleACPIPlatform.kext/


After reboot it should work, for me it works. AppleACPIPlatform.kext, IOACPIFamily.kext are used from 10.4.8. Also it can work on other mobos, where worked shutdown on 10.4.x and on 10.5.x doesn't..

As you can see you can used kexts from Mac OS on which worked shutdown... So share your experiences, I hope it help.

Link to comment
Share on other sites


  • Create New...