Jump to content

Dell Dimension 4600: iATKOS_1.0i_to_1.0ir2 working


10 posts in this topic

Recommended Posts

Reporting succesfull install on P4 sse2 using Iatkos 10.5.1 iATKOS_v1.0ir2.ppf patch. Install went like a breeze,, sound and graphics working out of box.


Excellent work guys!!!!!!





Processor Name: Intel® Pentium® 4 CPU

Processor Speed: 3.07 GHz

Processor Features: SSE SSE2

Memory: 1.5 GB

Bus Speed: 2.13 GHz

Geforce FX 5200: fully working (QE/CI with nvinject driver from install) at last!

WLAN ASUS WL-167g USB2.0 WLAN Adapter (pen-type):working with ralink usb driver

ASUS CRW-5232A3: working

NEC DVD+RW ND-1100A: working

PS2 standard dell keyboard: working

USB mouse: working

USB scanner LIDE60 : working with standard canon drivers

USB HP deskjet: working with HP DeskJet Series, 1.3

Sound AC97 onboard sound: working

Link to comment
Share on other sites

  • 2 weeks later...

Same system here- it couldn't be easier to install on this thing! Most of it works right out of the box!




Dell Dimension 4600

Intel Pentium 4, 2.86ghz - SSE2

nVidia GeForce FX5200 (128mb)

2.5gb RAM


I posted this on the Uphuck forums, but for peeps searching here:


I searched around on multiple boards for a computer similar to mine to see if I could do iAtkos on a SSE2 successfully with the new patched DVD. The below installation method worked for me without a hitch! I didn't have to do the safe boot afterward (step 7) though.


I originally had a triple boot in 3 partitions on one internal hard drive (XP/Tiger/Ubuntu) using the Acronis OS Selector method. Tiger was running great, and was my main OS, but wanted to try Leopard, so I erased the Ubuntu partitions and installed iAtkos on partition 3.


No problems whatsoever, and I was expecting my triple boot to go away, but no! Acronis still loaded afterward, and I was able to select XP/Tiger/Leopard! Also, all resolutions work for the graphics out of the box, as do internet and sound. The whole install took less than an hour.


With all the unsuccessful installs reported, I was worried that I may not be able to do this, but it worked on the first try! No more messing around with kexts and such to Scotch tape together a working system! Worked better and easier than any Tiger DVD I've ever used. Thank you Uphuck team for iAtkos!


Don't believe the hype! iAtkos works on Pentium 4 SSE2 machines!



Quoted from Uphuck forum's unix_eng:



1. Use GParted Live cd and create an empty partition then click apply.

2. Next while still in GParted Live set the boot flag to boot that partition.

3. Exit and reboot with a "Patched" version iATKOS 1.0 R2.

4. In the Mac OS X Installer under Utilities choose the Disk utilities and erase the partition as a HFS Journal filesystem. (Make sure the partition is set to MBR and not GUID or Apple Partition Map.)

5. Select the install drive and then click next.

6. Next under the install summary choose custom from the menu and then choose the following stuff -

a. iATKOS system will be check by default.

b. Bootloader = Darwin boot (EFI is not working for me yet).

c. Patches = SSE2 and SSE3 Kernel + Remove CPUPowerManagment Driver

d. Drivers = NVidia Inject 128mb Driver.

e. System = SATA + AppleSMBIOS.kext netkas

f. Network = Intel Pro/100VE + Broadcom + Wireless Patch (Do Not use IO80211 Family.kext it does not work for this setup and some others.

g. Now start the install.


7. After Install boot the machine as follows -

a. F8

b. Then at the boot prompt issue a -x EXAMPLE Boot: -x This boots safe mode as I had an issue with the cool music and screen when it came time to do settings migration.

c. at that point you should be in safe mode so login for a sec then reboot as normal.


Link to comment
Share on other sites

  • 5 weeks later...

Hello :-)

@ trymac: i have a 4600i and can get sound via the blacksound jack at the sound panel (backside). How do you get your sound out of?

@tonymacx86: what is the last point c for? Why boot in safe mode for a sec?


Now and then i have this problem when i reboot or just start the machine, it switches off again if it comes to boot the osx (darwin). Its frustrating and i dont know how start the search for the problem. If i boot in safemode, it always works but not on normal boot.

Link to comment
Share on other sites

yes because my graphiccard isnt working with full acceleration. With the 5200 and tiger it worked and now i have to figure something out, to get wether another card or wait for a real mac.

concerning the sound: Dont know if it is working, if we have to use a different jack as it is meant...know what i mean?

For leopard it is more difficult with a older rig. So perhaps its time for some new stuff... :blink:

Link to comment
Share on other sites

i changed the applesmbios.kext with the netkas one and my about apple doesn't crash anymore and it seems to effect my network thing positive. Before it was more like Russian roulette, will i have network or not. The only thing what doesn't work is this graphic card. What CG with AGP does work? It shouldn't be something like a gf5200. Are there some 7900er cards agp which does work with full acceleration? OK, ok i know the answer is somewhere in this forum, i will look for it too.

Link to comment
Share on other sites

  • 10 months later...
Reviving an old thread....

Any luck with iATKOS 5i 10.5.5?

Crashes on install (5 minutes after checking CD)


Didn't try iAtkos, but had a very pain free install with the iPC OSx86 10.5.6 distro. Used EFI Studio to get my 6800GT working, sound worked out of the box via the black connector. Ethernet required a hack. Otherwise plain sailing ... :D

Link to comment
Share on other sites


  • Create New...