Jump to content



10 posts in this topic

Recommended Posts

I wrote this tut for all the people that, like myself (a newbie on mac), spend hours to get a 8800GT to work on my Leopard..After installing over and over again....

Maybe thing are double or not really needed to do this way but i just wrote exactly all the steps I did to finally get a working 8800GT on my Leo..

I Want to thank all other people on the form for all their info provided... I just put their stuff together to make everything a bit more clear for myself and hopefully also for you....

If things don't work just search this forum, because it can depend also on your system specs or for many other reasons!! Good luck!!


My System is:

X38-DQ6 gigabyte mainboard

Q6600 CPU

4GB Team Extreme memory 800

2-sata (Because of Raid) On intel ICH9R chip

1-ide (Leopard is installed on that one) AHCI On gigabyte SATA 2 chip



Files needed:



http://forum.insanelymac.com/index.php?showtopic=33007 (46.35kb)

<mod edit, torrent link removed, READ THE RULES PEOPLE: http://forum.insanelymac.com/index.php?act=boardrules >





If you re-install Leopard again because of testing etc create each time all partitions new again (otherwice system will hang after install finished and boots->gray screen)


Just for info: for people don't knowing... "xxxxx.kext" are actually folders and not files and to open you can do that by clicking right on it and choose: "Show Package Content"


Install from scratch:


First change your bios settings according:


To your CPU CONFIGURATION section :

MAX CPUID VALUE Limit (or similar) : Disabled

Vanderpool or virtualization : Disabled

CPU TM Function: Enabled

Excecute Disable Bit (or called NX or XD on some mobos) : Enabled (the most important, if not enabled the result is reboot loop with vanilla kernel)


To your POWER section:

ACPI 2.0 Support : Enabled

ACPI APIC : Enabled


Install the Kalyway dvd -> press F8 and type: Vanilla

....wait... when Leo shows up:

Open disk-utility and make 2 partions named:

->Leopard -> as HFS+ Journaled partition

->Click options and select: GUID

->Second partition: as for example DOS to swap files between windows and mac (incase of dualboot)


After partition is made close disk utility.

->Click continue

->Choose Leopard partition

->Click continue

->Click Customize

->Check first box "Vanilla kernel and EFI" both or select main box (this will check both inside)

->Check if available your soundcard kexts


if your (onboard) soundcard is not mentioned don't check anything!! I have a ALC889A which was not mentioned. If you have the same one please check for a working soundcard:


Support for other soundcards: you can find trought this page also!


->Click continue

Installation starts....finish in about 25 minutes....

Move your mouse every few minutes (i did each 2 min) to prevent that system will not respond)

After installation finish reboot.



Answer all required questions.

As soon leopard is started:

->Install plisteditpro (needed to modify Natit.kext later!!)

->Open Kext-helper (see applications, where you just added plisteditpro) (info usage kext-helper see: http://forum.insanelymac.com/index.php?showtopic=54098)

->Extract the two zip files (do this on your leopard, not windows!!)

->Drag/drop the first kext from the extracted geforce_1052_kext unzipped folder into the kext-helper

->Enter your password in the password field (you created during your first login into leopard)

->Click on: EASY INSTALL

->After install finished -> click: Clear All

->Drag/drop the second kext from the extracted geforce_1052_kext unzipped folder into the kext-helper

->Click on: EASY INSTALL

->After install finished -> click: Clear All


Do all the kext from geforce_1052_kext. unzipped folder that way!


After you finsihed all kexts in the folder geforce_1052_kext unzipped folder do the following:


->drag/drop Natit.kext into the kext-helper

->Click on: EASY INSTALL

->After install finished -> click: Clear All


->Close kext-helper


->Click your Leopard disk on your desktop

->If there is...Delete the folder: System/Frameworks/OpenGl.frameworks

->Copy the folder OpenGL.framework (which you extracted from the zip file "OpenGL.framework-1052.zip") into the directory: System/Frameworks/


->Now the more trickier part:

You need to modify the Natit.kext and than to save it!! For this you need the correct user rights otherwice you are not able to save your changes!



To have the user right:

->Click right on the folder Systems/Extensions and click on "Get Info"

->On the poping-up screen is on the bottom a sharing & permissions:

->Here you can add yourself (incase your not in this list)...under privilege click read/write

->Notice the lock symbol on the bottom-right!! You can click it to add a user and change user right (use your user password here)

->If later you have the same problem with any file or folder do the same thing again to get permissions!!

->Go to System/Extensions/Natit.kext and click right mouse button on it

->Choose in the menu: "Show Package Content"

->Window pops-up

->Open folder: Contents

->Now you click twice on info.plist

->plisteditPro (which we installed before) will now open this file!

->Make the following changes for your 8800GT:

->Look for (somewhere in the beginning of the document):



<string> 0ffx blabla ....some long code here..... </string>


replace with:




->Scroll whole the way down

->Look for:


<data>BAABAAA etc etc etc</data>


->add below as follow:




->So now it should look like:


<data>BAABAAA etc etc etc</data>




->Click on the red dot on the right top to close the file and when it asks to save....SAVE IT... If you have no permissions check the part above the assign correct user rights!!


Now the last part:


->Open Terminal (found in Applications) and excute the following lines:


sudo chown -R root:wheel /System/Library/Extensions/*

sudo chown -R root:wheel /System/Library/Frameworks/*

sudo chmod -R 755 /System/Library/Extensions/*

sudo chmod -R 755 /System/Library/Frameworks/*


close terminal and reboot and hope everything goes fine.... :)

Link to comment
Share on other sites

Hi Maxim1,Just read your post. i have to mention that i had exactly the same issue also ones. I had a black screen with mouse-pointer hanging in the top left..I just did everything over again. So just checked all my bios settings again, made the partition again and installed kalyway (without any video kexts from the kaly-cd) and installed. after installation did the whole process over again... and than it worked out fine... only dont know why i had the issue before.. maybe went something wrong during updating kexts with kext-helper or maybe the openGL.frameworks...If you have specific question just let me know and i will try to help you out..PS: forgot to mention...the last part is important:->Open Terminal (found in Applications) and excute the following lines:sudo chown -R root:wheel /System/Library/Extensions/*sudo chown -R root:wheel /System/Library/Frameworks/*sudo chmod -R 755 /System/Library/Extensions/*sudo chmod -R 755 /System/Library/Frameworks/*... if i remember right, you will have that issue as mentioned above...

Link to comment
Share on other sites

Hi Corleone, you could be right I only managed to get it to load after a tortures night of upgrading and trying to dual boot with xp. Before I try again I need to under stand how to dual boot properly.

I struggled to get windows back on to my machine and it was due to a faulty hard drive which i believe became faulty after numerous attempts to load win xp and Leo.

Any information you have on dual booting will be gratefull



Q6600 CPU

1 SATA HD 500gb (XP)



all runing on ACHI mode

Link to comment
Share on other sites

To Maxim1,

I struggle also a lot to get dual boot working, but finally got it working with standard booting in Leopard.

I don't know if its sufficient for your needs but i will explain what i have done....

What i have now is:

2 physical SATA disk both AHCI on the same controller (example both on ICH9) with on disk-1 Leopard and on disk-2 Vista x64:

Standard Booting (meaning: in your bios this disk is set to primary which is in my case disk-1) from disk-1 into Leopard, with using VM-ware-Fusion to start Vista x64

inside Leopard.

Or I set disk-2 as primary disk in my bios to boot directly into Vista, and (on this moment) without having the option to choose between Leopard or Vista.

I still need to find a solution for this.... Maybe with the chain0 file from the brazilmac-patch this should be possible

Will come back on that as soon as i got that working..



....Need vista for programming purposes....And don't want to reboot into Vista all the time for testing in Windows enviornment

Check google and torrents to get VMWare Fusion v1.1 to do this.


What I have done:

First check which disk is your primary disk in your bios and install the leopard stuff on that disk. As soon the leopard CD has finished loading I splitted my primary


HDD (disk-1) into 2 partition using disk-utility:

The first partition, I selected as HFS+ Journaled partition, and I named it Leopard and choose in options "GUID".

The second partition on the same physical disk you can format whatever you like..


Then HDD (disk-2) see between dashed-lines:

I followed this guide: http://forum.insanelymac.com/lofiversion/i...php/t73952.html

But ONLY followed this part:


Simply take advantage of Disk Utilities Partitioner and make at least a 5gb partition first formatted with Mac OS Ext. also select GUID in options. ( if you get failing while partitioning reboot in single user mode and type the first line it says i beileve it is /sbin/fsck -fy and that will repair the disk and try partitioning again) after it is done exit out of disk utility and open it back up and click your new "Boot camp" partition and erase it and format it with MS-DOS(FAT) keep its name boot camp.

Make if you like also a second partition again also on this disk-2



Then just before you start installing Leopard dont forget to check the first checkbox by clicking the customize button to install also the Vanilla kernel and EFI stuff. The last checkbox, check efi_guid and not mbr (but if im right it is already standard checked).

When installation has been finished reboot and let Leopard to load from disk-1, pass all question etc (did this just to make sure my install went ok).

Then reboot again, but now load into your bios first by pressing delete.

Than set disk-2 as primary disk in your bios and save this setting. Reboot from you Windows CD (I used vista Don't know about XP)

but if XP: press F6 if you need to load SATA driver in case you install on a SATA disk...

Continue installation and choose disk-2 (which you just put as your primary disk in your bios) first partition for installation, if asking, you can re format the partition in vista to NTFS it wont hurt anything. Finish the installation completely untill you have your windows desktop in front of you..Your windows should work good..

So now:

if you boot from disk-1 (set primary in bios) it will load Leopard and you can you use VMWare v1.1 to start vista within leopard

if you boot from disk-2 (set primary in bios) it will load Windows (no chose of OS)


Final note: To get VMWare Fusion to work correctly I noticed that i had first to install the VGA-card correctly in leopard, meaning with the correct kexts. and in the bios I had to enable back again this option: again Vanderpool or virtualization : Disabled (you disabled this before... to install Leopard).


I know from other people on the forum that if you want to achieve the same dualboot-way from just one physical disk it causes problems to correctly dual-boot and to use VMware Fusion... So just started directly with 2 physical disks.


As last what I have read on other forums VMWare supports WinXP 64 and vista X64.... Meaning you can boot those two windows from VMWare but it will run as a 32bit not as 64... More on this check:




By the way after you launches VMWare the first time it should automatically recognize your boot-camp partition and it should be mentioned in that window


PS: like to mention that when i was trying to install vista on disk-2 it didn't install on it because it was saying "can not find a correct volume to install" so couldn't install on that partition (disk-2 partition: Boot Camp) not even after formatting it as NTFS....which was driving me nuts... Finally after putting disk-2 as primary disk in bios (when i already finished installing leopard on disk-1 set as primary) it recognized and started to install vista on the Boot Camp partition.


To spanakorizo:

I saw the past few days already your posts about this but didn't have time yet to really check that problem.

Untill now i only used several browser and VMWare to boot Vista with.

I spent a lot of time to get this dualboot-way to work also with VMware..

As soon i have done that I will come back on it... shortly probably after this weekend when i finished installing other software needed for programming in Leo..

Link to comment
Share on other sites

  • 2 weeks later...

Tried several times, all I did get was a black screen. :)


Sorry, but I think the following solution is much easier and better:




Got a 8800GT with 256 MB RAM and Kalyways 10.5.1. Did play World of Warcraft several hours now with a resolution of 1600 x 1200 without a crash. Only small annoyance are sometimes flickering nameplates, but I can life with that.


I am optimistic with 10.5.2 everything will run perfect. Have fun! :)

Link to comment
Share on other sites

Corleone, with your method do you get full 512MB? At the moment I have my 8800GT working using the method foureyes linked to which is incredibly simple but only 256MB.


I also have high hopes for 10.5.2, let's hope Apple doesn't try to break our Hackintoshes.

Link to comment
Share on other sites

Thanks Corleone!


You helped me a lot to don't waste too much time in try/error process.


I have everything working perfectly by now with my GA-X38-DQ6 and Gigabyte 8800GT!

Now I'm just hoping to get TVOut with 10.5.2 final release drivers.


Thanks again!

Link to comment
Share on other sites

  • 2 weeks later...

  • Create New...