Jump to content

Problem dual booting- won't let me boot


1 post in this topic

Recommended Posts

I'm new to this so I don't know too much about it, but I'll explain the scenario and any help would be appreciated...


I'm working on a Dell E1505-Intel Core duo 1.6ghz-Radeon Mobility x1400

I wiped it and made a winxp partition first, saving the other half of the harddrive to format for ToH RC2.

I formatted that partition as a Fat32/ShagOS, then when the installer came up, used disk utilities to put it in OS Journaled.

Successfully INSTALLED and patched, which is as far as I got.


I tried using Acronis to locate the OS so I could boot, doesn't work, it tells me there's no OS on the partition...


I tried booting from the DVD as another forum described and it just brings me to the installer.


I attempted to do a fix from another post which I'll describe here :


If you have problems booting into leopard without the DVD in, follow directions below:


Somehow, The Leopard Installation process does no make the partition bootable. You need to do this yourself (working on a fix). Within Leopard:


Open DiskUtils (applications > Utilities)

Click on the Leopard Partition and click Info

Write down what disk it is: diskXsx (example Disk0s1)

Close DiskUtils


· Open up terminal. This is what you do (quoted text is what terminal will show after the commands you enter):


sudo cp /Volumes/PATCHER/files/i386/boot1h /usr/standalone/i386/ (replace if prompted)

sudo fdisk -e /dev/rdiskX ( replace X and x with the disk/partition you wrote down above)'

fdisk: 1> update

'Machine code updated.'

fdisk:*1> f 1

'Partition 1 marked active.'

fdisk:*1> w

'Device could not be accessed exclusively.'

A reboot will be needed for changes to take effect. OK? [n] y

'Writing MBR at offset 0.'

fdisk: 1> q


Reboot computer again with DVD.. boot the DVD.

After welcome and Language.. from Utilites

Open DiskUtils

Click on the Leopard Partition and click Info

Write down what disk it is on: diskXsx (example Disk0s1 could have changed from above)

Now click the Unmount button

Close DiskUtil and open Terminal


· Ok, now lets put the file “boot1h” in the beginning of the partition: In terminal, type:

cd /Volumes/PATCHER/i386 folder

Then type this:

sudo dd if=boot1h of=/dev/rdiskXsx bs=512 count=1 (replace X's with disk you wrote down above

** if you get error of no dd that is ok.. move on)

· Now, lets run the startup tool to embed the boot code:

cd /Volumes/PATCHER/files and then type this:

sudo startupfiletool -v /dev/rdiskXsx boot

· And last, lets give the pope’s blessing to the partition:

sudo bless -device /dev/diskXsx -setBoot –verbose


(Credits to

nateleav76 for the above)

BUUUTTT, I can only attempt that in the disk utility on the installer. I can't do it from Leopard because I can't boot it.


Also, my dad mentioned that I might want to try making it a fat32 with a Unix file type instead of ShagOS, but I haven't tried that.


Any help would be appreciated, thanks.

Link to comment
Share on other sites


  • Create New...