Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
JuanDiego

Before you begin "There is no keyboard connected to your computer"

36 posts in this topic

Recommended Posts

I did have same thing (win 7 and Lion dual boot in same HD), however, I had Snow Leopard installed using Vmware but I installed Lion using USB thumb so only changed there. However, I did change those two lines booting into single user mode. Did you do like I said to remove those two lines from that Info.plist? The file must be there otherwise there is something wrong as Info.plist defines it's properties. Are you using PS/2 or USB keyboard? I am assuming it's a laptop integrated keyboard. I am not sure about AppleUSBOHCI.kext but looks like it has got to do something with USB but not sure.

 

As i said before, the info.plist file is completely empty. There is nothing in it.

Share this post


Link to post
Share on other sites

This method is not as good as the ones mentioned above but this worked for me: 1. Boot into Lion installation media (in my case a [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] drive), 2. Open Terminal, 3. Type "cd /Volumes/(Insert drive name)/var/db", 4. Type "touch .AppleSetupDone", 5. Type "resetpassword" 6. Select your drive at the top and change root password in dialog, 7. Reboot, 8. Log on as "root" 9. Create new user account from System Preferences.

Share this post


Link to post
Share on other sites

Well I can say that while using JaS OS 10.4.8 I got a similar problem where it got fixed the VoodooPS2. But it was in the old days.

 

Currently I was facing same issue in iATKOS L2. But I got it working with ApplePS2 stock with L2 itself. The most simple solution will be using an USB Keyboard to login & use the PS2 kext from install media itself.

Share this post


Link to post
Share on other sites

Hi all, Same issue:

 

Photo-0020.jpg

 

 

 

 

There is various solutions here, but I am a noob to this.

 

What actually works?

 

could we have a step by step guide?

 

 

Im guessing first few steps:

 

1> Boot from installation media.

2> Instead of clicking continue setup, choose system > Terminal

3> type something in terminal......

 

I have no idea what it would be, or what files i need.

 

Im guessing this step by step simplified guide for the no keyboard issue, could stop any future posts?

 

 

Many Thanks for anyone who still has any patience left and is able to do this. Im sure your all fed up of hearing this over and over.

 

for those unsure, this is how to get to terminal with your installation media:

 

Photo-0021-1.jpg

 

 

all we need now is confirmation what to do from here

Share this post


Link to post
Share on other sites

To fix this problem:

 

1. Go to terminal and type:

cd /Volumes/Your Partition/var/db

touch .AppleSetupDone

resetpassword

2. Then, insert a new password for root user.

3. Reboot to the installed OS-X and login as root.

 

1. Copy Patched AppleACPIPS2Nub.kext and ApplePS2Controller.kext to your installation drive.

2. Go to terminal and type:

cp AppleACPIPS2Nub.kext /Volumes/Your Partition/System/Library/Extensions/AppleACPIPS2Nub.kext

cp ApplePS2Controller.kext /Volumes/Your Partition/System/Library/Extensions/ApplePS2Controller.kext

3. Reboot to the installed OS-X and do the setup.

Share this post


Link to post
Share on other sites

Hello to all!

 

I have made the experience, that it is enough, after having done the install media, to copy the proper kexts for keyboard and touchpad to S/L/E of it and repair the permissons on install media with for example KextWizzard. Then you have during the install working keyboard and touchpad. During the install the before mentioned kexts are automaticly installed to your new installation. At prompt of bootloader you ever have to set flag -f during installtion. No external keyboard or mouse are needed on the most laptops. I have done it like this everytime. For me this solution has ever worked.

 

Have fun!

Share this post


Link to post
Share on other sites

There were some Voodoo PS/2 kexts I found for my laptop's keyboard and trackpad.  All I had to do was copy those kexts into place!  Sometimes post-installation, I have to plug in a USB mouse and USB keyboard so I can take this kind of action.  Runs like a champ!  The Command key is usually between Windows/Left-Alt.

Share this post


Link to post
Share on other sites

@level70steve

 

All you have to do to get a working keyboard at first loggin at you new installation is to store your ps2.kexts in a folder of the root of your install device.

 

For example the name of this folder is kexts an your install hd partiton is named ML.

 

After installation on harddrive has finished, reboot from your usb install device, fire up terminal and type in this command:

 

cp -r /kexts/*.kext /volumes/ML/system/library/extensions/

(You can place in the before mentioned kext folder also fakesmc.kext, and if needed nullcpupowermanagement.kext, to copy this kexts also over to your hd install)

 

Then you can close terminal and repair with diskutility permissions of ML and you are done. No need of usb keyboard or mouse anymore. Then you can reboot and finish your installation as normally.

 

Have fun.

Share this post


Link to post
Share on other sites

I don't know if I am alone using this simple approach, but I didn't use any patches. I simply pressed spacebar twice to install from USB and thats all. The Connect Bluetooth Keyboard popup appears on every OS update (sometimes even blocking the login area), but it can be moved and when OS is done updating there are no problems (e.g OS update from 10.9.2 to 10.9.3).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×